Answers column is in the wrong order in person's "Most active in" table

Bug #127489 reported by Matthew Paul Thomas on 2007-07-22
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Jamal Fanaian

Bug Description

A page such as <https://launchpad.net/~siretart> shows that in the "Most active in" table, the Answers column is before the Bugs column. This is wrong, because in the application tabs the Answers column comes after all the others.

Related branches

Changed in launchpad:
importance: Undecided → Low
status: New → Confirmed
Jamal Fanaian (jamalta) on 2009-07-31
Changed in launchpad-foundations:
assignee: nobody → Jamal Fanaian (jamalfanaian)
Changed in launchpad-foundations:
status: Triaged → Fix Committed
affects: launchpad-foundations → launchpad-registry
Changed in launchpad-registry:
status: Fix Committed → Triaged
milestone: none → 3.0
Diogo Matsubara (matsubara) wrote :

Re-opened since the sort order is not following the application tabs sort order. Blueprint icons appear after answer tracker icons.

The hard coded dict to fix this bug contains blueprints and specs. blueprints should be removed from this sort dict.

+ sort = {'code': 0, 'bugs': 1, 'blueprints': 2, 'translations': 3,
+ 'answers': 4, 'specs': 5, 'soyuz': 6}
+ return sorted(categories, key=lambda category: sort[category.name])

Diogo Matsubara (matsubara) wrote :

Retargeted to 3.1.10 since this is not release critical and can be fixed later.

Changed in launchpad-registry:
milestone: 3.0 → 3.1.10
Jamal Fanaian (jamalta) wrote :

Diogo,

I have committed a fix to the original branch (http://code.launchpad.net/~jamalta/launchpad/bug-127489). You didn't mention anything regarding a merge proposal so let me know if I need to go through that process again.

Changed in launchpad-registry:
status: Triaged → Fix Committed
Curtis Hovey (sinzui) on 2009-09-25
tags: added: post-3-ui-cleanup
Curtis Hovey (sinzui) wrote :

Hi Jamal. Thanks for working on this. We use the Fix Committed state to indicate the fix is merged into devel. Would you like to propose your branch for review: https://code.edge.launchpad.net/~jamalta/launchpad/bug-127489/+register-merge . I ahve not had time to look at your branch, but I can review it.

Changed in launchpad-registry:
status: Fix Committed → In Progress
Edwin Grubbs (edwin-grubbs) wrote :
Changed in launchpad-registry:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2009-11-06
Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers