people use the "Register branch" form to request code imports

Bug #115965 reported by Martin Pitt
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Low
Curtis Hovey

Bug Description

"Register branch" currently only imports remote bzr branches. Especially for working on Debian projects which are maintained on svn.debian.org it would be very helpful to directly import those into a bzr branch without having to bother you with an answer ticket.

Tags: lp-code qa-ok

Related branches

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

I don't think we're ever going to allow the completely automatic importing of stuff from SVN.

We are working on making the process easier (for you and for us) and more transparent though.

BTW, you shouldn't file an answer ticket for this sort of thing: on the page 'trunk' series for the product you should be able to 'edit source' and put the details there.

Revision history for this message
David Allouche (ddaa) wrote :

There's an interesting aspect in this bug. Some people DO use "Register branch" form to request imports in the past. For example:

 * https://code.launchpad.net/~bluviolin/torapplet/main -> http://svn.berlios.de/svnroot/repos/torapplet/trunk
 * https://code.launchpad.net/~cjcollier/dnpb/cjac -> http://dnpb.svn.sourceforge.net/svnroot/dnpb/branches/Prebuild-cjac
 * https://code.launchpad.net/~mark-baas123/congabonga/trunk -> http://svn.gna.org/viewcvs/congabonga/trunk
 * https://code.launchpad.net/~aquette/nut/nut--trunk -> http://svn.debian.org/wsvn/nut/trunk
 * And more...

I do not think we can sanely fix that until CodeImports are separated from ProductSeries. But even when it's done, I am not sure how we could avoid the confusion.

Revision history for this message
Andrew Bennetts (spiv) wrote : Re: [Bug 115965] Re: "Register branch" should work with remote CVS/SVN

David Allouche wrote:
> There's an interesting aspect in this bug. Some people DO use "Register
> branch" form to request imports in the past. For example:
>
[...]
>
> I do not think we can sanely fix that until CodeImports are separated
> from ProductSeries. But even when it's done, I am not sure how we could
> avoid the confusion.

Why not just have the one form, and then when the user enters a URL quickly
inspect the URL and figure out if it's a bzr branch or not. If not, walk the
user through the more complex registration for CVS/SVN imports. If it is a bzr
branch, then you're done.

Revision history for this message
David Allouche (ddaa) wrote :

I do not think we'll want the application servers to connect to arbitrary, user specified, servers over the internet.

Revision history for this message
Jonathan Lange (jml) wrote :

David, I'm not sure how your comment follows on from Andrew's.

Having one form sounds like a good idea to me.

Marking as 'Incomplete' until we've decided what to do with it.

Changed in launchpad-bazaar:
assignee: nobody → ddaa
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Andrew Bennetts (spiv) wrote :

I think David is objecting to the idea that the lpnet servers should access arbitrary URLs in response to form submissions.

The problem is URLs like "http://example.com/src-repo/my-project/trunk". WIthout accessing the URL or more information from the user, it's ambiguous whether the URL is a Bazaar branch or an SVN branch.

(URLs of the form "svn://..." aren't a problem for this idea, though.)

I do see David's point; we already have systems intended to go hit foreign hosts to mirror/import branches, and they have appropriate reverse DNS so that we show up sensibly in log files, the sysadmins have set the firewalls appropriately, etc.

But if we could accomodate this somehow I think the user experience would be much better. All we'd need to do is a HEAD request on URL + '.bzr/format'. If it exists, it's Bazaar, no more user input needed. If it isn't, prompt the user for more details about SVN import.

We don't have to have the lpnet servers do the actual probing. They could poke another internal system to do it for them, which would deal with the reverse DNS and firewall issues (at the cost of the extra complexity of a new moving part). There's also the question of what to do about unreachable hosts and other timeouts; probably a page saying "sorry we couldn't autodetect, please choose the source control system manually: (*) Bazaar, ( ) Subversion, ..." (we're effectively making them choose manually already after all). Or refuse the registration, because it's probably a mistyped URL, and we can't do anything with it anyway.

It's tempting to guess purely on the string of the URL itself; if it contains the regex "\<svn\>" it's probably an SVN branch, and if not probably not, but we'd need some easy way to override the guess because that won't be 100% reliable. It would have caught all of the examples in comment #2 though. Perhaps a "good enough" solution is to just warn if a Bazaar URL contains "\<svn\>"? Not as elegant for the user as the DWIM of actually probing the URL's location, but perhaps it'd be good enough to deal with most cases?

David Allouche (ddaa)
Changed in launchpad-bazaar:
status: Incomplete → Confirmed
assignee: ddaa → nobody
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
assignee: nobody → Curtis Hovey (sinzui)
tags: added: qa-needstesting
Changed in launchpad:
status: Triaged → Fix Committed
Curtis Hovey (sinzui)
tags: added: qa-ok
removed: qa-needstesting
Ian Booth (wallyworld)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions