Cannot add subscribers to skipped list because of bad indentation

Bug #114657 reported by Curtis Hovey on 2007-05-14
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Curtis Hovey

Bug Description

Line 991 in mailnotification.py is indented 15 spaces--should be 16. We are not executing the skipped.add(person) instruction.

Curtis Hovey (sinzui) wrote :

This is a trivial fix.

Changed in launchpad-answers:
assignee: nobody → sinzui-is
description: updated
Changed in launchpad-answers:
status: Unconfirmed → Confirmed
Curtis Hovey (sinzui) wrote :

Fixed in RF 4232.

Changed in launchpad-answers:
status: Confirmed → Fix Committed
James Henstridge (jamesh) wrote :

Why do you believe that the instruction wouldn't be executed? While we want to have consistent indentation, it isn't required (only that each individual block has consistent indentation). Python doesn't silently refuse to execute code due to things like this.

Curtis Hovey (sinzui) wrote :

Thank you for clarifying that. The tests do pass. I was under the assumption it would cause errors or at least warnings. (So much for 11 years of casual Python experience.)

Curtis Hovey (sinzui) wrote :

Fix released in RF 4282.

Changed in launchpad-answers:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers