Translations are getting marked as "needing review" on each upload, preventing complete translation of Ubuntu for the release

Reported by Timo Jyrinki on 2007-04-03
16
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Carlos Perelló Marín

Bug Description

Many translations are set "need review" on each upload of the source package, mainly update-manager packages ie. update-manager, python-apt and software-properties.

It seems to vary from language to language, but for example https://translations.launchpad.net/ubuntu/feisty/+source/software-properties/+pots/software-properties/ shows again that eg. French has 3 untranslated strings, Japanese 5, even though they have been both throroughly translated already before, and no strings have been changed. Similarly to eg. French (at this very moment), I also had to again mark as not needing review the string "Please insert a disk in the drive:", even though the string has not been changed and I've unselected the "needs review" at least three times already after the last three uploads of the package.

One of the most unfortunate problems is that "Starting Update Manager" in update-manager pot is getting marked as needing review on every upload, since it's a very visible string - if and when update-manager is once again translated after the translation deadline on 12th of April, it's impossible to have it translated on release. This was the case with the same string in Finnish and Ubuntu 6.10 - I "translated" it numerous times, but eventually the deadline came and one more update-manager upload was done, leaving the translation out of the release, only to be included over a month later or so in the first translation updates.

If there's anything you can do to _make sure_ that _every_ translation of: update-manager, python-apt, update-notifier and software-properties, are _kept and included in the Ubuntu 7.04 release_, please do so!

Timo Jyrinki (timo-jyrinki) wrote :

One of the most persisting problems, but which only seems to affect Finnish and maybe three-four other languages, is https://translations.launchpad.net/ubuntu/feisty/+source/update-notifier/+pots/update-notifier/fi/28/+translate ("There is %i update available" + plural), which I've been "translating" tens of times since Ubuntu 6.06 days, with no change at all in the strings. Also when there was a Ubuntu 6.10 update recently, it also became untranslated there once again (https://translations.launchpad.net/ubuntu/edgy/+source/update-notifier/+pots/update-notifier/fi/22/+translate).

It's hard to pinpoint exactly which specific languages are affected, since it's hard to be certain if something _was_ really translated before the upload (I only know my own language for sure), and also because many of the more active translators soon unmark the "needs review" soon, like I'm doing too.

I also e-mailed about these problems on rosetta-users, but there was no answer either in there: https://lists.ubuntu.com/archives/rosetta-users/2007-March/002124.html

Carlos Perelló Marín (carlos) wrote :

Ok, finally, I found the cause of this problem. It's related with bug #102449

Now that I finally found the problem, I will get it fixed as soon as possible.

Changed in rosetta:
assignee: nobody → carlos
importance: Undecided → Critical
status: Unconfirmed → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

Really cool if you managed to pinpoint the problem!

Changed in rosetta:
status: Confirmed → In Progress
Carlos Perelló Marín (carlos) wrote :

Fixed in RF 4111

Changed in rosetta:
status: In Progress → Fix Committed
Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers