Queue tool requires direct DB access

Bug #1006173 reported by Colin Watson
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Colin Watson

Bug Description

scripts/ftpmaster-tools/queue is one of the tools Ubuntu archive administrators use most often, yet it still requires an ssh login to a privileged account on ftpmaster. There is a UI, DistroSeries:+queue, but there are many situations where scripting is helpful to us. For example, when we run an auto-sync from Debian we want to go through shortly afterwards and accept all the new packages we chose to sync (since our auto-sync tool prompts us for each new source package, i.e. those not previously in Ubuntu, presenting all the relevant information not covered by Ubuntu's general trust of Debian's hygiene in accepting new packages). This can be done by hand using the web UI if we must, but it is clearly amenable to better automation.

Some of queue's capabilities are not currently exposed in the web UI, in particular overriding individual binaries in an upload. Julian has said that he considers this a bug in its own right (bug 828649), but that's a case where it would probably be easier to expose an API in the short term than to do yet another UI redesign; and, again, that's something I can imagine automated use cases for (e.g. syncing over the overrides for all of linux's zillion binary packages each time there's a new kernel API in the development release).

In general, I believe we make use of just about all the facilities provided by the queue tool in one way or another. I think the most straightforward approach here is just to provide a like-for-like replacement. We don't need the new API to have any particular stability guarantees, since the main consumers of it will be in ubuntu-archive-tools which isn't packaged and is just run out of a bzr branch whose users tend to keep it current, so exporting it only on devel with no plans to release it more formally should be fine. It also isn't necessary for the new API to follow the exact shape of the current data model, which I gather is considered problematic in various ways and best not exposed directly.

Related branches

Colin Watson (cjwatson)
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: New → In Progress
Colin Watson (cjwatson)
summary: - Replace queue tool with API
+ Queue tool requires direct DB access
Curtis Hovey (sinzui)
Changed in launchpad:
importance: Undecided → High
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Revision history for this message
Colin Watson (cjwatson) wrote :

My client is still distinctly rough, but it was enough to successfully reject and then accept a package in oneiric-proposed on qastaging.

tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Revision history for this message
Colin Watson (cjwatson) wrote :

The read-only bits are mostly fine. The one thing I spotted is that there's no way to get an "info"-type summary of the custom files contained in an upload; but that's not a regression.

tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :

Fixed in stable r16052 (http://bazaar.launchpad.net/~launchpad-pqm/launchpad/stable/revision/16052) by a commit, but not testable.

tags: added: qa-untestable
removed: qa-ok
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers