cscvs blows on svn:externals

Bug #69513 reported by David Allouche
2
Affects Status Importance Assigned to Milestone
Launchpad CSCVS
Fix Released
Medium
David Allouche

Bug Description

When a svn branch to import makes use of svn externals, cscvs fails to import it.

The created svn checkout contains the externals, but the applied changesets (and ultimately the imported branch) ignores them. When cscvs validates the imported workingtree against the svn checkout, the presence of external files is detected as a discrepancy and causes a failure.

Since we want to preserve the structure of the imported repository, externals should be ignored _completely_. That means that the svn calls for checkout, update, etc. must be configured to ignore svn:externals.

Related to bug 68175.

David Allouche (ddaa)
Changed in launchpad-bazaar:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Revision history for this message
David Allouche (ddaa) wrote :

Fixed. But externals support is still broken by bug 82483.

Changed in launchpad-cscvs:
assignee: nobody → ddaa
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers