package_name and suite not passed to dailydeb

Bug #515918 reported by Michael Nelson on 2010-02-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
launchpad-buildd
Low
Unassigned

Bug Description

This relates to a branch that hasn't landed yet at:

https://code.edge.launchpad.net/~abentley/launchpad/build-recipe

but just so it doesn't fall off the radar: In the above branch, we currently pass the sourcepackage name and the suite to the slave builder (in lp.soyuz.model.recipebuilder._extraBuildArgs(), and I can see this being passed through to the actual slave build script in canonical.buildd.buildrecipe.RecipeBuilder.__init__(), but then buildTree() - the method that calls bzr dailydeb, doesn't use these arguments at all, which means that we will always build the sourcepackage using the sourcepackagename and suite from the previous changelog entry, rather than the values specified by the user on the recipe.

Aaron Bentley (abentley) wrote :

We create a CurrentlyBuilding file. Is that enough?

On Wed, Feb 3, 2010 at 10:10 PM, Aaron Bentley <email address hidden> wrote:
> We create a CurrentlyBuilding file.  Is that enough?
>

I don't think so. Looking at bzr help dailybuild seems to indicate
that we need to use the --package and --distribution options to pass
the source package name and suite respectively? (Otherwise it defaults
to the previous changelog entry).

Aaron Bentley (abentley) on 2011-01-21
tags: added: recipe
removed: wellington

bzr: ERROR: No previous changelog to take the package name from, and --package not specified: debian/changelog didn't contain any parseable stanzas.

I have started to get these on daily builds. See:

https://code.launchpad.net/~credativ/+recipe/web-6.0-releases

ignore my last comment. Error between the keyboard and the chair.

Jelmer Vernooij (jelmer) wrote :

The --package argument to bzr-builder is now optional, and might be removed in the future.

Robert Collins (lifeless) wrote :

Sounds like this might be irrelevant now

Changed in launchpad:
importance: Medium → Low
Jelmer Vernooij (jelmer) wrote :

Marking as dupe of 855479 which is also about not specifying the suite.

The package name doesn't have to be passed in since bzr-builder now takes the package name from debian/control.

affects: launchpad → launchpad-buildd
Changed in launchpad-buildd:
status: Triaged → Invalid
status: Invalid → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers