open-iscsi fails to install

Bug #214476 reported by Pau Garcia Quiles on 2008-04-09
6
Affects Status Importance Assigned to Milestone
launchpad-buildd
Undecided
Adam Conrad
open-iscsi (Ubuntu)
Undecided
Unassigned

Bug Description

Launchpad-buildd fails to build packages which depend on open-iscsi due to this error:

Setting up open-iscsi (2.0.865-1) ...
 * iSCSI requires a mounted sysfs, not started.
invoke-rc.d: initscript open-iscsi, action "start" failed.
dpkg: error processing open-iscsi (--configure):
 subprocess post-installation script returned error exit status 1
[...]
Errors were encountered while processing:
 open-iscsi
E: Sub-process /usr/bin/dpkg returned an error code (1)
apt-get failed.
[...]

And the build is not started.

I don't know the autobuilders configuration but this *might* be a duplicate of bug #208441

Package builds fine on a Gutsy pbuilder in my laptop.

Chuck Short (zulcss) wrote :

Does the installation still fail if /sys is mounted?

chuck

Changed in open-iscsi:
status: New → Incomplete
Pau Garcia Quiles (pgquiles) wrote :

I'm not 100% sure because I don't know the configuration of the Launchpad builder machines.

On my system and on the pbuilders on my system, /sys is mounted and open-scsi installs fine.

On the Launchpad builder machines (for instance, Samarium), open-iscsi does not install. Is /sys mounted on those machines? I don't know.

Diogo Matsubara (matsubara) wrote :

I'm setting the launchpad-buildd status to incomplete and assigning to Adam. I've chatted with Celso and he told me that Lamont or Infinity would be able to answer this bug appropriately.

Changed in launchpad-buildd:
assignee: nobody → adconrad
status: New → Incomplete
Soren Hansen (soren) wrote :

Fixed by open-iscsi 2.0.865-1ubuntu4.

Changed in open-iscsi:
status: Incomplete → Fix Committed
Soren Hansen (soren) on 2008-05-02
Changed in open-iscsi:
status: Fix Committed → Fix Released
Jesper Krogh (jesper) wrote :

But ubuntu4 hasn't been uploaded to hardy.. so the bug is still present in hardy (just hit it)

Jesper

Celso Providelo (cprov) on 2009-08-18
Changed in launchpad-buildd:
assignee: Adam Conrad (adconrad) → nobody
Celso Providelo (cprov) wrote :

The launchpad-buildd issue seems to be fixed.

@Jesper: can you discuss with Soren if the backport is required and legitimate ?

Changed in launchpad-buildd:
assignee: nobody → Adam Conrad (adconrad)
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers