Snap build failed with "Failed to gather results: execv() arg 2 must contain only strings"

Bug #1832072 reported by 林博仁(Buo-ren, Lin) on 2019-06-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
launchpad-buildd
High
Colin Watson

Bug Description

I encountered several errors that aren’t caused by build failure while using `snapcraft remote-build`:

```
Priming desktop-qt5
Priming launchers
Priming patching
Priming selective-checkout
Priming main
sed --file /build/snapcraft-fe18a192c056412982c7e9eba40d9ca0/stage/patching/patch-desktop-entries.sed --in-place share/applications/featherpad.desktop
Priming scriptlets
Snapping 'featherpad' ...

Snapped featherpad_0.10.0+pkg-8c14_ppc64el.snap
Revoking proxy token...
Failed to gather results: execv() arg 2 must contain only stringsRUN: /usr/share/launchpad-buildd/bin/in-target scan-for-processes --backend=lxd --series=bionic --arch=ppc64el SNAPBUILD-580422
Scanning for processes to kill in build SNAPBUILD-580422
```

Log: <https://launchpad.net/~buo-ren-lin/+snap/snapcraft-fe18a192c056412982c7e9eba40d9ca0/+build/580422/+files/buildlog_snap_ubuntu_bionic_ppc64el_snapcraft-fe18a192c056412982c7e9eba40d9ca0_BUILDING.txt.gz>

Related branches

Colin Watson (cjwatson) wrote :

This is because the build creates a file with a non-ASCII name at its top level in the directory that launchpad-buildd scans for output .snaps, and when running in LC_ALL=C the call to self.backend.islink for this file fails. It may be difficult to construct a good test for this, since you can only change that aspect of Python's locale handling by starting a new interpreter, but it should be easy enough to fix otherwise.

Changed in launchpad-buildd:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → In Progress
Colin Watson (cjwatson) wrote :

And of course Python 3 is OK with it either way, but we still need to backport a few dependencies to allow launchpad-buildd to work with that.

Colin Watson (cjwatson) wrote :

Fixed in launchpad-buildd 175, now on production.

Changed in launchpad-buildd:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers