Unable to build python based snap on Launchpad

Bug #1642281 reported by Martin Wimpress on 2016-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
launchpad-buildd
High
Colin Watson

Bug Description

I'm trying to build my podpublish snap, which uses the 'python' plugin, on Launchpad. The issue is that Launchpad prevents network access during the build step and despite pulling in all the requirements during the pull step, snapcraft is attempting to pull some of the same requirements in the build step and this causes the build to fail.

Here is repository that includes snapcraft.yaml, requirements.txt and setup.py:

  * https://git.launchpad.net/podpublish/tree/

Here is a build log showing the build failure:

  * https://launchpadlibrarian.net/293648430/buildlog_snap_ubuntu_xenial_amd64_podpublish_BUILDING.txt.gz

Related branches

Colin Watson (cjwatson) on 2016-11-24
affects: snapcraft → launchpad-buildd
Colin Watson (cjwatson) wrote :

launchpad-buildd (141) trusty; urgency=medium

  * buildsnap: Grant access to the proxy during the build phase as well as
    during the pull phase (LP: #1642281).
  * buildsnap: Grant access to the proxy during the repo phase, allowing the
    base branch to be fetched from an external site.

 -- Colin Watson <email address hidden> Mon, 05 Dec 2016 19:05:50 +0000

Changed in launchpad-buildd:
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers