Packages with unsatisfied versioned BDs don't go into depwait

Bug #1468755 reported by Iain Lane on 2015-06-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
launchpad-buildd
High
Colin Watson

Bug Description

I uploaded gst-libav1.0 to my PPA (I won't supersede this) - it has a versioned dependency that can't be satisfied in wily currently.

  https://launchpad.net/~laney/+archive/ubuntu/ppa/+build/7575642

  The following packages have unmet dependencies:
   sbuild-build-depends-gst-libav1.0-dummy : Depends: libgstreamer1.0-dev (>= 1.5.2) but it is not going to be installed
                                             Depends: libgstreamer-plugins-base1.0-dev (>= 1.5.2) but it is not going to be installed

With the old resolver, we'd see output like

  After installing, the following source dependencies are still unsatisfied:
  libwayland-dev(inst 1.1.0-2ubuntu3 ! >= wanted 1.2.0)

i.e. there was a check was performed after installing the BDs.

I think "but it is not going to be installed" means that the package is available but uninstallable. Launchpad's historically failed builds with uninstallable build-deps (pending some more smarts e.g. bug #527245), so this much is intentional and perhaps there isn't a way to distinguish the cases we genuinely want to fail.

Related branches

lp:~cjwatson/launchpad-buildd/improve-depwait
William Grant: Approve (code) on 2015-07-08
Colin Watson (cjwatson) wrote :

10:18 <cjwatson> wgrant: Hm, https://launchpad.net/ubuntu/+source/libmoox-cmd-perl/0.013-2/+build/7541385 should have been a dep-wait, surely?
10:20 <cjwatson> wgrant: Oh, no, never mind, that's uninstallability more than one level deep
10:22 <cjwatson> wgrant: This is maybe a little unfortunate, because I think it really is just that one. Probably an sbuild bug in that it should be using "apt-get build-dep".
10:23 <cjwatson> Yeah, everything's fine in that build-dependency set apart from the version restriction
10:27 <cjwatson> Tempting to do http://paste.ubuntu.com/11772424/
10:56 <wgrant> cjwatson: Will that reliably cope with alternatives?
10:56 <wgrant> There are some complexities there.
10:58 <cjwatson> build-dep should in general cope better than install. The only reason I didn't do it in the first place in that code was that I was being conservative when fixing up cross handling.
10:58 <cjwatson> But it certainly makes sense to check that.
10:58 <cjwatson> Hm, it's perhaps possible that it would break the --no-resolve-alternatives case ...
11:00 * cjwatson leaves an XXX comment for himself to check that later

affects: launchpad → launchpad-buildd
Changed in launchpad-buildd:
importance: Undecided → High
status: New → Triaged
tags: added: regression
Colin Watson (cjwatson) on 2015-07-02
Changed in launchpad-buildd:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Colin Watson (cjwatson) on 2015-07-08
Changed in launchpad-buildd:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Fixed, and I retried your builds to demonstrate it.

Changed in launchpad-buildd:
status: Fix Committed → Fix Released
Iain Lane (laney) wrote :

Brilliant, thanks very much. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers