Does not start after installing using easy_install

Bug #1041928 reported by martinvol
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LauncherPosta
Won't Fix
Undecided
Unassigned

Bug Description

martin@martin-desktop:~$ sudo easy_install launcherposta
(...)
martin@martin-desktop:~$ launcherposta
Running Python sys.version_info(major=2, minor=7, micro=3, releaselevel='final', serial=0) on 'linux2'
Traceback (most recent call last):
  File "/usr/local/bin/launcherposta", line 5, in <module>
    pkg_resources.run_script('launcherposta==0.6', 'launcherposta')
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 499, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1235, in run_script
    execfile(script_filename, namespace, namespace)
  File "/usr/local/lib/python2.7/dist-packages/launcherposta-0.6-py2.7.egg/EGG-INFO/scripts/launcherposta", line 38, in <module>
    version = open(version_file).read().strip()
IOError: [Errno 2] No such file or directory: '/usr/local/version.txt'

OS: Ubuntu 12.04
Python versions available: 2.7.3, 3.2.3

Revision history for this message
Facundo Batista (facundo) wrote :

Sorry, easy_install installing mechanism is kind of broken/useless for what I need to, because it doesn't run post installation scripts.

In view of this that I just learned, I'm stopping using PyPI to distribute this.

In the future I may start using it again, if I change the distribution library, but in the mean time please use an alternative installation method (from the tar.gz, from the .deb, or subscribing to the PPA).

Thank you and sorry for the inconvenience.

Changed in launcherposta:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers