Recent MikteX / PSTricks update causes misplacement of texts

Bug #1640094 reported by Lorenzo Benedetti on 2016-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LaTeXDraw
Critical
arno_b

Bug Description

After an update of MikTek, LatexDraw started to misplace texts (formulas too) and group shapes.
In the attachment I added a .rar file with an example file in order to reproduce the bug and some image of it:

"ExampleMisplacement-OriginalFile.svg" is a file that I had already made with a previous version of Miktek. I made it with LatexDraw 3.3.1 and the .png export of this file in its correct rendering is in the file "previous rendering.png". Now, with both LatexDraw 3.3.1 and 3.3.4 the result is given in the file "actual rendering.png". Note that initially, at the opening of the .svg file, the positioning of the shapes is correct (see "actual position.png").

The bug produces a misplacement of the text (see "TextBoundingBox.png"), a misplacement of formulas (see "FormulaBoundingBox.png"), a correct placement of geometrical shapes and group shapes but the latter has a wrong bounding box (see "singleShapeSelection.png" and "groupSelection.png").

The MikTek that was able to produce a correct rendering has only the package pstricks dated 2015-08-31, but now is deprecated and divided in multiple packages. The MikTek packages that creates the issues are the latest. I checked on pstricks website and from 2015 the updates were:

2016-06-08: update pstricks base
2016-05-15: new package pst-cie
2016-05-16: update pst-plot
2016-05-14: update pst-node
2016-02-09: update pstricks-add
2015-12-17: update pst-solides3d
2015-05-18: update pst-coil
2015-05-15: update pst-barcode

The system tab in "About LatexDraw" reads:

LateXDraw version: 3.3.4, 20160917
LaTeX version:
MiKTeX-pdfTeX 2.9.6100 (1.40.17) (MiKTeX 2.9.6100)
Copyright (C) 1982 D. E. Knuth, (C) 1996-2016 Han The Thanh
TeX is a trademark of the American Mathematical Society.
compiled with zlib version 1.2.8; using 1.2.8
compiled with libpng version 1.6.24; using 1.6.24
compiled with poppler version 0.46.0
compiled with jpeg version 8.4

DviPS version:
This is dvips(k) 5.996 Copyright 2016 Radical Eye Software
MiKTeX 2.9.6100
Copyright 2016 Radical Eye Software.
There is NO warranty. You may redistribute this software
under the terms of the GNU General Public License
and the Dvips copyright.
For more information about these matters, see the files
named COPYING and dvips.h.
Primary author of Dvips: T. Rokicki.

PS2PDF version:

Usage: ps2pdf input.ps [output.pdf]
   or: ps2pdf [options...] input.[e]ps output.pdf

PS2EPSI version:
"Usage: ps2epsi <infile.ps> <outfile.epi>"

PDFcrop version:pdfcrop: The script engine could not be found.
pdfcrop: Data: scriptEngine="perl.exe"

Java properties:
sun.java2d.opengl: false
java.runtime.name: Java(TM) SE Runtime Environment
sun.boot.library.path: C:\Program Files (x86)\Java\jre1.8.0_111\bin
java.vm.version: 25.111-b14
com.apple.mrj.application.apple.menu.about.name: LaTeXDraw
java.vm.vendor: Oracle Corporation
java.vendor.url: http://java.oracle.com/
path.separator: ;
java.vm.name: Java HotSpot(TM) Client VM
file.encoding.pkg: sun.io
user.country: IT
user.script:
sun.java.launcher: SUN_STANDARD
sun.os.patch.level: Service Pack 1
java.vm.specification.name: Java Virtual Machine Specification
user.dir: C:\Program Files\latexdraw
java.runtime.version: 1.8.0_111-b14
java.awt.graphicsenv: sun.awt.Win32GraphicsEnvironment
java.endorsed.dirs: C:\Program Files (x86)\Java\jre1.8.0_111\lib\endorsed
os.arch: x86
java.io.tmpdir: C:\Users\[UserName]\AppData\Local\Temp\
line.separator:

java.vm.specification.vendor: Oracle Corporation
user.variant:
os.name: Windows 7
apple.laf.useScreenMenuBar: true
sun.jnu.encoding: Cp1252
java.library.path: C:\Program Files (x86)\Java\jre1.8.0_111\bin;
C:\Windows\Sun\Java\bin;
C:\Windows\system32;
C:\Windows;
C:\ProgramData\Oracle\Java\javapath;
C:\Program Files (x86)\MiKTeX 2.9\miktex\bin;
C:\Program Files\Microsoft HPC Pack 2008\Bin\;
C:\Program Files\Common Files\Microsoft Shared\Windows Live;
C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;
C:\Windows\system32;
C:\Windows;
C:\Windows\System32\Wbem;
C:\Windows\System32\WindowsPowerShell\v1.0\;
C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;
C:\Program Files\Broadcom\Broadcom 802.11 Network Adapter\Driver;
C:\Program Files (x86)\Windows Live\Shared;
C:\Program Files\WIDCOMM\Bluetooth Software\;
C:\Program Files\WIDCOMM\Bluetooth Software\syswow64;
C:\Program Files\Microsoft Windows Performance Toolkit\;
C:\Program Files (x86)\gnuplot\bin;
C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;
C:\Program Files (x86)\QuickTime\QTSystem\;
C:\Program Files\Ghostgum\pstoedit;
C:\Program Files\gs\gs9.04\bin;
C:\Program Files\gs\gs9.04\lib;
C:\Cast3M\PCW_11\bin;
C:\Python27;.
sun.awt.enableExtraMouseButtons: true
java.specification.name: Java Platform API Specification
java.class.version: 52.0
sun.management.compiler: HotSpot Client Compiler
os.version: 6.1
user.home: C:\Users\[UserName]
user.timezone: Europe/Berlin
java.awt.printerjob: sun.awt.windows.WPrinterJob
file.encoding: Cp1252
java.specification.version: 1.8
java.class.path: C:\Program Files\latexdraw\LaTeXDraw.jar
user.name: [UserName]
java.vm.specification.version: 1.8
sun.java.command: C:\Program Files\latexdraw\LaTeXDraw.jar
java.home: C:\Program Files (x86)\Java\jre1.8.0_111
sun.arch.data.model: 32
user.language: it
java.specification.vendor: Oracle Corporation
awt.toolkit: sun.awt.windows.WToolkit
java.vm.info: mixed mode
java.version: 1.8.0_111
java.ext.dirs: C:\Program Files (x86)\Java\jre1.8.0_111\lib\ext;C:\Windows\Sun\Java\lib\ext
sun.boot.class.path: C:\Program Files (x86)\Java\jre1.8.0_111\lib\resources.jar;C:\Program Files (x86)\Java\jre1.8.0_111\lib\rt.jar;C:\Program Files (x86)\Java\jre1.8.0_111\lib\sunrsasign.jar;C:\Program Files (x86)\Java\jre1.8.0_111\lib\jsse.jar;C:\Program Files (x86)\Java\jre1.8.0_111\lib\jce.jar;C:\Program Files (x86)\Java\jre1.8.0_111\lib\charsets.jar;C:\Program Files (x86)\Java\jre1.8.0_111\lib\jfr.jar;C:\Program Files (x86)\Java\jre1.8.0_111\classes
java.vendor: Oracle Corporation
file.separator: \
java.vendor.url.bug: http://bugreport.sun.com/bugreport/
sun.io.unicode.encoding: UnicodeLittle
sun.cpu.endian: little
sun.desktop: windows
sun.cpu.isalist: pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86

Let me know if I can provide you further information to solve the problem...
Thank you for your work!

arno_b (arno.b) wrote :

Hi,
Thanks for the report!
Can you test the latest development version:
https://ci.inria.fr/malai/job/latexdraw%20bundle/

I recently fixed a problem due to a change in PSTricks that affect recent miktex updates.

Cheers

Hi Arno,

it appears that in the latest development version the issues were solved. I am sorry that, before sending the bug, I could not find the development version bundle to run a test.

I really do appreciate your work!! Thank you very much!!

Cheers,

Lorenzo

arno_b (arno.b) wrote :

No problem. I prefer to have more feedback on a problem than no feedback ;)

Changed in latexdraw:
status: New → Fix Released
importance: Undecided → Critical
assignee: nobody → arno_b (arno.b)
milestone: none → 3.3.5
summary: - Miktek update causes misplacement of texts, formulas and group shapes
+ Recent MikteX / PSTricks update causes misplacement of texts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers