Ubuntu language selector

Belarusian Latin for selector

Reported by Ihar Hrachyshka on 2007-09-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector
Fix Released
Undecided
Unassigned

Bug Description

We should provide the possibility to choose Belarusian Latin language (presented as <email address hidden> files, <email address hidden> locale) from Ubuntu Language Selector. If there is such possibility, we should not use cyrillic belarusian translations when there are no latin translations (no use of be.po files) because that whould mean inconsistency of translations (they are very different).

Is there a chance for this bug to be fixed for 8.04 LTS? It's very annoying because lots of belarusian users can't use be@latin translation only because they lack technical knowledge for manually reconfiguring locales and editing configuration files.

Aleksander Navicki (navicki) wrote :

Is anybody home?
U ich zimovaja śpiačka...

Here is a patch for language-selector that fixes this bug...

Was this patch committed as it is stated in #157651? If so, shouldn't this bug be marked as fixed?

Is there any chance to see this fixed and running for Ubuntu 8.04?

Aleksander Navicki (navicki) wrote :

Let me guess, it will be stated In Ubuntu 9.11?

U mianie takoje ŭražańnie, što tolki ja tut tabie adkazvaju...

Any news? It's silly that GNOME l10n people work hard to provide Linux users the best of localization but Ubuntu developers just don't want to commit a simple fix to support available options for their users!!!

Arne Goetje (arnegoetje) wrote :

Added the following fallback string to language-selector:

be_BY@latin:be@latin:be_BY:be:en_GB:en

Changed in language-selector:
status: New → Fix Committed

Wow, thanks a lot. This bug was so mad. It's great we will have 'Belarusian Latin' option in 10.04 LTS release!

booxter wrote:
> Wow, thanks a lot. This bug was so mad. It's great we will have
> 'Belarusian Latin' option in 10.04 LTS release!
>
Sorry I haven't done that earlier, I haven't been subscribed to this
bugmail and didn't see this bug.

Arne Goetje (arnegoetje) wrote :

Fixed in version 0.5.1.

Changed in language-selector:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers