crash in landscape-broker

Bug #360510 reported by Sidnei da Silva on 2009-04-13
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Landscape Client
Critical
Christopher Armstrong
Landscape Server
Critical
Unassigned
landscape-client (Ubuntu)
High
Mathias Gug

Bug Description

I've got a crash with a core dump (apparently) from landscape-broker. I can't report it through apport because I have a pinned python-apt package. I'm attaching the generated report, fished out of /var/crash

Sidnei da Silva (sidnei) wrote :
Sidnei da Silva (sidnei) wrote :

For the records, this started after the upgrade to the latest launchpad-client 1.0.29 package. I get the apport prompt for the crash on every restart. It never seems to recover. :(

Sidnei da Silva (sidnei) on 2009-04-13
Changed in landscape:
importance: Undecided → Critical
milestone: none → mountainview
status: New → Confirmed
Changed in landscape-client:
importance: Undecided → Critical
milestone: none → 1.0.30
status: New → Confirmed
Changed in landscape:
status: Confirmed → Invalid
Sidnei da Silva (sidnei) on 2009-04-13
Changed in landscape-client (Ubuntu):
status: New → Confirmed
Sidnei da Silva (sidnei) wrote :

Tried workaround suggested by radix:

"""
add this to landscape/lib/fetch.py : curl.setopt(pycurl.NOSIGNAL, 1)
"""

After that, landscape-broker doesn't crash anymore. Further comments from radix:

"""
what this means is that it'll be thread-safe but DNS resolution will block...
 that could be a while in some cases, but I think it's acceptable
 or rather
 DNS resolution will block and be impossible to timeout
"""

Changed in landscape-client:
assignee: nobody → Christopher Armstrong (radix)
status: Confirmed → Fix Committed
Christopher Armstrong (radix) wrote :

I've attached a branch for updating the jaunty package to this version (1.0.29-segfault-bug).

We'll either need to get this into jaunty-updates or into the actual Jaunty release (which means getting authorization for upload since we're already in Final Freeze).

This bug is pretty severe, since we're getting so many reports of it even with the very small number of users using landscape-client on jaunty. The fix for it is only the insertion of one line (the one in Sidnei da Silva's comment above). The change also comes with several other inserted lines in the unit tests. Given the severity and the simplicity of the fix, I hope we can get it into the Jaunty release.

Christopher Armstrong (radix) wrote :

I meant to add: not *all* users will get this, since it's a race condition involving threads and signals, and this is why we didn't find the bug in our own testing. However, it seems a sizable portion of users will get it anyway, based on the reports (from sidnei and from two others in the duplicate bug).

visibility: private → public
Christopher Armstrong (radix) wrote :

I've made an official 1.0.29.1 upstream release and updated the attached branch with it.

Changed in landscape-client:
milestone: 1.0.30 → 1.0.29.1
Mathias Gug (mathiaz) on 2009-04-14
Changed in landscape-client (Ubuntu):
assignee: nobody → mathiaz
milestone: none → ubuntu-9.04
status: Confirmed → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.0.29.1-0ubuntu0.9.04.0

---------------
landscape-client (1.0.29.1-0ubuntu0.9.04.0) jaunty; urgency=low

  * Apply a fix for segfault bug involving curl timeouts. (LP: #360510)

 -- Christopher Armstrong <email address hidden> Mon, 13 Apr 2009 14:33:31 -0400

Changed in landscape-client (Ubuntu):
status: In Progress → Fix Released
Andreas Hasenack (ahasenack) wrote :

A 1.0.29.1 landscape-client tarball was released.

tags: added: needs-package-release
Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers