autopilot newton with horizon, can't launch instances with default settings

Bug #1644923 reported by David Britton
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Landscape Server
Won't Fix
Medium
Unassigned
OpenStack Dashboard Charm
Invalid
Undecided
Unassigned
openstack-dashboard (Juju Charms Collection)
Invalid
Undecided
Unassigned

Bug Description

dpb │ Error: Failed to perform requested operation on instance "test-dpb", the instance has an error status: Please try again later [Error: Build of instance 34dbc854-64ae-425c-a4e6-6522032893f0 aborted: Block Device Mapping is Invalid.

Needs investigation.

Workaround: uncheck 'create new volume' when launching the instance.

Tags: landscape sts
David Britton (dpb)
Changed in landscape:
milestone: none → 16.11
Revision history for this message
Alberto Donato (ack) wrote :

It seems defaults changed in Horizon, it doesn't seem something we can do on the Landscape side.

FWIW the volume should be eventually created, but it takes longer than the retries Nova does to check if the volume is ready. So it eventually gives up and the image build fails.

Changed in landscape:
status: New → Invalid
David Britton (dpb)
Changed in landscape:
status: Invalid → New
David Britton (dpb)
information type: Proprietary → Public
Changed in landscape:
milestone: 16.11 → 16.12
Changed in landscape:
status: New → Triaged
Revision history for this message
Chad Smith (chad.smith) wrote :

Just reproduced on the lp:landscape cloud deployment

Error: Failed to perform requested operation on instance "test", the instance has an error status: Please try again later [Error: Build of instance 6fd6e315-99fb-43fd-af7e-821135b222ca aborted: Block Device Mapping is Invalid.].

Changed in landscape:
milestone: 16.12 → 17.01
Chad Smith (chad.smith)
Changed in landscape:
milestone: 17.01 → 17.02
James Page (james-page)
Changed in openstack-dashboard (Juju Charms Collection):
status: New → Invalid
Revision history for this message
Chad Smith (chad.smith) wrote :

Will close when we update release notes documentation.

Chad Smith (chad.smith)
Changed in landscape:
milestone: 17.02 → 17.03
David Britton (dpb)
Changed in landscape:
status: Triaged → Fix Committed
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

landscape server status is "wontfix" actually, since we didn't change anything and don't plan to.

Changed in landscape:
status: Fix Committed → Won't Fix
Revision history for this message
Frode Nordahl (fnordahl) wrote :

The root cause of this issue is in Horizon itself see bug 1560965

tags: added: sts
Revision history for this message
Frode Nordahl (fnordahl) wrote :

Looking a bit further into this the horizon bug mentioned in #5 comes into play in some circumstances when using iSCSI as block storage back-end.

There is however a separate and different issue leading to similar results present on Autopilot deployed clouds using Ceph as block storage back-end.

I will follow-up with more details about this in a separate bug report.

Revision history for this message
James Page (james-page) wrote :

Bug is in OpenStack (bug 1560965); marking charm task as invalid.

Changed in charm-openstack-dashboard:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers