Non-xen machines are reported as being xen VMs

Bug #921970 reported by Björn Tillenius on 2012-01-26
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Landscape Client
Medium
Thomas Herve
landscape-client (Ubuntu)
Undecided
Unassigned
Nominated for Oneiric by Jonathan Davies

Bug Description

Both my oneiric and precise machines are being reported as being xen VMs. Looking closer at the detection code, it checks for the presence of /sys/bus/xen, which does indeed exist. It seems like we have to look at what's inside that directory. On my real machines, /sys/bus/xen/drivers/ and /sys/bus/xen/devices/ exist, but are empty. On my linode xen vm, the drivers/ and devices/ directories do contain some files.

Canonistack instances also seem to be wrongly reported as xen vms, when they should be kvm ones.

Lucid doesn't seem to be affected. I haven't check what happens for natty.

Changed in landscape-client:
milestone: none → backlog
Thomas Herve (therve) on 2012-01-26
Changed in landscape-client:
importance: Undecided → Medium
Nobuto Murata (nobuto) wrote :

My bare metal client is also recognized as "xen", and does not seem to send hardware information to Landscape server.

$ tree /sys/bus/xen/
/sys/bus/xen/
├── devices
├── drivers
├── drivers_autoprobe
├── drivers_probe
└── uevent

Changed in landscape-client:
status: New → Confirmed
Thomas Herve (therve) on 2012-01-30
Changed in landscape-client:
milestone: backlog → 12.01.2
assignee: nobody → Thomas Herve (therve)
Thomas Herve (therve) on 2012-01-30
Changed in landscape-client:
status: Confirmed → Fix Committed
Changed in landscape-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in landscape-client (Ubuntu):
status: New → Confirmed
Andreas Hasenack (ahasenack) wrote :

It should be fixed in the 12.04.2-0ubuntu1 package that is in precise. Can you try?

Changed in landscape-client (Ubuntu):
status: Confirmed → Incomplete
Nobuto Murata (nobuto) wrote :

@Andreas

Sorry for late testing.
Though my bare metal machine is not reported as xen, hardware information is not still shown on Landscape Web UI.

My environment:
 * current up-to-date Precise
 * landscape-{client,common} 12.04.3-0ubuntu1
 * time elapsed since resistered with Landscape - 48+ hours
 * /etc/landscape/client.conf
    [client]
    ping_url = http://landscape.canonical.com/ping
    data_path = /var/lib/landscape/client
    computer_title = non-xen-test
    registration_password =
    account_name = <ACCOUNT>
    http_proxy = <HTTP_PROXY>
    https_proxy = <HTTPS_PROXY>

Output on Web UI:
 * https://landscape.canonical.com/account/<ACCOUNT>/computer/<MACHINE_ID>/info
    non-xen-test
    <HOSTNAME>
    Last seen: Today at 17:40 <Today means Thu 12 Apr>
    Registered: Tue 10 Apr, 16:55
    Distribution: Ubuntu precise (development branch) (precise)
    Hardware: Intel(R) Core(TM)2 Duo CPU U9400 @ 1.40GHz
    3.86GB RAM

* https://landscape.canonical.com/account/<ACCOUNT>/computer/<MACHINE_ID>/hardware
    Hardware
    No hardware device information is available.

Changed in landscape-client (Ubuntu):
status: Incomplete → Confirmed
Andreas Hasenack (ahasenack) wrote :

Hardware information requires a new client which is currently undergoing SRU, see bug #978884. This bug will also be marked "fix released" once that SRU is out, since it fixes it for lucid, natty and oneiric.

Nobuto Murata (nobuto) wrote :

@Andreas
I don't think my issue is related to Bug #978884.
#978884 handles SRU for oneiric or older, but I have used the newest package 12.04.3-0ubuntu1 on *Precise*.

BTW, though hardware information is not shown, indeed it's reported as a non-xen (bare metal) machine.
So I will mark this bug for Precise task as Fix Released.

Is "hardware information not shown" issue tracked somewhere?

Nobuto Murata (nobuto) wrote :

landscape-client (12.04-0ubuntu0.12.04.0) precise; urgency=low

  * Change package management features to use APT instead of Smart (LP: #856244,
    #861707, #859615, #861345, #863239, #863259, #865270, #865272, #865285,
    #865273, #871641, #865299, #873196, #873939, #876493, #881973, #882438,
    #866014, #881998, #884142, #884151, #884131, #887037, #886208, #887578,
    #887947, #889067, #889069, #889087, #889099, #865303, #889113, #890605,
    #890606, #890609, #897416, #891855, #898681, #898683, #897656, #898542,
    #862212, #903202, #914734, #914735, #914737, #916301, #915280, #914742,
    #918925, #918175, #919179, #921664, #921699, #922582, #922511, #921712,
    #928750, #932136, #928941, #937411, #937567, #925543, #947803, #952973,
    #948142, #953136, #953906, #956590).
  * Add a GTK interface to configure the client (LP: #911279, #911666, #912163,
    #911665, #916300, #931937, #931937, #943622, #945025, #911279, #944652,
    #948464, #948416, #949158, #911671, #950864, #949208, #949147, #953070,
    #953292, #953463, #953034, #949200, #953026, #954499, #954516, #954285,
    #953065, #954414, #954332, #954542, #955966, #955139, #956030, #956119).
  * Add the ability to auto discover the server location on local deployment
    (LP: #917422, #927620, #917422, #928585, #929087, #932325, #948564)
  * Allow the client to accept arbitrary environment variables from the
    server for script execution (LP: #954999).
  * Make landscape-config exit non-zero when registration fails and
    --ok-no-register is not passed (LP: #271759).
  * Check for the content of /sys/bus/xen/devices to report a machine as a Xen
    VM instead of just relying on the existence of /sys/bus/xen (LP: #921970).
  * Make sure cloud registration succeeds if there is no kernel specified in
    the meta-data service (LP: #920453).
  * Report private and public IP adresses from the metadata service at cloud
    registration time (LP: #918366).
  * Add support for reporting hardware information using lshw (LP: #899002,
    #943975, #955734).
  * Add support for the new attachment service in script execution
    (LP: #893040).
  * Adds a new message type, 'register-provisioned-machine', which is meant
    to register computers using an OTP (LP: #881405).
  * Add local cloning option for load testing (LP: #872830, #925924).
  * Add more variables to preseeding (LP: #863204, #867710).
  * Allow the configuration of the ping interval (LP: #397884).
  * Add fake package reporters for load testing purposes (LP: #821571,
    #821570).
  * Report a package reporter error to the server if no APT sources are
    configured, to trigger a package reporter alert (LP: #823769).

 -- Andreas Hasenack <email address hidden> Mon, 19 Mar 2012 09:33:34 -0300

Changed in landscape-client (Ubuntu):
status: Confirmed → Fix Released
Andreas Hasenack (ahasenack) wrote :

The hardware information plugin runs once a day, have you given it enough time? Is the client communicating properly with the server, i.e., do activities complete, is monitoring data up-to-date, etc?

Andreas Hasenack (ahasenack) wrote :

Oh, I'm sorry, the new hardware page isn't in landscape production yet. We expect it to be deployed next week, it's currently undergoing testing among a host of other changes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers