Limit the number of items in network activity messages

Bug #760486 reported by Thomas Herve on 2011-04-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Medium
Thomas Herve

Bug Description

If the landscape server is down for a bit, or a machine has access to network but not landscape, it can accumulate quite a few network items, and send it to us at once. We should limit the number of items in a single network message, like it's done for free-space information.

Thomas Herve (therve) on 2011-04-14
Changed in landscape-client:
status: New → In Progress
Thomas Herve (therve) on 2011-04-14
Changed in landscape-client:
status: In Progress → Fix Committed
tags: added: verifie
tags: added: verified
removed: verifie

Hello Thomas, or anyone else affected,

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Andreas Hasenack (ahasenack) wrote :

This is a bit hard to reproduce. I used a firewall rule to prevent the machine from reaching the landscape server, and left a wget running to get some network data for several hours. Then stopped the wget but left the machine like this for about 12h, and in the end only got 134 network messages, still below the 200 limit.

I would ask to consider this fixed, though, because:
- you can see in the diff that this bug has a test
- I verified that the code introduced by the diff is indeed in the package from proposed

I will however leave the machine accumulating network data for a few more days this time, as I understand that no matter how soon the verification process finishes (this bug was the last one for this SRU I believe), the package has to stay in proposed for a week. And then open the flood gates (i.e., remove the firewall rule) on monday or tuesday.

Martin Pitt (pitti) on 2011-08-03
tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Hello Thomas, or anyone else affected,

Accepted landscape-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello Thomas, or anyone else affected,

Accepted landscape-client into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Andreas Hasenack (ahasenack) wrote :

Verified that the same code is present in the current Natty and Maverick packages. This is hard to reproduce in a live environment, please consider the verification done by code inspection as was done for Lucid and Oneiric.

Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers