Network traffic plugin must discard data for unmounted interface

Bug #641264 reported by Thomas Herve on 2010-09-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Critical
Thomas Herve
landscape-client (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Right now, if you unmount an interface, and then remount it we'll try to compare the traffic between the 2 mounts, but I *think* the /proc/net/dev values are resetted. We should discard the value in memory as well.

Changed in landscape-client:
milestone: 1.5.5 → 1.5.5.1
Thomas Herve (therve) on 2010-09-17
Changed in landscape-client:
status: New → In Progress
Andreas Hasenack (ahasenack) wrote :

Tried the 1.5.5 version with therve's trick (remove the network module) and indeed there was a huge jump in traffic. Then I applied the patch and repeated the trick, and there was no such spike.

qa + 1

Thomas Herve (therve) on 2010-09-20
Changed in landscape-client:
status: In Progress → Fix Committed
Chuck Short (zulcss) wrote :

Change log:

landscape-client (1.5.5.1-0ubuntu0.10.10.0) maverick; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

And i have attached the debdiff as well:

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.10.10.0

---------------
landscape-client (1.5.5.1-0ubuntu0.10.10.0) maverick; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Maverick):
status: New → Fix Released
Andreas Hasenack (ahasenack) wrote :

Confirmed working with the lucid, karmic and jaunty packages built from those branches.

Andreas Hasenack (ahasenack) wrote :

Oh, and maverick too, of course (before the release).

Scott Kitterman (kitterman) wrote :

Unsubscribing the release team to get it off the team buglist.

Martin Pitt (pitti) wrote :

The current upload in lucid-proposed queue includes two changelogs/new versions: 1.5.5-0ubuntu0.10.04.0 and 1.5.5.1-0ubuntu0.10.04.0. Please reupload the source package using debuild -v1.5.4-0ubuntu0.10.04.0, so that both of them are included into the source.changes, and all bugs of 1.5.5-0ubuntu0.10.04.0 are covered as well.

Chuck Short (zulcss) wrote :

done

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Changed in landscape-client (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted landscape-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Jaunty):
status: New → Fix Committed
Andreas Hasenack (ahasenack) wrote :

Tested this specific fix in the 1.5.5.1 jaunty package, it's working.

Andreas Hasenack (ahasenack) wrote :

Also working for 1.5.5.1-0ubuntu0.9.10.0 and 1.5.5.1-0ubuntu0.10.04.0 from proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.10.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.10.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches