Payload with multiple user activities: only one is carried out

Bug #617624 reported by Andreas Hasenack on 2010-08-13
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
High
Free Ekanayaka
landscape-client (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

It was first seen when deleting several users in one big activity. Only one user would be deleted.

After some experimenting, turns out that whenever more than one user related activity is in a payload, only one is carried out.

Here is an example for the deleting multiple users case:

2010-08-18 10:48:28,434 DEBUG [Dummy-1 ] Received payload:
{'client-accepted-types-hash': 'W\xda\xb7\xc6\xe9Q\xd3=\xf8;^\xed7\xae\xd6\xf2',
 'messages': [{'delete-home': True,
               'operation-id': 126069,
               'type': 'remove-user',
               'uid': 1001,
               'username': u'another'},
              {'delete-home': True,
               'operation-id': 126070,
               'type': 'remove-user',
               'uid': 1000,
               'username': u'new2'}],
 'next-expected-sequence': 53659,
 'server-uuid': '7c6efe47-12fb-11de-91bb-0016353c8658'}
2010-08-18 10:48:28,439 INFO [MainThread] Switching to normal exchange mode.
2010-08-18 10:48:28,537 DEBUG [MainThread] Started firing message.
2010-08-18 10:48:28,537 DEBUG [MainThread] Calling landscape.broker.ping.Pinger._handle_set_intervals() for message with priority 0.
2010-08-18 10:48:28,537 DEBUG [MainThread] Calling landscape.broker.server.BrokerServer.broadcast_message() for message with priority 0.
2010-08-18 10:48:28,538 DEBUG [MainThread] Finished firing message.
2010-08-18 10:48:28,540 DEBUG [MainThread] Started firing message.
2010-08-18 10:48:28,540 DEBUG [MainThread] Calling landscape.broker.ping.Pinger._handle_set_intervals() for message with priority 0.
2010-08-18 10:48:28,540 DEBUG [MainThread] Calling landscape.broker.server.BrokerServer.broadcast_message() for message with priority 0.
2010-08-18 10:48:28,541 DEBUG [MainThread] Finished firing message.
2010-08-18 10:48:28,542 DEBUG [MainThread] Started firing exchange-done.
2010-08-18 10:48:28,542 DEBUG [MainThread] Calling landscape.broker.registration.RegistrationHandler._handle_exchange_done() for exchange-done with priority 0.
2010-08-18 10:48:28,542 DEBUG [MainThread] Finished firing exchange-done.
2010-08-18 10:48:28,542 INFO [MainThread] Message exchange completed in 1.32s.
2010-08-18 10:48:28,788 WARNING [MainThread] No message context for message with operation-id: 126070

Only the new2 user was removed:
(manager log)

2010-08-18 10:48:28,559 INFO [MainThread] Removing user new2 (UID 1000) and deleting their home directory.

Related branches

summary: - Client reporting "No message context" warnings in the logs
+ Payload with multiple user activities: only one is carried out
description: updated
Changed in landscape-client:
importance: Low → High
milestone: later → 1.5.5
description: updated
Andreas Hasenack (ahasenack) wrote :
Download full text (4.9 KiB)

Here is an example for adding two users. This is done via two separate activities on the server, done quickly one after the other so they both get into the same payload:

2010-08-18 10:40:26,912 DEBUG [Dummy-1 ] Received payload:
{'client-accepted-types-hash': 'W\xda\xb7\xc6\xe9Q\xd3=\xf8;^\xed7\xae\xd6\xf2',
 'messages': [{'home-number': None,
               'location': None,
               'name': u'new1',
               'operation-id': 126065,
               'password': u'2010-08-18 10:39:25,404 INFO ',
               'primary-group-name': None,
               'require-password-reset': True,
               'type': 'add-user',
               'username': u'new1',
               'work-number': None},
              {'home-number': None,
               'location': None,
               'name': u'new2',
               'operation-id': 126067,
               'password': u'2010-08-18 10:39:25,404 INFO ',
               'primary-group-name': None,
               'require-password-reset': True,
               'type': 'add-user',
               'username': u'new2',
               'work-number': None}],
 'next-expected-sequence': 53648,
 'server-uuid': '7c6efe47-12fb-11de-91bb-0016353c8658'}
2010-08-18 10:40:26,917 INFO [MainThread] Switching to normal exchange mode.
2010-08-18 10:40:26,986 DEBUG [MainThread] Started firing message.
2010-08-18 10:40:26,986 DEBUG [MainThread] Calling landscape.broker.ping.Pinger._handle_set_intervals() for message with priority 0.
2010-08-18 10:40:26,986 DEBUG [MainThread] Calling landscape.broker.server.BrokerServer.broadcast_message() for message with priority 0.
2010-08-18 10:40:26,987 DEBUG [MainThread] Finished firing message.
2010-08-18 10:40:26,989 DEBUG [MainThread] Started firing message.
2010-08-18 10:40:26,990 DEBUG [MainThread] Calling landscape.broker.ping.Pinger._handle_set_intervals() for message with priority 0.
2010-08-18 10:40:26,990 DEBUG [MainThread] Calling landscape.broker.server.BrokerServer.broadcast_message() for message with priority 0.
2010-08-18 10:40:26,990 DEBUG [MainThread] Finished firing message.
2010-08-18 10:40:26,991 DEBUG [MainThread] Started firing exchange-done.
2010-08-18 10:40:26,991 DEBUG [MainThread] Calling landscape.broker.registration.RegistrationHandler._handle_exchange_done() for exchange-done with priority 0.
2010-08-18 10:40:26,991 DEBUG [MainThread] Finished firing exchange-done.
2010-08-18 10:40:26,991 INFO [MainThread] Message exchange completed in 1.59s.
2010-08-18 10:40:27,621 WARNING [MainThread] No message context for message with operation-id: 126067
2010-08-18 10:40:57,224 INFO [MainThread] Ping indicates message available. Scheduling an urgent exchange.
2010-08-18 10:41:17,606 DEBUG [MainThread] Started firing impending-exchange.
2010-08-18 10:41:17,606 DEBUG [MainThread] Calling landscape.broker.server.BrokerServer.broadcast_event() for impending-exchange with priority 0.
2010-08-18 10:41:17,607 DEBUG [MainThread] Finished firing impending-exchange.
2010-08-18 10:41:27,219 INFO [MainThread] Ping indicates message available. Scheduling an urgent exchange.
2010-08-18 10:41:27,604 DEBUG [Mai...

Read more...

Changed in landscape-client:
assignee: nobody → Free Ekanayaka (free.ekanayaka)
status: New → In Progress
Changed in landscape-client:
status: In Progress → Fix Committed
tags: added: needs-testing
Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the maverick package.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the Lucid and Karmic packages.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the Jaunty package.

Colin Watson (cjwatson) wrote :

landscape-client (1.5.5-0ubuntu0.10.10.0) maverick; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).

 -- Andreas Hasenack <email address hidden> Wed, 08 Sep 2010 15:34:09 -0400

Changed in landscape-client (Ubuntu):
status: New → Fix Released
Changed in landscape-client:
milestone: 1.5.5 → 1.5.5.1
Andreas Hasenack (ahasenack) wrote :

Please drop the nomination for Maverick, as this was fixed in 1.5.5.

Changed in landscape-client (Ubuntu):
status: Fix Released → Fix Committed
tags: removed: needs-testing
description: updated

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Changed in landscape-client (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted landscape-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Jaunty):
status: New → Fix Committed
Andreas Hasenack (ahasenack) wrote :

Confirmed working with 1.5.5.1-0ubuntu0.9.04.0, 1.5.5.1-0ubuntu0.10.04.0 and 1.5.5.1-0ubuntu0.9.10.0 from proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.10.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.10.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: Fix Committed → Fix Released
Changed in landscape-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers