Update jaunty, karmic, lucid and maverick to landscape-client 1.5.4

Bug #610744 reported by Free Ekanayaka on 2010-07-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Undecided
Unassigned
landscape-client (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Landscape Client 1.5.4 has been released. We would like to get these changes into Maverick, Lucid, Karmic and Jaunty.

As far as released version of Ubuntu are concerned, the required pieces of information for the needed SRU follow (as laid out in the "Procedure" section of https://wiki.ubuntu.com/StableReleaseUpdates).

=== Statement explaining the impact ===

This release sports both bug-fixes and new features and we would like to make sure all of our supported customers (even those on Jaunty, Karmic and Lucid) have access to these improvements. The notable ones are:

1) The Eucalyptus management plugin now reports the output of the 'euca-describe-availability-zones verbose' command, which includes information about the available instance types and the maximum number of each instance type that the cloud can support.

2) Check if the package directory exists before trying to check the package changer lock in the dbus-proxy. This fixes a bug when upgrading a dbus-landscape which never registered.

3) Allow an LDS server to bootstrap new cloud instances with its own CA, which is picked up by the client, written to a file on the instance, and used in subsequent exchanges with the server.

4) Skip loopback interface when reporting device info.

5) Disable landscape-sysinfo when load is more than 1.

For more details see Bug #599338, Bug #603514, Bug #605079, Bug #608314, and Bug #608278 (all mentioned in the debian/changelog of the proposed packages).

=== How the bug has been addressed ===

We have been following the development procedure laid out in https://wiki.ubuntu.com/LandscapeUpdates

=== Patches ===

The three branches for the new landscape-client jaunty, karmic and lucid source packages are attached to this bug, and were derived from

lp:ubuntu/jaunty-updates/landscape-client
lp:ubuntu/karmic-updates/landscape-client
lp:ubuntu/lucid-updates/landscape-client

respectively.

=== Detailed instructions how to reproduce the bug ===

N/A

=== Discussion ===

All the source packages have been subject to the QA process detailed in the LandscapeUpdates document linked above.

=== How the bug has been addressed ===

We have been following the development procedure laid out in https://wiki.ubuntu.com/LandscapeUpdates

Free Ekanayaka (free.ekanayaka) wrote :

The profile in question was a "broken" one, meaning one that got its associated package retired at some point (it was before we implemented the fix for not retiring profile packages). Everything seem to work when bumping the profile in question (that re-generates its associated package) or creating a new profile.

Free Ekanayaka (free.ekanayaka) wrote :

Ooops, wrong bug :) Discard the previous commend.

Jonathan Riddell (jr) wrote :

Needs approval from ubuntu-sru, now subscribed

Martin Pitt (pitti) wrote :

Closing maverick task:

landscape-client | 1.5.4-0ubuntu0.10.10.0 | maverick | source, amd64, i386

affects: ubuntu → landscape-client (Ubuntu)
Changed in landscape-client (Ubuntu Maverick):
status: New → Fix Released
Changed in landscape-client:
status: New → Invalid
Martin Pitt (pitti) wrote :

Can you please walk through the bugs again and update the upstream and maverick status? I added the SRU tasks and Ubuntu package tasks (I'd appreciate if I wouldn't have to do all that each time, BTW).

A lot of the bugs are still open upstream, or targetted wrongly. For example, bug 605079 is targetted at 1.5.5, and not even fix committed, and the others should be "fix released", not just "committed", if it's fixed in 1.5.4 (which is released).

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Free Ekanayaka (free.ekanayaka) wrote :

I've updated the upstream status of the bugs to "Fix released".

The one you report (bug 605079) was indeed erroneously still not marked as "Fix committed" and so it got automatically shifted to milestone 1.5.5 by a script that we run at the end of the milestone. I didn't find any other bug with the wrong milestone though, note that we push a new SRU only every two releases, so in this SRU there bugs targeted to both 1.5.3 and 1.5.4, hope it's fine.

As mentioned on IRC, I didn't create tasks for all the bugs because at some point someone told me that it was fine to do that for the main SRU bug only, for reducing the overhead. If you prefer to have individual tasks for all the bugs linked to the main SRU request bug, please let me know and I'll do that next time.

Thanks!

Martin Pitt (pitti) wrote :

Accepted landscape-client into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Jaunty):
status: New → Fix Committed
Changed in landscape-client (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted landscape-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.4-0ubuntu0.10.04.0

---------------
landscape-client (1.5.4-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * New upstream version (LP: #610744):

    - The Eucalyptus management plugin reports the output of the
      'euca-describe-availability-zones verbose' command, which includes
      information about the available instance types and the maximum
      number of each instance type that the cloud can support (LP: #599338)

    - Check if the package directory exists before trying to check the
      package changer lock in the dbus-proxy. This fixes a bug when upgrading
      a dbus-landscape which never registered (LP: #603514).

    - Allow an LDS server to bootstrap new cloud instances with its own CA,
      which is picked up by the client, written to a file on the instance, and
      used in subsequent exchanges with the server (LP: #605079).

    - Skip loopback interface when reporting device info (LP: #608314)

    - Disable landscape-sysinfo when load is more than 1 (LP: #608278)
 -- Free Ekanayaka <email address hidden> Wed, 28 Jul 2010 08:14:02 +0200

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.4-0ubuntu0.9.04.0

---------------
landscape-client (1.5.4-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream version (LP: #610744):

    - The Eucalyptus management plugin reports the output of the
      'euca-describe-availability-zones verbose' command, which includes
      information about the available instance types and the maximum
      number of each instance type that the cloud can support (LP: #599338)

    - Check if the package directory exists before trying to check the
      package changer lock in the dbus-proxy. This fixes a bug when upgrading
      a dbus-landscape which never registered (LP: #603514).

    - Allow an LDS server to bootstrap new cloud instances with its own CA,
      which is picked up by the client, written to a file on the instance, and
      used in subsequent exchanges with the server (LP: #605079).

    - Skip loopback interface when reporting device info (LP: #608314)

    - Disable landscape-sysinfo when load is more than 1 (LP: #608278)
 -- Free Ekanayaka <email address hidden> Wed, 28 Jul 2010 08:14:02 +0200

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.4-0ubuntu0.9.10.0

---------------
landscape-client (1.5.4-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * New upstream version (LP: #610744):

    - The Eucalyptus management plugin reports the output of the
      'euca-describe-availability-zones verbose' command, which includes
      information about the available instance types and the maximum
      number of each instance type that the cloud can support (LP: #599338)

    - Check if the package directory exists before trying to check the
      package changer lock in the dbus-proxy. This fixes a bug when upgrading
      a dbus-landscape which never registered (LP: #603514).

    - Allow an LDS server to bootstrap new cloud instances with its own CA,
      which is picked up by the client, written to a file on the instance, and
      used in subsequent exchanges with the server (LP: #605079).

    - Skip loopback interface when reporting device info (LP: #608314)

    - Disable landscape-sysinfo when load is more than 1 (LP: #608278)
 -- Free Ekanayaka <email address hidden> Wed, 28 Jul 2010 08:14:02 +0200

Changed in landscape-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers