Landscape manager fails to acquire lock for its socket

Bug #607747 reported by Free Ekanayaka on 2010-07-20
140
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Landscape Client
High
Free Ekanayaka
landscape-client (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

It happened on Barry's Maverick installation.

Related branches

Changed in landscape-client:
assignee: nobody → Free Ekanayaka (free.ekanayaka)
Barry Warsaw (barry) wrote :
Andreas Hasenack (ahasenack) wrote :

Reproduced and debugged. The issue happens when a stale lock file exists in /var/lib/landscape/client/sockets and its stale PID points to an existing process that is still running.

Changed in landscape-client:
importance: Undecided → High
milestone: none → 1.5.5
status: New → In Progress
Changed in landscape-client:
status: In Progress → Fix Committed
tags: added: needs-testing
Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the maverick package.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the Lucid and Karmic packages.

Colin Watson (cjwatson) wrote :

landscape-client (1.5.5-0ubuntu0.10.10.0) maverick; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).

 -- Andreas Hasenack <email address hidden> Wed, 08 Sep 2010 15:34:09 -0400

Changed in landscape-client (Ubuntu):
status: New → Fix Released
Changed in landscape-client:
milestone: 1.5.5 → 1.5.5.1
solarisfire (sg-solarisfire) wrote :

So how would one go about getting this fix in Lucid?

Andreas Hasenack (ahasenack) wrote :

It will be in lucid-proposed shortly, and a week after that in lucid-updates. We postponed it to 1.5.5.1 because we want to get a fix for bug #641264 in as well.

Andreas Hasenack (ahasenack) wrote :

In the meantime, if you are in a situation where landscape-client gets restarted frequently, and are thus more susceptible to this bug, I suggest to clean up the lock files in the "stop" target of the landscape-client initscript. Something like "rm -f /var/lib/landscape/client/sockets/*lock".

Andreas Hasenack (ahasenack) wrote :

The nomination for Maverick can be dropped, as it was fixed in 1.5.5.

Changed in landscape-client (Ubuntu):
status: Fix Released → Fix Committed
tags: removed: needs-testing
Martin Pitt (pitti) wrote :

I suppose these bugs are fixed in 1.5.5.1, which is in maverick.

Changed in landscape-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted landscape-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Jaunty):
status: New → Fix Committed
Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in 1.5.5.1-0ubuntu0.9.10.0 from proposed repository for karmic.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in 1.5.5.1-0ubuntu0.10.04.0 from the lucid proposed repository.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in 1.5.5.1-0ubuntu0.9.04.0 from the jaunty proposed repository.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.10.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.10.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers