get_active_interfaces reports duplicated interfaces

Bug #597000 reported by Andreas Hasenack on 2010-06-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
High
Thomas Herve
landscape-client (Ubuntu)
High
Free Ekanayaka
Jaunty
High
Free Ekanayaka
Karmic
High
Free Ekanayaka
Lucid
High
Free Ekanayaka

Bug Description

2010-06-21T18:48:42 ERROR SiteError https://staging.landscape.canonical.com/message-system
Traceback (most recent call last):
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/publisher/publish.py", line 134, in publish
    result = publication.callObject(request, obj)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/app/publication/zopepublication.py", line 205, in callObject
    return mapply(ob, request.getPositionalArguments(), request)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/publisher/publish.py", line 109, in mapply
    return debug_call(obj, args)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/publisher/publish.py", line 115, in debug_call
    return obj(*args)
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/browser/message/message.py", line 38, in __call__
    result = message_system.dispatch(self.request)
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/message/system.py", line 45, in dispatch
    return message_api.run()
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/message/messageapis.py", line 159, in run
    self.computer.consecutive_errors += 1
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/security/policy.py", line 35, in checkPermission
    decision = checker(permission)
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/security/policy.py", line 84, in __call__
    self._roles = self.get_roles()
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/security/checkers.py", line 299, in get_roles
    roles = self.context.get_license_roles().copy()
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/model/main/computer.py", line 276, in get_license_roles
    return self.account.get_license_roles_by_computer(self)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/references.py", line 148, in __get__
    if self._relation.local_variables_are_none(local):
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/references.py", line 551, in local_variables_are_none
    if local_info.variables[column].get() is not None:
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/store.py", line 901, in _resolve_lazy_value
    result = self._connection.execute(Select(autoreload_columns, where))
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/databases/postgres.py", line 249, in execute
    return Connection.execute(self, statement, params, noresult)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/database.py", line 229, in execute
    self._event.emit("register-transaction")
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/zope/zstorm.py", line 208, in register_store_with_transaction
    transaction_manager.get().join(data_manager)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/transaction/_transaction.py", line 213, in join
    self._prior_operation_failed() # doesn't return
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/transaction/_transaction.py", line 209, in _prior_operation_failed
    self._failure_traceback.getvalue())
TransactionFailedError: An operation previously failed, with traceback:

  File "/usr/lib/python2.6/threading.py", line 504, in __bootstrap
    self.__bootstrap_inner()
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/threading.py", line 484, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.6/dist-packages/twisted/python/threadpool.py", line 210, in _worker
    result = context.call(ctx, function, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/twisted/python/context.py", line 59, in callWithContext
    return self.currentContext().callWithContext(ctx, func, *args, **kw)
  File "/usr/lib/python2.6/dist-packages/twisted/python/context.py", line 37, in callWithContext
    return func(*args,**kw)
  File "/usr/lib/python2.6/dist-packages/twisted/web/wsgi.py", line 313, in run
    appIterator = self.application(self.environ, self.startResponse)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/app/wsgi/__init__.py", line 58, in __call__
    request = publish(request, handle_errors=handle_errors)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/publisher/publish.py", line 134, in publish
    result = publication.callObject(request, obj)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/app/publication/zopepublication.py", line 205, in callObject
    return mapply(ob, request.getPositionalArguments(), request)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/publisher/publish.py", line 109, in mapply
    return debug_call(obj, args)
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/zope/publisher/publish.py", line 115, in debug_call
    return obj(*args)
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/browser/message/message.py", line 38, in __call__
    result = message_system.dispatch(self.request)
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/message/system.py", line 45, in dispatch
    return message_api.run()
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/message/messageapis.py", line 153, in run
    return self._run(max_response_messages)
  File "/srv/staging.landscape.canonical.com/staging/landscape/canonical/landscape/message/messageapis.py", line 263, in _run
    self.transaction.commit()
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/transaction/_manager.py", line 93, in commit
    return self.get().commit()
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/transaction/_transaction.py", line 325, in commit
    t, v, tb = self._saveAndGetCommitishError()
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/transaction/_transaction.py", line 322, in commit
    self._commitResources()
  File "/srv/staging.landscape.canonical.com/staging/zope3/src/transaction/_transaction.py", line 414, in _commitResources
    rm.tpc_begin(self)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/zope/zstorm.py", line 239, in tpc_begin
    self._store.flush()
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/store.py", line 490, in flush
    self._flush_one(obj_info)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/store.py", line 527, in _flush_one
    result = self._connection.execute(expr)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/databases/postgres.py", line 243, in execute
    result = Connection.execute(self, Returning(statement), params)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/database.py", line 237, in execute
    raw_cursor = self.raw_execute(statement, params)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/databases/postgres.py", line 259, in raw_execute
    return Connection.raw_execute(self, statement, params)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/database.py", line 321, in raw_execute
    self._check_disconnect(raw_cursor.execute, *args)
  File "/srv/staging.landscape.canonical.com/staging/storm/storm/database.py", line 366, in _check_disconnect
    return function(*args, **kwargs)
IntegrityError: duplicate key value violates unique constraint "network_device_computer_id_key"

That's staging.landscape.canonical.com at rev 684.

Andreas Hasenack (ahasenack) wrote :

BTW, trunk was merged into staging just before that (or about so)

Andreas Hasenack (ahasenack) wrote :

Client /var/lib/landscape directory

Andreas Hasenack (ahasenack) wrote :

And now logs, with debug enabled at the end

Thomas Herve (therve) on 2010-06-21
Changed in landscape-client:
assignee: nobody → Thomas Herve (therve)
Thomas Herve (therve) on 2010-06-22
summary: - 1.5.2~bzr265 client breaks staging
+ get_active_interfaces reports duplicated interfaces
Changed in landscape-client:
status: New → In Progress
Thomas Herve (therve) on 2010-06-22
Changed in landscape-client:
status: In Progress → Fix Committed
Jonathan Riddell (jr) wrote :

A package has been uploaded to ubuntu jaunty-proposed (landscape-client_1.5.2.1-0ubuntu0.9.04.0) pointing at this bug. However there's no patch on this bug, ubuntu-sru aren't subscribed, the bug isn't marked as affecting ubuntu jaunty, there's no test case and it overlaps with another upload (1.5.2-0ubuntu0.9.04.0)

Mathias Gug (mathiaz) on 2010-07-02
Changed in landscape-client (Ubuntu):
status: New → Fix Released
Changed in landscape-client (Ubuntu Lucid):
assignee: nobody → Ekanayaka (ekanayaka)
assignee: Ekanayaka (ekanayaka) → Free Ekanayaka (free.ekanayaka)
Changed in landscape-client (Ubuntu Karmic):
assignee: nobody → Free Ekanayaka (free.ekanayaka)
Changed in landscape-client (Ubuntu Jaunty):
assignee: nobody → Free Ekanayaka (free.ekanayaka)
importance: Undecided → High
Changed in landscape-client (Ubuntu Karmic):
importance: Undecided → High
Changed in landscape-client (Ubuntu Lucid):
importance: Undecided → High
Changed in landscape-client (Ubuntu):
importance: Undecided → High
assignee: nobody → Free Ekanayaka (free.ekanayaka)
Mathias Gug (mathiaz) wrote :

@Free: Please prepare a normal SRU report as this is a bug fix in addition to bug 594594.

When the package is uploaded include *all* the versions since the one in -updates. In this use case the lucid package should be built with the following option: -v1.5.0.1-0ubuntu0.10.04.0.

tags: added: needs-testing
John Dong (jdong) wrote :

An upload for this version is in lucid-proposed. I don't see a SRU writeup (verification procedure, regression potential) for this bug, but there is a very detailed one for the previous verion.

Can this be added to the bug report in the meantime? I'll give an ACK on the content of the patch.

Free Ekanayaka (free.ekanayaka) wrote :

Please see Bug #594594 for the full SRU writeup. I've updated it to include the two additional bugs (this one and Bug #596062) that have been addressed since the original SRU writeup was filed.

John Dong (jdong) wrote :

Thanks for the clarification. With this additional information, I am going to ACK this patch :)

Martin Pitt (pitti) wrote :

The current upload does not only contain 1.5.2.1-0ubuntu0.10.04.0, but also a previous changelog record 1.5.2-0ubuntu0.10.04.0. Please either merge them into one changelog record/version (i. e. 1.5.2.1-0ubuntu0.10.04.0 mentions all the bugs from 1.5.2 as well), or build the .changes with -v1.5.0.1-0ubuntu0.10.04.0.

Martin Pitt (pitti) wrote :

The karmic upload on the other hand now references all changelog entries _ever_ (http://launchpadlibrarian.net/51628004/landscape-client_1.5.2.1-0ubuntu0.9.10.0_source.changes) and thus a million bugs. Please reupload with the correct -v1.5.0.1-0ubuntu0.9.10.0. Thanks!

Martin Pitt (pitti) wrote :

Karmic .changes bug also applies to jaunty version, please fix and reupload.

Chuck Short (zulcss) wrote :

done

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted landscape-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted landscape-client into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Jaunty):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.2.1-0ubuntu0.9.04.0

---------------
landscape-client (1.5.2.1-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * Filter duplicate network interfaces in get_active_interfaces (LP: #597000)

landscape-client (1.5.2-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream version (LP: #594594):
    - A new includes information about active network devices and their
      IP address in sysinfo output (LP: #272344).
    - A new plugin collects information about network traffic (#LP :284662).
    - Report information about which packages requested a reboot (LP: #538253).
    - Fix breakage on Lucid AMIs having no ramdisk (LP: #574810).
    - Migrate the inter-process communication system from DBus to Twisted AMP.
 -- Free Ekanayaka <email address hidden> Mon, 28 Jun 2010 18:07:18 +0200

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.2.1-0ubuntu0.9.10.0

---------------
landscape-client (1.5.2.1-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * Filter duplicate network interfaces in get_active_interfaces (LP: #597000)

landscape-client (1.5.2-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * New upstream version (LP: #594594):
    - A new includes information about active network devices and their
      IP address in sysinfo output (LP: #272344).
    - A new plugin collects information about network traffic (#LP :284662).
    - Report information about which packages requested a reboot (LP: #538253).
    - Fix breakage on Lucid AMIs having no ramdisk (LP: #574810).
    - Migrate the inter-process communication system from DBus to Twisted AMP.
 -- Free Ekanayaka <email address hidden> Mon, 28 Jun 2010 18:07:18 +0200

Changed in landscape-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.2.1-0ubuntu0.10.04.0

---------------
landscape-client (1.5.2.1-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * Filter duplicate network interfaces in get_active_interfaces (LP: #597000)

landscape-client (1.5.2-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * New upstream version (LP: #594594):
    - A new includes information about active network devices and their
      IP address in sysinfo output (LP: #272344).
    - A new plugin collects information about network traffic (#LP :284662).
    - Report information about which packages requested a reboot (LP: #538253).
    - Fix breakage on Lucid AMIs having no ramdisk (LP: #574810).
    - Migrate the inter-process communication system from DBus to Twisted AMP.

landscape-client (1.5.0.1-0ubuntu0.10.04.0) lucid; urgency=low

  * New upstream version
    - Fix smart-update failing its very first run (LP: #562496)
    - Depend on pythonX.Y-dbus and pythonX.Y-pycurl (LP: #563063)
    - Make only one request at a time to retrieve EC2 instances (LP: #567515)
 -- Free Ekanayaka <email address hidden> Mon, 28 Jun 2010 18:07:18 +0200

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: Fix Committed → Fix Released
tags: removed: needs-testing verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers