Can't stop landscape-client from System > Administration > Services

Bug #361024 reported by Fabián Rodríguez on 2009-04-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
Landscape Client
Low
Unassigned
gnome-system-tools (Ubuntu)
Medium
Unassigned

Bug Description

Normally running services are listed under System > Administration > Services. The landscape-client service however can't be stopped on a desktop system by going there. Landscape-client should be visible and stoppable from there.

Andreas Hasenack (ahasenack) wrote :

I can confirm this. But I have no idea how services-admin (from gnome-system-tools) gets the list of services. I checked a few that are in its list and also have scripts in /etc/init.d and couldn't even find the description text that services-admin displays, so I don't know where it gets that from.

Changed in landscape-client:
importance: Undecided → Low
milestone: none → 1.0.x
status: New → Confirmed
Fabián Rodríguez (magicfab) wrote :

apt-file find services-admin tells me it's part of gnome-system-tools.

Looking at the changelog:
http://changelogs.ubuntu.com/changelogs/pool/main/g/gnome-system-tools/gnome-system-tools_2.22.2-0ubuntu3/changelog

... I see Daniel Holbach and James Westby have contributed fixes/changes related to services in the past. I've subscribed them so they can pitch in or perhaps suggest how to go about this.

Integration of the Landscape client to the desktop as an applet that would make it easy to watch what it does via notifications but also control it has been discussed informally in the past, so perhaps this could open the way for that to eventually happen.

Daniel Holbach (dholbach) wrote :

Do you want to milestone this?

The change needs to happen in src/common/gst-service-role.c and needs to be of the form
{ "postgresql-8.2", GST_ROLE_DATABASE_SERVER },

So maybe
{ "landscape-client", GST_ROLE_SYSTEM_MONITORING },

Check out src/common/gst-service-role.h for the list of roles.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Andreas Hasenack (ahasenack) wrote :

This can't be fixed in landscape-client itself, so I'm marking it as invalid for it.

Changed in landscape-client:
status: Confirmed → Invalid
Milan Bouchet-Valat (nalimilan) wrote :

I've just pushed the fix as explained by Daniel as commit 72c72fa. Sadly, it won't be available until GNOME 2.30, since we're now frozen. Possibly for a minor 2.28.1 release, but I'd need to know whether some Ubuntu developers are interested in uploading it.

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Changed in gst:
status: New → Fix Committed

On Fri Sep 18 13:33:25 UTC 2009 Milan Bouchet-Valat wrote:
> I've just pushed the fix as explained by Daniel as commit 72c72fa.
> Sadly, it won't be available until GNOME 2.30, since we're now frozen.
> Possibly for a minor 2.28.1 release, but I'd need to know whether some
> Ubuntu developers are interested in uploading it.

As we have now moved to Upstart for some services, which doesn't
yet have a general mechanism for disabling services (though there
are various ways to acheive it), that we should perhaps not ship/hide
by default services-admin in karmic.

Do you know if there has been any work to get it supporting upstart?

Thanks,

James

Milan Bouchet-Valat (nalimilan) wrote :

Yeah, the fix was just so easy that I pushed it anyways, but the long term solution is different. See bug 433701: services-admin is not shipped in Karmic now.

As I said on the other report, I'd like somebody to give a look at what should be done to support upstart and improve the GUI. We're now two (!) working on the g-s-t, so we can help - but maybe not do all the work by ourselves...

Milan Bouchet-Valat (nalimilan) wrote :

This is fixed for a long time in Lucid, since the change was pushed in gnome-system-tools at the beginning of the cycle.

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Fix Released
Changed in gst:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers