upgrade activity failing with "The following packages have unmet dependencies: lxd: Unknown dependency error"

Bug #1668583 reported by Junien Fridrick on 2017-02-28
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Critical
Björn Tillenius
landscape-client (Ubuntu)
Critical
Andreas Hasenack
Trusty
Critical
Andreas Hasenack
Xenial
Critical
Andreas Hasenack
Yakkety
Critical
Andreas Hasenack

Bug Description

Hi,

I have an upgrade activity that is failing with the following error message :

The following packages have unmet dependencies:
  lxd: Unknown dependency error

This is on xenial.

[Impact]
In a lot of cases, landscape-client can't update packages on xenial machines if lxd is installed.

[Test case]
Register a fresh xenial machine with landscape.canonical.com. (Install landscape-client and run 'sudo landscape-config'). After the registration is done, go to Landscape, accept the pending computer and wait for package information to sync. Without the fix, there should be an upgrade for lxd and lxd-client available to the version that is in xenial-backports. With the patch, there won't be any upgrade available.

[Regression potnentials]
Users won't be able to install packages from backports. This is OK, though, since Landscape doesn't support that officially.
Potentially also, the introduced change can influence and break package upgrade behavior.

Related branches

Junien Fridrick (axino) wrote :
Changed in landscape-client:
assignee: nobody → Björn Tillenius (bjornt)
status: New → In Progress
Björn Tillenius (bjornt) wrote :

I haven't figured out exactly where the problem is, but a symptom of the problem is this:

  Upgrade package lxd 2.0.5-0ubuntu1~ubuntu16.04.1 to 2.8-0ubuntu1~ubuntu16.04.1

(from https://landscape.is.canonical.com/account/standalone/activity/2208329, computer 12351)

2.8 is from xenial-backports, and Landscape shouldn't try to upgrade to it.

Björn Tillenius <email address hidden> writes:

> I haven't figured out exactly where the problem is, but a symptom of the
> problem is this:
>
> Upgrade package lxd 2.0.5-0ubuntu1~ubuntu16.04.1 to
> 2.8-0ubuntu1~ubuntu16.04.1
>
> (from
> https://landscape.is.canonical.com/account/standalone/activity/2208329,
> computer 12351)
>
> 2.8 is from xenial-backports, and Landscape shouldn't try to upgrade to
> it.

Is this not the same problem as LP #1661103 except with an implicit
pin (-backports)?

--
James

Björn Tillenius (bjornt) wrote :

This is similar to bug 1661103, yes. Both could be fixed by adding proper support for pinning to Landscape.

But making Landscape respect pinning is quite a lot of work. This bug is more severe, since backports now is enabled by default. So I'm considering doing something special for this case, like ignoring packages that come from $release-backports, or packages that have a policy value of 100.

Maybe even ignoring packages that have a policy value less than 500 would help both for this bug and bug 1661103?

Björn Tillenius (bjornt) wrote :

Marking this as critical, since it prevents upgrades from happening, and we need to SRU this fix as soon as possible.

Changed in landscape-client:
importance: Undecided → Critical
Björn Tillenius (bjornt) wrote :

FWIW, it's possible to work around this by either marking lxd and lxd-client as held, or using the "Request upgrades" button in the "Packages" tab.

The "Request upgrades" button will basically do a "apt-get dist-upgrade", so pinning will be respected.

Changed in landscape-client:
status: In Progress → Fix Committed
Changed in landscape-client (Ubuntu):
status: New → Confirmed
Björn Tillenius (bjornt) wrote :
Björn Tillenius (bjornt) wrote :
description: updated
Björn Tillenius (bjornt) wrote :

This fix needs to be uploaded to zesty, and then xenial. See attached debdiffs.

Andreas Hasenack (ahasenack) wrote :

Uploaded to zesty, with a slight change in the debdiff: version is 16.03-0ubuntu3, not 0ubuntu2.17.04.1.

Changed in landscape-client (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
importance: Undecided → Critical
status: Confirmed → In Progress
Changed in landscape-client (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Andreas Hasenack (ahasenack)
Andreas Hasenack (ahasenack) wrote :

Uploaded to xenial:

[ubuntu/xenial-proposed] landscape-client 16.03-0ubuntu2.16.04.1 (Waiting for approval)

Björn Tillenius (bjornt) wrote :

I built a package for trusty, uploaded to ppa:bjornt/test and confirmed that it works. See attached debdiff.

Björn Tillenius (bjornt) wrote :

I built a package for yakkety, uploaded it to ppa:bjornt/test and confirmed that it works. See attached debdiff.

Andreas Hasenack (ahasenack) wrote :

Yakkety and trusty uploaded.

Changed in landscape-client (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in landscape-client (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Andreas Hasenack (ahasenack)
Brian Murray (brian-murray) wrote :

I don't see a new version of landscape-client in Zesty which fixes this, setting to Incomplete for all tasks to prevent accidental acceptance of this by other SRU team members.

Changed in landscape-client (Ubuntu Trusty):
status: In Progress → Incomplete
Changed in landscape-client (Ubuntu Xenial):
status: In Progress → Incomplete
Changed in landscape-client (Ubuntu Yakkety):
status: In Progress → Incomplete
Andreas Hasenack (ahasenack) wrote :

It's in the upload queue, pending approval by someone from the release team:

https://launchpad.net/ubuntu/zesty/+queue?queue_state=1&queue_text=landscape-client

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu3

---------------
landscape-client (16.03-0ubuntu3) zesty; urgency=medium

  * Don't report packages that are coming from backports, so that Landscape
    doesn't try to upgrade to versions of packages that are in backports.
    (LP: #1668583)

 -- Bjorn Tillenius <email address hidden> Mon, 20 Mar 2017 10:25:40 +0000

Changed in landscape-client (Ubuntu):
status: In Progress → Fix Released

Hello Junien, or anyone else affected,

Accepted landscape-client into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/16.03-0ubuntu2.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in landscape-client (Ubuntu Yakkety):
status: Incomplete → Fix Committed
tags: added: verification-needed
Changed in landscape-client (Ubuntu Xenial):
status: Incomplete → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Junien, or anyone else affected,

Accepted landscape-client into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/16.03-0ubuntu2.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Łukasz Zemczak (sil2100) wrote :

As for trusty - I will try handling that one as well, but it seems the upload there has more changes so needs a bit more review-time.

Andreas Hasenack (ahasenack) wrote :

Please ignore the 14.12-0ubuntu4.14.04 landscape-client package. That's from a previous SRU that didn't make it. 0ubuntu5, the package I uploaded, only has the change for this bug.

Andreas Hasenack (ahasenack) wrote :

I meant the previous comment in the context of the trusty package upload.

Björn Tillenius (bjornt) wrote :

I created a new xenial VM, installed landscape-client from xenial-proposed and registered it with landscape.canonical.com. I confirmed that it no longer wants to upgrade lxd to the version in backports and that upgrading all the packages works if you select "All upgrades".

I also upgraded landscape-client from xenial-proposed on computer 12221 in IS' Landscape deployment and confirmed that it doesn't want to upgrade lxd to the version in backports anymore. I didn't try an upgrade, since I don't have permission to do that. Junien, if you could try an upgrade of computer 12221, it would be appreciated.

Łukasz Zemczak (sil2100) wrote :

Hello Junien, or anyone else affected,

Accepted landscape-client into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu5.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Trusty):
status: Incomplete → Fix Committed
Junien Fridrick (axino) wrote :

@bjornt : it's done (and successful !), see activity 2719117

Thanks !

Björn Tillenius (bjornt) wrote :

I think that all uploaded packages are ready to go from -proposed to -updates. For xenial and and trusty I both created new VMs with landscape-client installed from -proposed, and installed landscape-client from -proposed on existing machines that already were registered with Landscape.

For yakkety, I didn't have an existing machine, so I only created a VM and installed landscape-client from -proposed, and registered it with Landscape.

I've confirmed that no machines that have landscape-client from -proposed reports packages from -backports. I've also confirmed that both manual upgrades and automatic upgrades through upgrade profiles work. The machines have successfully communicated with Landscape, performed upgrades, and reporting information since almost a week now. I haven't noticed any problems so far.

The original reporter also confirmed that the package from xenial-proposed fixed his original problem.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu2.16.04.1

---------------
landscape-client (16.03-0ubuntu2.16.04.1) xenial; urgency=medium

  * Don't report packages that are coming from backports, so that Landscape
    doesn't try to upgrade to versions of packages that are in backports.
    (LP: #1668583)

 -- Bjorn Tillenius <email address hidden> Mon, 20 Mar 2017 10:25:40 +0000

Changed in landscape-client (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for landscape-client has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu5.14.04

---------------
landscape-client (14.12-0ubuntu5.14.04) trusty; urgency=medium

  * Don't report packages that are coming from backports, so that Landscape
    doesn't try to upgrade to versions of packages that are in backports.
    (LP: #1668583)

 -- Bjorn Tillenius <email address hidden> Thu, 23 Mar 2017 09:45:14 +0000

Changed in landscape-client (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu2.16.10.1

---------------
landscape-client (16.03-0ubuntu2.16.10.1) yakkety; urgency=medium

  * Don't report packages that are coming from backports, so that Landscape
    doesn't try to upgrade to versions of packages that are in backports.
    (LP: #1668583)

 -- Bjorn Tillenius <email address hidden> Mon, 20 Mar 2017 10:25:40 +0000

Changed in landscape-client (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers