make sourcepackage is broken

Bug #1658796 reported by Ursula Junque on 2017-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Undecided
Ursula Junque
landscape-client (Ubuntu)
Undecided
Andreas Hasenack

Bug Description

As of r931, make sourcepackage is broken. It fails showing a diff from the orig file, saying .bzr-builddeb isn't there. Tested on trusty.

make sdist is responsible for creating the source tarball, using "bzr export" to copy files to a temporary sdist folder. Issue is that command ignores the hidden files, leaving the checked in .bzr-builddeb directory behind. When the step to build the actual package runs, it finds the diff as that directory is missing and fails:

{{{
dpkg-source: info: local changes detected, the modified files are:
 trunk/.bzr-builddeb/default.conf
dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/landscape-client_16.08+bzr931-0ubuntu0.diff.EGdtaU
dpkg-source: info: you can integrate the local changes with dpkg-source --commit
dpkg-buildpackage: error: dpkg-source -b trunk gave error exit status 2
debuild: fatal error at line 1364:
dpkg-buildpackage -rfakeroot -d -us -uc -S failed
make: *** [sourcepackage] Error 29
}}}

To fix this, we need to add a line to Makefile so these are copied over, or delete the directory altogether before running make sourcepackage.

Related branches

Ursula Junque (ursinha) on 2017-01-23
description: updated
description: updated
Revision history for this message
Adam Collard (adam-collard) wrote :

Hmm, I can see this but not when I rm -r .bzr-builddeb. - it doesn't appear to be related to the recent changes (i get the same issue on r929)

Ursula, can you confirm that you're able to reproduce this on a clean checkout?

Changed in landscape-client:
status: New → Invalid
Revision history for this message
Ursula Junque (ursinha) wrote :

.bzr-builddeb is checked in. I can reproduce the problem by just branching trunk and running make sourcepackage (trusty and xenial, on my host or container). The issue is the conflicting file is checked in and not part of the orig tarball, hence the error.

Changed in landscape-client:
status: Invalid → Incomplete
status: Incomplete → New
Ursula Junque (ursinha) on 2017-01-25
Changed in landscape-client:
status: New → In Progress
assignee: nobody → Ursula Junque (ursinha)
Revision history for this message
Ursula Junque (ursinha) wrote :

I have proposed a branch that moves .bzr-builddeb/default.conf to debian/, which solves this issue and also allows bzr builddeb to work as supposed.

Changed in landscape-client:
status: In Progress → Fix Committed
Changed in landscape-client (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package landscape-client - 18.01-0ubuntu1

---------------
landscape-client (18.01-0ubuntu1) bionic; urgency=medium

  * New upstream release 18.01:
    - Ported to python3 (LP: #1577850)
    - move Replaces/Breaks landscape-client-ui rules to landscape-common
      (LP: #1560424)
    - Add a libpam-systemd Depends if built for xenial (LP: #1590838)
    - Some units not reporting swift usage (LP: #1588404)
    - Fix missing install directories for landscape-common and drop
      usr/share/landscape as its only used and created by landscape-client.
      (LP: #1680842)
    - Fix VM detection for Xen, by returning "xen" only for paravirtualized and
      HVM hosts, not for dom0. (LP: #1601818)
    - Add an indication of truncation to process output that has been truncated
      prior to delivery to the server. (LP: #1629000)
    - add /snap/bin to the PATH when executing scripts. (LP: #1635634)
    - Save the original sources.list file when a repository profile is
      associated with a computer and restore it when the profile is removed.
      (LP: #1607529)
    - Drop the legacy HAService plugin, which is no longer used.
    - Avoid double-decoding package descriptions in build_skeleton_apt, which
      causes an error with Xenial python-apt. (LP: #1655395)
    - Remove dead dbus code and textmessage (confirmed not supported in server
      for ~2 years). (LP: #1657372)
    - Move bzr-builddeb conf file from deprecated location to debian/
      (LP: #1658796)
    - Support for new server error message about there being too many pending
      computers already (LP: #1662530)
    - Add a timestamp to the package reporter result (LP: #1674252)
    - Check if ubuntu-release-upgrader is running before apt-update (LP: #1699179)
    - Implicitly trust file-local sources managed by landscape. On upgrades,
      add the trusted flag to the landscape file-local apt source file if it's
      not there. (LP: #1736576)
    - Use local system tools to change the user's password (LP: #1743558)
  * clean up packaging and getting in sync with the new landscape version:
    - d/rules: drop extra:suggests which is unused since 13.07.1-0ubuntu2
    - Remove antique postinst code. No supported landscape-client version
      installs cronjobs anymore (since a long time).
    - d/landscape-client.docs: the README file is now a markdown file, so
      install that instead.
    - d/landscape-common.postinst: no need to single out
      /var/lib/landscape/.gnupg when fixing ownerships, just do it over
      the entire parent directory.
    - guard user and group removal via an empty .cleanup.* file in post, so we
      only remove the user/group if we were the ones who created them at
      install time.
    - lintian: remove absolute path from update-motd calls in maintainer
      scripts
    - d/rules: drop special handling for dapper, hardy and lucid, which are no
      longer supported.
    - d/rules: make sure we have an "extra:Depends=" in substvars even if it's
      empty
    - d/rules: drop dh_pycentral handling, it's obsolete
  * Dropped (already included in this version):
    - d/p/set-vm-info-to-kvm-for-aws-C5-instances.patch:
  ...

Read more...

Changed in landscape-client (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers