Update lucid, precise, trusty, utopic to landscape-client 14.12

Bug #1401523 reported by Chris Glass on 2014-12-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Medium
Unassigned
landscape-client (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

Landscape Client 14,12 has been released. We would like to get these changes into lucid, precise, trusty and utopic.

As far as released version of Ubuntu are concerned, the required pieces of information for the needed SRU follow (as laid out in the "Procedure" section of https://wiki.ubuntu.com/StableReleaseUpdates).

=== Statement explaining the impact ===

This release sports both bug-fixes and new features and we would like to make sure all of our supported customers (even those on lucid, precise, trusty and utopic) have access to these improvements. The notable ones are:

1) Upgrading the landscape client to 14.01 as part of a landscape update created a ghost activity (staying in progress forever), that users had no mean to cancel (LP: #1389686)
2) A regression was fixed where a race condition would sometimes prevent registration from functionning when a user switched landscape servers (LP: #1376134)
3) The virtual machine detection code failed when users deployed landscape-client to quemu machines. Landscape assigned them a "real machine" status which is problematic when users have only VM licenses left (LP: #1374501)
4) The client-server message format for information pertaining to juju machines was changed, since a server-side refactoring made these messages obsolete. (LP: #1369635, LP: #1362506)
5) Dropped the "provisioning" registration message from the client-server protocol since the provisionning code was dropped from the server and was replaced by MAAS (LP: #1362506)
6) Drop cloud registration messages, since the corresponding code in the server was dropped a long time ago (LP: #1342646)
7) Changed the interface to the apt library since the library changed in trusty (LP: #1326940)
8) Changed the Swift plugin to report total/available/used space instead of the raw device info (LP: #1320236)
9) The client erroneously reported machines as "full machines" when run on kvm on POWER machines (LP: #1271615)
10) Added a CPU information parser for arm64 machines (LP: #1306824)
11) The landscape client now has some (code) mechanism to set its own user agent. This was pulled in since it allowed us to avoid complex source control operation and is no-op (LP: #1399139)
12) During testing for this SRU an upgrade bug was discovered and subsequently fixed. Our partial resync mechanism was not behaving properly during Landscape initiated dist-upgrades (LP: #1401867)

Some packaging-only changes are as follows:
1) Dropped sysinfo-ignore-nonexistent-config patch, already applied upstream

For more details see the aforementioned bugs (all mentioned in the debian/changelog of the proposed packages).

=== How the bug has been addressed ===

We have been following the development procedure laid out in https://wiki.ubuntu.com/LandscapeUpdates

Furthermore, the testing procedure results can be seen in
https://wiki.canonical.com/Landscape/ClientSRUTests/14.12

=== Patches ===

Branches allowing to recreeate tested packages are attached to this bug report. A simple "debuild" should be possible once checked out.

=== Detailed instructions how to reproduce the bug ===

N/A

=== Discussion ===

All the source packages have been subject to the QA process detailed in the LandscapeUpdates document linked above.

Chris Glass (tribaal) on 2014-12-11
Changed in landscape-client:
assignee: nobody → Chris Glass (tribaal)
Chris Glass (tribaal) on 2014-12-11
description: updated
Chris Glass (tribaal) on 2014-12-11
description: updated
Chris Glass (tribaal) on 2014-12-11
Changed in landscape-client:
status: New → In Progress
Chris Glass (tribaal) on 2014-12-12
summary: - Update lucid, precise, trusty, utopic to landscape-client 14.11
+ Update lucid, precise, trusty, utopic to landscape-client 14.12
description: updated
Chris Glass (tribaal) on 2014-12-19
description: updated
Changed in landscape-client:
status: In Progress → New
assignee: Chris Glass (tribaal) → nobody
importance: Undecided → Medium
Raghuram Kota (rkota) wrote :

Hi,
One of the features being delivered in this SRU : "10) Added a CPU information parser for arm64 machines (LP: #1306824)"
is needed for offering UA on HP moonshot McDivitt platform (ARM64). This platform has shipped on Dec 16th, 2014. UA team is currently waiting on this SRU to offer UA for this platform. Any help to expedite this SRU acceptance would be greatly appreciated.

Thaanks,
Raghu

Andreas Hasenack (ahasenack) wrote :

I uploaded the packages to proposed, and they are pending approval.

Changed in landscape-client (Ubuntu):
status: New → Fix Released

Hello Chris, or anyone else affected,

Accepted landscape-client into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.14.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Utopic):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Chris, or anyone else affected,

Accepted landscape-client into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Trusty):
status: New → Fix Committed
Chris Glass (tribaal) wrote :

I tested 14.12-0ubuntu0.14.04 and this fixes the bug for me (no problems discovered).

Changing to verification-done.

tags: added: verification-done
removed: verification-needed
Andreas Hasenack (ahasenack) wrote :

The verification for the trusty packages has finished and was done in the individual bugs from the Debian changelog.

Chris Glass (tribaal) wrote :

(Re-flipping the tag since it appears it was done a bit prematurely)

tags: added: verification-needed
removed: verification-done
Chris J Arges (arges) wrote :

Hello Chris, or anyone else affected,

Accepted landscape-client into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.12.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Chris, or anyone else affected,

Accepted landscape-client into lucid-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.10.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done-trusty verification-done-utopic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu0.14.10

---------------
landscape-client (14.12-0ubuntu0.14.10) utopic; urgency=medium

  * New upstream version (LP: #1401523):
    - Fix regression occurring when performing Landscape-driven release
      upgrades (LP: #1389686)
    - Fix regression occurring when switching the client between different
      Landscape servers (LP: #1376134)
    - Support reporting QEMU virtualization (LP: #1374501)
    - Bump Juju integration message format (LP: #1369635, LP: #1362506)
    - Drop provisioning registration message (LP: #1344054)
    - Drop cloud registration message (LP: #1342646)
    - Fix handling broken packages (LP: #1326940)
    - Add new Swift usage message type (LP: #1320236)
    - Fix platform detection on POWER machines (LP: #1271615)
    - Fix platform detection for arm64 machines (LP: #1306824)
    - Added a mechanism to set the client's user-agent (LP: #1399139)
    - Fixed release-upgrader not asking for a seesion ID before attempting to
      send a message (LP: #1401867)
  * Dropped sysinfo-ignore-nonexistent-config patch, already applied upstream.
 -- Christopher Glass (Canonical) <email address hidden> Tue, 02 Dec 2014 23:59:36 -0600

Changed in landscape-client (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu0.14.04

---------------
landscape-client (14.12-0ubuntu0.14.04) trusty; urgency=medium

  * New upstream version (LP: #1401523):
    - Fix regression occurring when performing Landscape-driven release
      upgrades (LP: #1389686)
    - Fix regression occurring when switching the client between different
      Landscape servers (LP: #1376134)
    - Support reporting QEMU virtualization (LP: #1374501)
    - Bump Juju integration message format (LP: #1369635, LP: #1362506)
    - Drop provisioning registration message (LP: #1344054)
    - Drop cloud registration message (LP: #1342646)
    - Fix handling broken packages (LP: #1326940)
    - Add new Swift usage message type (LP: #1320236)
    - Fix platform detection on POWER machines (LP: #1271615)
    - Fix platform detection for arm64 machines (LP: #1306824)
    - Added a mechanism to set the client's user-agent (LP: #1399139)
    - Fixed release-upgrader not asking for a seesion ID before attempting to
      send a message (LP: #1401867)
  * Dropped sysinfo-ignore-nonexistent-config patch, already applied upstream.
 -- Christopher Glass (Canonical) <email address hidden> Mon, 15 Dec 2014 09:14:30 +0300

Changed in landscape-client (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in landscape-client (Ubuntu Precise):
status: New → Fix Committed
Chris Glass (tribaal) wrote :

Verification was done for individual bugs on lucid.

tags: added: verification-done-lucid
Chris Glass (tribaal) wrote :

Verification was done for all individual bugs on Precise.

All individual bugs have been verified for all target releases.

tags: added: verification-done-precise
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu0.10.04

---------------
landscape-client (14.12-0ubuntu0.10.04) lucid; urgency=medium

   * New upstream version (LP: #1401523):
    - Fix regression occurring when performing Landscape-driven release
      upgrades (LP: #1389686)
    - Fix regression occurring when switching the client between different
      Landscape servers (LP: #1376134)
    - Support reporting QEMU virtualization (LP: #1374501)
    - Bump Juju integration message format (LP: #1369635, LP: #1362506)
    - Drop provisioning registration message (LP: #1344054)
    - Drop cloud registration message (LP: #1342646)
    - Fix handling broken packages (LP: #1326940)
    - Add new Swift usage message type (LP: #1320236)
    - Fix platform detection on POWER machines (LP: #1271615)
    - Fix platform detection for arm64 machines (LP: #1306824)
    - Added a mechanism to set the client's user-agent (LP: #1399139)
    - Fixed release-upgrader not asking for a seesion ID before attempting to
      send a message (LP: #1401867)
  * Added dependency on python-configobj.
  * Removed dependency on python-twisted-names
 -- Christopher Glass (Canonical) <email address hidden> Mon, 15 Dec 2014 00:59:26 -0600

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for landscape-client has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu0.12.04

---------------
landscape-client (14.12-0ubuntu0.12.04) precise; urgency=medium

  * New upstream version (LP: #1401523):
    - Fix regression occurring when performing Landscape-driven release
      upgrades (LP: #1389686)
    - Fix regression occurring when switching the client between different
      Landscape servers (LP: #1376134)
    - Support reporting QEMU virtualization (LP: #1374501)
    - Bump Juju integration message format (LP: #1369635, LP: #1362506)
    - Drop provisioning registration message (LP: #1344054)
    - Drop cloud registration message (LP: #1342646)
    - Fix handling broken packages (LP: #1326940)
    - Add new Swift usage message type (LP: #1320236)
    - Fix platform detection on POWER machines (LP: #1271615)
    - Fix platform detection for arm64 machines (LP: #1306824)
    - Added a mechanism to set the client's user-agent (LP: #1399139)
    - Fixed release-upgrader not asking for a seesion ID before attempting to
      send a message (LP: #1401867)
 -- Christopher Glass (Canonical) <email address hidden> Mon, 15 Dec 2014 09:24:30 +0300

Changed in landscape-client (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers