Client fails to detect VM type when run on POWER kvm

Bug #1271615 reported by Andreas Hasenack on 2014-01-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Low
Geoff Teale

Bug Description

This is a client bug, but I'm filing it against the server to keep branches private. I don't know what's the best way to merge this with the client when release time comes, without making public we are working with the POWER arch.

The bug is that when the client is run on KVM on a POWER host, the kvm virtualization layer is not detected. The client looks for this file:

    sys_vendor_path = join_root_path("sys/class/dmi/id/sys_vendor")

but it doesn't exist.

Feel free to poke around the machine, it's https://staging.landscape.canonical.com/account/landscape-devel/computer/3131/info

information type: Proprietary → Public
affects: landscape → landscape-client
information type: Public → Private
tags: removed: kanban
Geoff Teale (tealeg) on 2014-01-23
Changed in landscape-client:
assignee: nobody → Geoff Teale (tealeg)
status: New → In Progress
Geoff Teale (tealeg) wrote :

Please see this accurate, but extra subtle bug for reference in the client.

https://bugs.launchpad.net/landscape-client/+bug/1271921

Geoff Teale (tealeg) wrote :

A fix was committed on the referenced bug.

Changed in landscape-client:
status: In Progress → Fix Committed
information type: Private → Public

Hello Andreas, or anyone else affected,

Accepted landscape-client into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.14.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Andreas, or anyone else affected,

Accepted landscape-client into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Andreas Hasenack (ahasenack) wrote :

We can't get the same environment to test this again, POWER is not exactly off-the-shelf hardware. I suggest we consider this verified, or just skip the verification on this one.

Andreas Hasenack (ahasenack) wrote :

I managed to login on such a machine, and while I couldn't register it with landscape due to other reasons (restricted access, no root, etc), I was able to check that the /proc/cpuinfo file that it exposes would have been enough to flag it as a virtual machine for Landscape.

So, this was verified with the package from trusty-proposed:

(trusty-ppc64el)andreas@kelsey01:~$ apt-cache policy landscape-client
landscape-client:
  Installed: (none)
  Candidate: 14.12-0ubuntu0.14.04
  Version table:
     14.12-0ubuntu0.14.04 0
        500 http://ports.ubuntu.com/ubuntu-ports/ trusty-proposed/main ppc64el Packages
     14.01-0ubuntu3 0
        500 http://ports.ubuntu.com/ubuntu-ports/ trusty/main ppc64el Packages

Andreas Hasenack (ahasenack) wrote :

Likewise for utopic:

(utopic-ppc64el)andreas@kelsey01:~$ apt-cache policy landscape-client
landscape-client:
  Installed: (none)
  Candidate: 14.12-0ubuntu0.14.10
  Version table:
     14.12-0ubuntu0.14.10 0
        500 http://ports.ubuntu.com/ubuntu-ports/ utopic-proposed/main ppc64el Packages
     14.01-0ubuntu3 0
        500 http://ports.ubuntu.com/ubuntu-ports/ utopic/main ppc64el Packages

Forgot to paste /proc/cpuinfo in the previous comment, here it is. It's the same for utopic and trusty, of course:
(utopic-ppc64el)andreas@kelsey01:~$ cat /proc/cpuinfo
processor : 0
cpu : POWER7+ (raw), altivec supported
clock : 4284.000000MHz
revision : 2.1 (pvr 004a 0201)

processor : 1
cpu : POWER7+ (raw), altivec supported
clock : 4284.000000MHz
revision : 2.1 (pvr 004a 0201)

processor : 2
cpu : POWER7+ (raw), altivec supported
clock : 4284.000000MHz
revision : 2.1 (pvr 004a 0201)

processor : 3
cpu : POWER7+ (raw), altivec supported
clock : 4284.000000MHz
revision : 2.1 (pvr 004a 0201)

processor : 4
cpu : POWER7+ (raw), altivec supported
clock : 4284.000000MHz
revision : 2.1 (pvr 004a 0201)

processor : 5
cpu : POWER7+ (raw), altivec supported
clock : 4284.000000MHz
revision : 2.1 (pvr 004a 0201)

timebase : 512000000
platform : pSeries
model : IBM pSeries (emulated by qemu)
machine : CHRP IBM pSeries (emulated by qemu)

Chris J Arges (arges) wrote :

Hello Andreas, or anyone else affected,

Accepted landscape-client into lucid-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu0.10.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done-trusty verification-done-utopic
Chris Glass (tribaal) wrote :

Verified with the package in lucid-proposed. Since I couldn't get access to POWER hardware I instead verified the code was the same as the utopic version, which succeeded at detecting POWER hardware.

tribaal@ubuntu:~$ apt-cache policy landscape-client
landscape-client:
  Installed: 14.12-0ubuntu0.10.04
  Candidate: 14.12-0ubuntu0.10.04
  Version table:
 *** 14.12-0ubuntu0.10.04 0
        500 http://deb-mirror.habari.co.tz/ubuntu/ lucid-proposed/main Packages
        100 /var/lib/dpkg/status
     13.07.3-0ubuntu0.10.04 0
        500 http://deb-mirror.habari.co.tz/ubuntu/ lucid-updates/main Packages
     1.5.0.1-0ubuntu0.10.04.0 0
        500 http://deb-mirror.habari.co.tz/ubuntu/ lucid/main Packages

tags: added: verification-done-lucid
Chris Glass (tribaal) wrote :

Verified with the package in precise-proposed. Since I couldn't get access to POWER hardware I instead verified the code was the same as the utopic version, which succeeded at detecting POWER hardware.

tribaal@ubuntu:~$ apt-cache policy landscape-client
landscape-client:
  Installed: 14.12-0ubuntu0.12.04
  Candidate: 14.12-0ubuntu0.12.04
  Version table:
 *** 14.12-0ubuntu0.12.04 0
        500 http://deb-mirror.habari.co.tz/ubuntu/ precise-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     13.07.3-0ubuntu0.12.04 0
        500 http://deb-mirror.habari.co.tz/ubuntu/ precise-updates/main amd64 Packages
     12.04.3-0ubuntu1 0
        500 http://deb-mirror.habari.co.tz/ubuntu/ precise/main amd64 Packages

tags: added: verification-done-precise
removed: verification-needed

The verification of the Stable Release Update for landscape-client has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers