Update lucid, raring, quantal, precise to landscape-client 13.07.3

Bug #1190510 reported by Chris Glass on 2013-06-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
High
Chris Glass
landscape-client (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

Landscape Client 13.07.3 has been released. We would like to get these changes into raring, quantal, precise and lucid.

As far as released version of Ubuntu are concerned, the required pieces of information for the needed SRU follow (as laid out in the "Procedure" section of https://wiki.ubuntu.com/StableReleaseUpdates).

=== Statement explaining the impact ===

This release sports both bug-fixes and new features and we would like to make sure all of our supported customers (even those on raring, quantal, precise and lucid) have access to these improvements. The notable ones are:

1) New annotations exchange mechanism allows clients to send any key-value data to the landscape server (#1123932)
2) Network devices now report their maximum theoretical speeds, and duplex status to landscape-server (#1126330, #1130733)
3) Landscape.client is now HA aware when HA is implemented using juju charms (#1122508)
4) The landscape client will now trigger a reboot if server sends a reboot-required message. (#1133005)
5) Big AMP code cleanup and refactoring in order to improve testing, improve performance and ease future maintainability (#1165047, #1169102, #1170669)
6) Added logic to detect cloned (virtual) computers (#1161856)
7) The landscape-client and landscape-common packages do not use or depend on dbus code anymore, and some legacy plugins using dbus were removed. (#1175553, #1180691)
8) The ceph manager plugin is now a monitor plugin and thus does not require root privileges anymore. (#1186973)

Some packaging-only changes are as follows:
9) Removed legacy upgrader code from postinst since support for it was dropped.
10) French translation patches were removed since the changes were merged upstream.
11) The /etc/dbus-1/system.d/landscape.conf file was moved from the landscape-client package to the landscape-client-ui package. A "Replaces" rule was therefore added to the landscape-client-ui package. No "Breaks" rule was added since the -ui package requires the exact same version of the -client package, avoiding the case described in http://www.debian.org/doc/debian-policy/footnotes.html#f53
12) dependencies on Dbus and hal/udev (python-dbus and gudev) are dropped from the landscape-client and landscape-common packages, since the client code does not use dbus at all anymore. The landscape-client-ui package however still does.

For more details see the aforementioned bugs (all mentioned in the debian/changelog of the proposed packages).

=== How the bug has been addressed ===

We have been following the development procedure laid out in https://wiki.ubuntu.com/LandscapeUpdates

Furthermore, the testing procedure results can be seen in
https://wiki.canonical.com/Landscape/ClientSRUTests/13.07.1?action=recall&rev=27

=== Patches ===

Debdiff patches against the currently released landscape version are attached to this bug report, by distribution.

=== Detailed instructions how to reproduce the bug ===

N/A

=== Discussion ===

All the source packages have been subject to the QA process detailed in the LandscapeUpdates document linked above.

Chris Glass (tribaal) on 2013-06-13
description: updated
Chris Glass (tribaal) on 2013-06-19
summary: - Update saucy, raring, quantal, precise to landscape-client XXX
+ Update saucy, raring, quantal, precise to landscape-client 13.05.1
description: updated
Chris Glass (tribaal) on 2013-07-01
description: updated
Chris Glass (tribaal) on 2013-08-20
summary: - Update saucy, raring, quantal, precise to landscape-client 13.05.1
+ Update saucy, raring, quantal, precise, lucid to landscape-client
+ 13.07.1
description: updated
Chris Glass (tribaal) on 2013-08-20
summary: - Update saucy, raring, quantal, precise, lucid to landscape-client
- 13.07.1
+ Update raring, quantal, precise, lucid to landscape-client 13.07.1
description: updated

The debidiff for the raring package (12.12 to 13.07.1)

Chris Glass (tribaal) wrote :

The precise debdiff (12.05 to 13.07.1)

Chris Glass (tribaal) wrote :

Th debdiff for the lucid package (12.05 to 13.07.1)

Chris Glass (tribaal) on 2013-08-20
description: updated
Chris Glass (tribaal) wrote :

The quantal debdiff

Chris Glass (tribaal) on 2013-09-09
description: updated
Chris Glass (tribaal) wrote :

Uploading a new (and correct) debdiff for quantal.

Andreas Hasenack (ahasenack) wrote :

The packages have been uploaded and will now await the review from the SRU team.

Changed in landscape-client:
milestone: none → 13.07.1
Andreas Hasenack (ahasenack) wrote :

Unsubscribed the SRU team, we decided to do another release.

Brian Murray (brian-murray) wrote :

While the SRU team is unsubscribed, the packages still exist in -proposed. Should they be rejected?

Additionally, having a changelog link to private bugs (as done in the changelog of the upload to raring-proposed) is considered bad form. Please consider making the relevant bug reports public.

Brian Murray (brian-murray) wrote :

Oh, and this bug report should really have a task about the Ubuntu package.

Andreas Hasenack (ahasenack) wrote :

Yes please, reject them (13.07.1). A new set will be uploaded in a few days.

Chris Glass (tribaal) on 2013-10-08
summary: - Update raring, quantal, precise, lucid to landscape-client 13.07.1
+ Update raring, quantal, precise, lucid to landscape-client 13.07.3
Chris Glass (tribaal) on 2013-10-08
summary: - Update raring, quantal, precise, lucid to landscape-client 13.07.3
+ Update raring, quantal, precise to landscape-client 13.07.3
description: updated
Chris Glass (tribaal) wrote :

The quantal debdiff for 13.07.3

Chris Glass (tribaal) wrote :

The raring debdiff for 13.07.3

The attachment "precise_12.05-0ubuntu1_to_13.07.3-0ubuntu0.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Chris Glass (tribaal) wrote :

The lucid debdiff for 13.07.3

summary: - Update raring, quantal, precise to landscape-client 13.07.3
+ Update lucid, raring, quantal, precise to landscape-client 13.07.3
description: updated
Andreas Hasenack (ahasenack) wrote :

Ubuntu sponsors, unfortunately I can't remove your subscription from this bug (that LP automatically added). There is nothing for you to do here, since this is an SRU, and not even the SRU team can do anything about it yet because the packages are not uploaded yet.

Andreas Hasenack (ahasenack) wrote :

Packages uploaded, the SRU team can review now.

Chris Glass (tribaal) on 2013-10-16
description: updated
Chris Glass (tribaal) wrote :

The precise debdiff

Chris Glass (tribaal) wrote :

The quantal debdiff

Chris Glass (tribaal) wrote :

The raring debdiff

Chris Glass (tribaal) wrote :

The lucid debdiff

Hello Chris, or anyone else affected,

Accepted landscape-client into lucid-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/landscape-client/13.07.3-0ubuntu0.10.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Changed in landscape-client (Ubuntu Precise):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chris, or anyone else affected,

Accepted landscape-client into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/landscape-client/13.07.3-0ubuntu0.12.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Quantal):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chris, or anyone else affected,

Accepted landscape-client into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/landscape-client/13.07.3-0ubuntu0.12.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Raring):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chris, or anyone else affected,

Accepted landscape-client into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/landscape-client/13.07.3-0ubuntu0.13.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Andreas Hasenack (ahasenack) wrote :

raring package from proposed tested, all good.

tags: added: verification-done-raring
Andreas Hasenack (ahasenack) wrote :

quantal package from proposed tested, all good

Andreas Hasenack (ahasenack) wrote :

precise package from proposed tested, all good

Andreas Hasenack (ahasenack) wrote :

lucid package from proposed tested, all good

tags: added: verification-done
removed: verification-needed
Andreas Hasenack (ahasenack) wrote :

Hi, is there anything else we (non-sru team) need to do here?

On Tue, Dec 03, 2013 at 12:23:58PM -0000, Andreas Hasenack wrote:
> Hi, is there anything else we (non-sru team) need to do here?

The pending SRU report
(http://people.canonical.com/~ubuntu-archive/pending-sru.html) which we
use to determine what SRUs to release still shows that the upload of
landscape-client has multiple bugs that need verification. I guess this
is because you've used a metabug (this one) for the SRU and your
verification of this bug presumably means that all the other bugs are
verified for every release. Is that correct?

--
Brian Murray
Ubuntu Bug Master

Andreas Hasenack (ahasenack) wrote :

Correct. I will comment on those bugs.

Andreas Hasenack (ahasenack) wrote :

I verified the individual bugs now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 13.07.3-0ubuntu0.13.04

---------------
landscape-client (13.07.3-0ubuntu0.13.04) raring; urgency=low

  * New upstream version (LP: #1190510)
   - New annotations exchange mechanism allows clients to send any key-value
     data to the landscape server (LP: #1123932)
   - Network devices now report their maximum theoretical speeds, and duplex
     status to landscape-server (LP: #1126330, LP: #1130733)
   - Landscape.client is now HA aware when HA is implemented using juju
     charms (LP: #1122508)
   - The landscape client will now trigger a reboot if server sends a
     reboot-required message. (LP: #1133005)
   - Big AMP code cleanup and refactoring in order to improve testing, improve
     performance and ease future maintainability (LP: #1165047, LP: #1169102,
     LP: #1170669)
   - Added logic to detect cloned (virtual) computers (LP: #1161856)
   - The landscape-client and landscape-common packages do not use or depend
     on dbus code anymore, and the dependencies to python-gi and gudev are
     dropped. The hardware info plugin now looks at /proc instead of querying
     DBus (LP: #1175553, LP: #1180691)
   - The ceph manager plugin is now a monitor plugin and thus does not require
     root privileges anymore. (LP: #1186973)
   - The detection logic for virtual machine was changed to account for the
     different semantics between Openstack Folsom and Grizzly, and was
     expanded to detect more hypervisors (LP: #1191843)
   - Removed legacy upgrader code from postinst since support for it was
     dropped.
   - French translation patches were removed since the changes were merged
     upstream.
   - Removed legacy upgrader from postinst.
   - The /etc/dbus-1/system.d/landscape.conf file was moved from the
     landscape-common package to the landscape-client-ui as part of
     LP: #1175553, LP: #1180691. No "Breaks" rule was added since the
     landscape-client-ui package requires the exact same version of
     landscape-common, which avoids the case outlined in
     http://www.debian.org/doc/debian-policy/footnotes.html#f53
 -- Christopher Glass (Canonical) <email address hidden> Wed, 16 Oct 2013 10:14:28 +0200

Changed in landscape-client (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for landscape-client has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 13.07.3-0ubuntu0.12.10

---------------
landscape-client (13.07.3-0ubuntu0.12.10) quantal; urgency=low

  * New upstream version (LP: #1190510)
   - New annotations exchange mechanism allows clients to send any key-value
     data to the landscape server (LP: #1123932)
   - Network devices now report their maximum theoretical speeds, and duplex
     status to landscape-server (LP: #1126330, LP: #1130733)
   - Landscape.client is now HA aware when HA is implemented using juju
     charms (LP: #1122508)
   - The landscape client will now trigger a reboot if server sends a
     reboot-required message. (LP: #1133005)
   - Big AMP code cleanup and refactoring in order to improve testing, improve
     performance and ease future maintainability (LP: #1165047, LP: #1169102,
     LP: #1170669)
   - Added logic to detect cloned (virtual) computers (LP: #1161856)
   - The landscape-client and landscape-common packages do not use or depend
     on dbus code anymore, and the dependencies to python-gi and gudev are
     dropped. The hardware info plugin now looks at /proc instead of querying
     DBus (LP: #1175553, LP: #1180691)
   - The ceph manager plugin is now a monitor plugin and thus does not require
     root privileges anymore. (LP: #1186973)
   - The detection logic for virtual machine was changed to account for the
     different semantics between Openstack Folsom and Grizzly, and was
     expanded to detect more hypervisors (LP: #1191843)
   - Removed legacy upgrader code from postinst since support for it was
     dropped.
   - French translation patches were removed since the changes were merged
     upstream.
   - Removed legacy upgrader from postinst.
   - The /etc/dbus-1/system.d/landscape.conf file was moved from the
     landscape-common package to the landscape-client-ui as part of
     LP: #1175553, LP: #1180691. No "Breaks" rule was added since the
     landscape-client-ui package requires the exact same version of
     landscape-common, which avoids the case outlined in
     http://www.debian.org/doc/debian-policy/footnotes.html#f53
 -- Christopher Glass (Canonical) <email address hidden> Wed, 16 Oct 2013 10:30:28 +0200

Changed in landscape-client (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 13.07.3-0ubuntu0.12.04

---------------
landscape-client (13.07.3-0ubuntu0.12.04) precise; urgency=low

  * New upstream version (LP: #1190510)
   - New annotations exchange mechanism allows clients to send any key-value
     data to the landscape server (LP: #1123932)
   - Network devices now report their maximum theoretical speeds, and duplex
     status to landscape-server (LP: #1126331, LP: #1130733)
   - Landscape.client is now HA aware when HA is implemented using juju
     charms (LP: #1122508)
   - The landscape client will now trigger a reboot if server sends a
     reboot-required message. (LP: #1133005)
   - Big AMP code cleanup and refactoring in order to improve testing, improve
     performance and ease future maintainability (LP: #1165047, LP: #1169102,
     LP: #1170669)
   - Added logic to detect cloned (virtual) computers (LP: #1161856)
   - The landscape-client and landscape-common packages do not use or depend
     on dbus code anymore, and the dependencies to python-gi and gudev are
     dropped. The hardware info plugin now looks at /proc instead of querying
     DBus (LP: #1175553, LP: #1180691)
   - The ceph manager plugin is now a monitor plugin and thus does not require
     root privileges anymore. (LP: #1186973)
   - The detection logic for virtual machine was changed to account for the
     different semantics between Openstack Folsom and Grizzly, and was
     expanded to detect more hypervisors (LP: #1191843)
   - Removed legacy upgrader code from postinst since support for it was
     dropped.
   - The /etc/dbus-1/system.d/landscape.conf file was moved from the
     landscape-common package to the landscape-client-uii as part of
     LP: #1175553, LP: #1180691. No "Breaks" rule was added since the
     landscape-client-ui package requires the exact same version of
     landscape-common, which avoids the case outlined in
     http://www.debian.org/doc/debian-policy/footnotes.html#f53 .
  * Removed the hardwareinfo patch since the changes were merged upstream
  * Changed dh_clean -K to dh_prep (dh_clean -K is deprecated)
  * Removed the packages arguments to dh_installman since all pacakges have
    manpages now.
 -- Christopher Glass (Canonical) <email address hidden> Fri, 20 Sep 2013 10:10:28 +0200

Changed in landscape-client (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 13.07.3-0ubuntu0.10.04

---------------
landscape-client (13.07.3-0ubuntu0.10.04) lucid; urgency=low

  * New upstream version (LP: #1190510)
   - New annotations exchange mechanism allows clients to send any key-value
     data to the landscape server (LP: #1123932)
   - Network devices now report their maximum theoretical speeds, and duplex
     status to landscape-server (LP: #1126330, LP: #1130733)
   - Landscape.client is now HA aware when HA is implemented using juju
     charms (LP: #1122508)
   - The landscape client will now trigger a reboot if server sends a
     reboot-required message. (LP: #1133005)
   - Big AMP code cleanup and refactoring in order to improve testing, improve
     performance and ease future maintainability (LP: #1165047, LP: #1169102,
     LP: #1170669)
   - Added logic to detect cloned (virtual) computers (LP: #1161856)
   - The landscape-client and landscape-common packages do not use or depend
     on dbus code anymore, and the dependencies to python-gi and gudev are
     dropped. The hardware info plugin now looks at /proc instead of querying
     DBus (LP: #1175553, LP: #1180691)
   - The ceph manager plugin is now a monitor plugin and thus does not require
     root privileges anymore. (LP: #1186973)
   - The detection logic for virtual machine was changed to account for the
     different semantics between Openstack Folsom and Grizzly, and was
     expanded to detect more hypervisors (LP: #1191843)
   - Removed legacy upgrader code from postinst since support for it was
     dropped.
   - The /etc/dbus-1/system.d/landscape.conf file was moved from the
     landscape-common package to the landscape-client-uii as part of
     LP: #1175553, LP: #1180691. No "Breaks" rule was added since the
     landscape-client-ui package requires the exact same version of
     landscape-common, which avoids the case outlined in
     http://www.debian.org/doc/debian-policy/footnotes.html#f53 . The Replaces
     rule of landscape-client was updated accordingly.
  * Removed the hardwareinfo patch since the changes were merged upstream
  * Changed dh_clean -K to dh_prep (dh_clean -K is deprecated)
  * Removed the packages arguments to dh_installman since all packages have
    manpages now.
  * While the debconf config file still has registration_password as a
    variable, the newest code expects a registration_key. Made the necessary
    changes for that to work.
 -- Christopher Glass (Canonical) <email address hidden> Wed, 16 Oct 2013 11:30:47 +0200

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Chris Glass (tribaal) on 2013-12-12
Changed in landscape-client:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in landscape-client (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers