Landscape Client doesn't start on 13.04

Bug #1159997 reported by Alex Moldovan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Invalid
Critical
Andreas Hasenack
systemd (Ubuntu)
Fix Released
Critical
Martin Pitt

Bug Description

Landscape client doesn't start in 13.04 due to missing libgudev-1.0-0.

Using landscape-client 12.12-0ubuntu3 on Ubuntu 13.04 with 3.8.0-14-generic

"** (process:3461): WARNING **: Failed to load shared library 'libgudev-1.0.so.0' referenced by the typelib: libgudev-1.0.soso: cannot open shared object file: No such file or directory"

$ apt-rdepends landscape-client | grep gudev
  Depends: gir1.2-gudev-1.0 (>= 165-0ubuntu2)
gir1.2-gudev-1.0

Installing the libgudev-1.0-0. package solves the start problem.

Revision history for this message
Alex Moldovan (alexmoldovan) wrote :
Revision history for this message
Alex Moldovan (alexmoldovan) wrote :
description: updated
Changed in landscape-client:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → 13.03
Changed in landscape-client:
assignee: nobody → Andreas Hasenack (ahasenack)
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

I emailed ubuntu-devel@ about this, because on Oneiric, Precise and Quantal gir1.2-gudev-1.0 pulls in libgudev-1.0-0, and landscape-client depends on gir1.2-gudev-1.0. But on Raring gir1.2-gudev-1.0 does not depend on libgudev-1.0-0 anymore, so I asked if this is a mistake or done on purpose. If it's a mistake, this bug will be fixed in gir1.2-gudev-1.0. If it's on purpose, I'll add a dependency for libgudev-1.0-0 in Raring builds of landscape-client.

Changed in systemd (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in systemd (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in my packaging git this morning, will upload now.

Revision history for this message
Martin Pitt (pitti) wrote :

I didn't see that bug early enough, sorry (just the ML post). So closing manually as the changelog misses the bug ref.

systemd (198-0ubuntu8) raring; urgency=low

  * debian/tests/control: Add libpam-systemd dependency for logind test, as
    it checks for the mounted cgroup. Mounting that moved into libpam-systemd,
    see 198-0ubuntu7.
  * Drop usr/lib/systemd/ from systemd-services, this doesn't belong there and
    is already installed into systemd.
  * debian/rules: Call dh_girepository to get correct dependencies of
    gir1.2-gudev-1.0.
  * 0016-Add-poweroff-reboot-suspend-hibernate-fallback.patch: Send
    PrepareFor{Sleep,Shutdown}() signals with "false" after the operation
    finished. Thanks to Iain Lane for the initial patch! (LP: #1157122)

 -- Martin Pitt <email address hidden> Tue, 26 Mar 2013 11:08:39 +0100

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
assignee: Dmitrijs Ledkovs (xnox) → Martin Pitt (pitti)
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Thanks!

Changed in landscape-client:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers