fluidsynth uses wrong liblash

Bug #877724 reported by Shoichi Chou on 2011-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KXStudio
Undecided
Unassigned

Bug Description

My Ubuntu Studio is Lucid. After installing KXstudio, I found that I can't run fluidsynth by qsynth.

I saw the console. It printed "can't find liblash.so.2"

After checking pacakages , I found liblash2 replaced by liblash-compat-1,but fluidsynth still find liblash.so.2 of liblash2 not liblash.so.1 of liblash-compat-1 .

I ugly sudo ln liblash.so.1 liblash.so.2 to solve this. The fluidsynth package should be correct to use liblash.so.1 , not 2.

falkTX (falk-t-j) wrote :

thanks for the report, It's good to have a user in Lucid to test these things.
I'll recompile the package ASAP

falkTX (falk-t-j) wrote :

actually, the fluidsynth package in lucid does *not* have lash support enabled, so this is coming from where?

do you have other/extra PPAs enabled?

Shoichi Chou (mgdesigner) wrote :

My fluidsynth version is 1.1.3-3+nolash1~lucid1 . libfluidsynth1 is ,too. I found its dependence no liblash, but it indeed usees it. Its maintain er is Debian Multimedia Maintainers <email address hidden>

falkTX (falk-t-j) wrote :

This is now fixed in the lucid PPAs, thanks for the report

Changed in kxstudio:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers