jackdbus file grows to enormous sizes

Bug #619014 reported by Kayosiii on 2010-08-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KXStudio
High
Unassigned
Ubuntu Studio
Fix Released
Undecided
Unassigned
jackit
Fix Released
Unknown

Bug Description

the jackdbus log file in ~/.log very quickly grows to fill up all of my disk space growing to 100s of GBs in size in the space of a few hours.

falkTX (falk-t-j) wrote :

Thanks for reporting the bug,

I've check my logs, they are around 450Mb, which is already very big

Not as big as yours, but still... no good for a log

I'll talk with nedko about this

Changed in kxstudio:
status: New → Confirmed

Do you see countless repetitive patterns in the log file? Like xruns or jackdbus crashes followed by restarts? If you compress the file with gzip/bzip2, how big does it become?

falkTX (falk-t-j) wrote :

Compressing the file heavily reduces the size (512->3.6Mb, using just gzip)

A simple solution would be to automatically rename the log, (jackdbus.log.0 or jackdbus.log.20100818) and compress it,
leaving only the current/daily log un-compressed. The very old logs should be auto-delete.
Basically what it's called log-rotation.

This seems a serious bug, reporting to ubuntu/ubuntustudio

Changed in kxstudio:
importance: Undecided → High
affects: kxstudio → jackit
falkTX (falk-t-j) on 2010-08-18
affects: jackit → kxstudio
Changed in jackit:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Недко Арнаудов (nedko)
assignee: Недко Арнаудов (nedko) → nobody
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in jackit:
status: Unknown → Fix Released
falkTX (falk-t-j) wrote :

Log Rotation is now implemented on KXStudio with compression support.

Fixed!

Changed in kxstudio:
status: Confirmed → Fix Released
Erich Eickmeyer (eeickmeyer) wrote :

Wow, uh... long-since fix-released. Marking as such for Ubuntu Studio as well!

Changed in ubuntustudio:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.