Doc missing needed config to enable Network Policy

Bug #1811370 reported by Maysa de Macedo Souza on 2019-01-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kuryr-kubernetes
Undecided
Maysa de Macedo Souza

Bug Description

The docs are outdated with the current Network Policy support. The current implementation requires that the namespace handler is also enabled, and consequently, needs pod_subnet_driver to be set as namespace. Also, to add a pod_subnet_pool and a pod_router.

Changed in kuryr-kubernetes:
assignee: nobody → Maysa de Macedo Souza (maysa)
status: New → In Progress

Reviewed: https://review.openstack.org/630158
Committed: https://git.openstack.org/cgit/openstack/kuryr-kubernetes/commit/?id=d490b08cb7e0a0f4fa71d080226f8aa6ef0637c9
Submitter: Zuul
Branch: master

commit d490b08cb7e0a0f4fa71d080226f8aa6ef0637c9
Author: Maysa Macedo <email address hidden>
Date: Fri Jan 11 11:20:42 2019 +0000

    Fix Network Policy documentation

    Adds additional configuration needed to fully enable Network Policy
    functionality.

    Closes-Bug: #1811370
    Change-Id: I785e703dcd83201ffa3e9cc92c31466087770890

Changed in kuryr-kubernetes:
status: In Progress → Fix Released

This issue was fixed in the openstack/kuryr-kubernetes 0.6.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers