Indicator icon no showing

Bug #1479413 reported by Tonny
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kupfer
New
Undecided
Unassigned

Bug Description

The indicator icon does not show on Unity. I tried both the package from the official ubuntu repository and from the ppa. The python-appindicator pacakge was missing, but after installing the icon was still missing. Calling export $(dbus-launch) gets rid of some dbus related errors reported on the logs, but did nothing regarding the indicator icon. I added some logging statements on the browser.py module, and it seemed like the set_visible method of the _statusicon attribute from the WindowController does not exist, but the error gets silenced. Could be a mismatch with the python-appindicator module, which by the way, shouldn't it be a dependency?

Revision history for this message
Steve George (slgeorge) wrote :

What version of Ubuntu are you on?

I've just installed it this evening from the 14.04 LTS (Trusty Tahr) repository. In Unity, I can the app indicators in Unity. I'm also running it under i3wm which has support for applets and it's fine there.

Bet you did this already, but there's a debug flag you could also send ie.

  $ kupfer --debug

I already had python-appindicator installed so can't confirm it's a strict dependency or not.

If you have anything you want to try happy to help. There's a mirror on github you could push a patch to if you've solved it.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers