Unofficial Package Updates for Kubuntu

amarok-common conflicts with amarok

Reported by Leonardo Silva Amaral on 2012-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned

Bug Description

Amarok-common conflicts with Amarok since my last update some minutes ago. My Kubuntu was installed from Kubuntu PPA (Stable version) about 4 or 5 hours ago.

root@scrat:~# LANGUAGE=C apt-get install amarok
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 amarok : Depends: amarok-common (= 2:2.5.0-0ubuntu4~oneiric1~ppa1) but 2:2.5.0-0ubuntu1~ppa1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@scrat:~# LANGUAGE=C apt-cache policy amarok amarok-common
amarok:
  Installed: (none)
  Candidate: 2:2.5.0-0ubuntu4~oneiric1~ppa1
  Version table:
     2:2.5.0-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
     2:2.5.0-0ubuntu4~oneiric1~ppa1 0
        990 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ oneiric/main amd64 Packages
     2:2.5.0-0ubuntu1~ppa1 0
        100 /var/lib/dpkg/status
     2:2.4.3-1ubuntu2.1 0
        990 http://mirror.unesp.br/ubuntu/ oneiric-updates/main amd64 Packages
     2:2.4.3-1ubuntu2 0
        990 http://mirror.unesp.br/ubuntu/ oneiric/main amd64 Packages
amarok-common:
  Installed: 2:2.5.0-0ubuntu1~ppa1
  Candidate: 2:2.5.0-0ubuntu1~ppa1
  Version table:
     2:2.5.0-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
 *** 2:2.5.0-0ubuntu1~ppa1 0
        990 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
     2:2.4.3-1ubuntu2.1 0
        990 http://mirror.unesp.br/ubuntu/ oneiric-updates/main amd64 Packages
     2:2.4.3-1ubuntu2 0
        990 http://mirror.unesp.br/ubuntu/ oneiric/main amd64 Packages

P.s: Precise mirror upside dont affects this installation.

Just a quick workarround:

apt-get download amarok
dpkg --force-depends-version -i amarok_2.5.0-0ubuntu4~oneiric1~ppa1_amd64.deb

Philip Muškovac (yofel) wrote :

That's archive inconsistency due to the long build queues for the different architectures currently. Should work now.

Changed in kubuntu-ppa:
status: New → Fix Released

@Yofel, i know a lot these times are really annoying. Isnt the time to Kubuntu have you own build site? Im waiting KDE 4.8 a lot of days and until now we have broken packages due the time of compilation.

On 01/28/2012 02:09 PM, Leonardo Silva Amaral wrote:
> @Yofel, i know a lot these times are really annoying. Isnt the time to
> Kubuntu have you own build site? Im waiting KDE 4.8 a lot of days and
> until now we have broken packages due the time of compilation.
>

Well, not as in a seperate repository server. For KDE itself we have a
seperate archive (with restricted access) with higher priority where we
build the packages and later just copy them over to the PPAs. But
uploads to one of the PPAs itself end up in the same queue as every
other PPA. And I don't believe that's going to change in the near future.

I see. BTW, close this bug. The issue is solved and apt is ok again here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers