KDE 4.7 - KPackageKit - "Failed to obtain authentication" due to missing "polkit-kde-1" dependency

Bug #819266 reported by theghost on 2011-08-01

This bug report will be marked for expiration in 47 days if no further activity occurs. (find out why)

16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned

Bug Description

Updating 11.04 to KDE 4.7 resulted in problems with kpackagekit.
Update went fine but since update i can't install updates with kpackagekit.

It seems "kubuntu-desktop" does not require "polkit-kde-1" as dependency.

Description - Steps to reproduce:

1. Install Ubuntu
2. Add Kubuntu Backports PPA for KDE 4.7
3. Install "kubuntu-desktop" metapackage.
4. Start Kpackagekit and search for updates
6. Updates are found
7. Try to install updates via KPackagekit results in error: "Failed to obtain authentication"

Solution:

1. Install "polkit-kde-1"
2. Retry update installation via kpackagekit
3. Everything works fine

Edit - It seems it was also a bug before KDE 4.7:

- There is an upstream bug, reported by an kubuntu 11.04 user too: https://bugs.kde.org/show_bug.cgi?id=274204
- There is also a duplicate bug on launchpad for 11.04: https://bugs.launchpad.net/ubuntu/+source/kpackagekit/+bug/758592

theghost (theghost) on 2011-08-01
description: updated
theghost (theghost) on 2011-08-04
summary: - KDE 4.7 - KPackageKit - "Failed to obtain authentication"
+ KDE 4.7 - KPackageKit - "Failed to obtain authentication" due to missing
+ dependencies
description: updated
summary: KDE 4.7 - KPackageKit - "Failed to obtain authentication" due to missing
- dependencies
+ "polkit-kde-1" dependency
Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Kubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Kubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect 819266

and any other logs that are relevant for this particular issue.

Changed in kubuntu-ppa:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers