Power button delay dialog in kde 4.6+

Bug #713198 reported by Salva Ferrer on 2011-02-04
112
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

I am using kubuntu backports version of kde 4.6.

since I updated to kde 4.6RC the power button has a delay of 1minute until the shutdown dialog shows in the screen.

I configured power management to show the shutdown dialog when I press the power button.

I guess it is related to power devil, since it should be managing power button events, in that case my version is:

libpowerdevilcore0: 4:4.6.0a-0ubuntu2~maverick1~ppa1

Reproducible always, I haven't seen any other log in the system that seemed related to it, just ask for anything needed.

Salva Ferrer (salva-ferrer) wrote :

I bit more info I thought could be of interest:

kernel: Linux xikitin 2.6.35-26-generic #46-Ubuntu SMP Sun Jan 30 08:10:51 UTC 2011 i686 GNU/Linux
upower: 0.9.5-4
acpi: 1.5-2

compositing is enabled, but it is reproducible if disabled as well.

Seems to affect Archlinux as well according to this bug report in kde:

https://bugs.kde.org/show_bug.cgi?id=265405

Dennis Schridde (devurandom) wrote :

I had the same issue in the beginning. Now it changed to immediately shutting down the system via non-KDE methods. Probably the ACPI daemon decides to call "shutdown", instead of letting KDE show the logout dialogue (which I setup to be shown in the power management settings).
Salva, can you confirm that for your system, too?

Salva Ferrer (salva-ferrer) wrote :

Sorry Dennis, I missed your comment, sorry for the late reply.

I've seen inconsistent behavior lately, the delay is still there most of the times. But sometimes after pressing the shutdown button the system goes down without showing the shutdown dialog. Unfortunately I am not able to isolate the reproduction steps, but I guess that several suspend to memory cycles are somehow related.

Salva Ferrer (salva-ferrer) wrote :

I tried but I am unable to reproduce the immediate shutdown behavior, although i've seen it.

What I realized trying to trigger this is that the dialog only takes one minute to appear the first time. If you cancel the shutdown dialog, successive press of the shutdown button trigger the shutdown dialog immediately.

Michele Gastaldo (poomerang) wrote :

I confirm the delay of the logout dialogue, for first time calling only (as for Salva).

About the direct shutdown with no confirmation asked, the problem should be in acpid calling /etc/acpi/powerbtn.sh when event powerbtn happens. This can be changed commenting out /etc/acpi/events/powerbtn (at least the "action=" line).
I guess the patch provided for bug #553557 (https://bugs.launchpad.net/ubuntu/+source/acpid/+bug/553557) should fix this - acpid actions should be blocked if powerdevil is set otherwise

Dennis Schridde (devurandom) wrote :

I inserted "exit" just before "shutdown" in /etc/acpi/powerbtn.sh and now I always get the delay. I do not know why the KDE/PowerDevil detection logic in that shellscript does not work, though.

Dennis Schridde (devurandom) wrote :

(I have just one "kdeinit4: kded4" process, so returns only one value, hence kde-bug #236490 should not be the cause.)

Dennis Schridde (devurandom) wrote :

s/so returns/so pidof returns/

Victor (vprea) wrote :

Same problem here. It's a fresh Kubuntu 11.04 x64 install on a new Lenovo Thinkpad.
It takes a long time to appear for first time, but if I cancel the Exit dialog, then every time I press the power button the dialog appears immediately.

Sergio Callegari (callegar) wrote :

Confirmed on a kubuntu 11.04 upgraded from maverick.
Maverick was showing exactly the same issue with kde 4.6 (installed from the backport PPA)

Thomas McNicholas (thommcn) wrote :

I have the same issue with both my desktop machine and my laptop (HP Compaq 6735s) with Kubuntu 11.04 or Linux Mint KDE 10 (both use KDE 4.6).

Changed in ubuntu:
status: New → Confirmed

I have had the same problem for everybody about delay time.
For the first time I press the button I need to wait for 1 minute. And after, it is immediate
Using KDE 4.7.00 PPA5 backports repository

Piotr Reszko (piotr-reszko) wrote :

Same problem here. I hope it would be sorted out soon.

summary: - Power button delay dialog in kde 4.6
+ Power button delay dialog in kde 4.6+
T. Dalbo (cooltd825) wrote :

I'd like to chime in that this problem still exists KDE 4.7 for me. It's also not isolated to Kubuntu, so I would definitely consider this an upstream KDE bug.

Running on an HP Pavilion G62-144dx

michael (reeves-87) wrote :

Upstream has fixed it in 4.8 they looking at the possibility of back-porting the fix to 4.7.

Adam Porter (alphapapa) wrote :

It's a shame that data-loss wasn't reason enough to get it fixed. It took a much more obscure security bug, one that's very unlikely to occur in the real world. The data-loss angle is an everyday risk: press the power button, expecting to get prompted to shutdown, and watch all your X apps get killed, instead.

Hey, I'm glad they fixed the security aspect, but let's be realistic here: If a user has the ability to run processes on the system, and the system is a laptop or desktop running KDE 4, most likely the user has physical access to the system, and he could snoop-on or erase data without having to jump through such obscure hoops. On the other hand, the data-loss aspect could happen because of a cat or a dog or a two-year-old--or a forgetful adult.

*sigh* Priorities...

Adam Porter (alphapapa) wrote :

Oops, haha, wrong bug, sorry. :/

T. Dalbo (cooltd825) wrote :

4.7.4 fixed the issue for me. Can anyone confirm this?

Saurav (sauravzone1) wrote :

In reply to comment #18, the issue is still present in Kubuntu 11.10 (amd64) with KDE SC 4.7.4.

this is also present in kubuntu-11.10-desktop-i386
On Mon, Jan 9, 2012 at 5:56 PM, Saurav <email address hidden> wrote:

> In reply to comment #18, the issue is still present in Kubuntu 11.10
> (amd64) with KDE SC 4.7.4.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/713198
>
> Title:
> Power button delay dialog in kde 4.6+
>
> Status in Unofficial Package Updates for Kubuntu:
> New
> Status in Ubuntu:
> Confirmed
>
> Bug description:
> I am using kubuntu backports version of kde 4.6.
>
> since I updated to kde 4.6RC the power button has a delay of 1minute
> until the shutdown dialog shows in the screen.
>
> I configured power management to show the shutdown dialog when I press
> the power button.
>
> I guess it is related to power devil, since it should be managing
> power button events, in that case my version is:
>
> libpowerdevilcore0: 4:4.6.0a-0ubuntu2~maverick1~ppa1
>
> Reproducible always, I haven't seen any other log in the system that
> seemed related to it, just ask for anything needed.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kubuntu-ppa/+bug/713198/+subscriptions
>

--
Alok Singh Mahor
http://alokmahor.co.cc
Join the next generation of computing, Open Source and Linux/GNU!!

Saurav (sauravzone1) wrote :

Fixed in KDE SC 4.8.0.

elbowz (elbowz) wrote :

mhhh...
For me the fix is only lasted some days with kde 4.8.

Now power button and also lid closed events are not intercepted from kde power manager.
Same problem on two PC with Kubuntu 11.10, with 32bit and 64bit.

Acpid works good, also beacause i use a workaround /etc/acpi/events/powerbtn:
event=button[ /]power
#action=/etc/acpi/powerbtn.sh
action=/sbin/poweroff

Anyone can confirm or help?

thanks!

elbowz (elbowz) wrote :

Latest update: 4:4.8.0b-0ubuntu1~oneiric1~ppa3 0
From Kubuntu backports solved all (again)...

I had the same issue with Kubuntu 11.10 which seems to be caused by /etc/acpi/powerbtn.sh being missing.

I reinstalled "acpid" and powerbtn.sh was created.

This seems to have cured the problem.

Correction - reinstalling "acpid" does create the missing file, but approx 20sec delay/freeze after pressing the power button is still present following a reboot.

Using Kubuntu 11.10 with KDE 4.7.4

Can confirm that the power dialog pops instantly for subsequent presses of the power button in a session.

Rohan Garg (rohangarg) wrote :

Thanks for taking the time to report this bug. 11.10 reached EOL on May 9, 2013.
Please see this document for currently supported Kubuntu releases:
https://wiki.kubuntu.org/Releases

Unfortunately this means that there will be no more bugfixes for 11.10. It is also recommended that you upgrade, if you have not already.

Please feel free to report any other bugs you may find, and thanks for your understanding.

Changed in kubuntu-ppa:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.