Copy text from email adds HTML tags to clipboard

Bug #707135 reported by Klaus Layer on 2011-01-24
100
This bug affects 20 people
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Medium
Kubuntu PPA
Undecided
Unassigned
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdepim

As describe in https://bugs.kde.org/show_bug.cgi?id=259468 there is a bug in kmail which leads to copying HTML text from kmail. This bug is also visible in kubuntu 10.04 since KDE 4.4.5 was distributed as a bug fix. According to https://bugs.kde.org/show_bug.cgi?id=259468 SVN commit 1215050 by cgiboudeaux: fixes the issue upstream. Please include this fix in kubuntu to fix this annoying bug. Copy/paste text from emails is something users are doing daily and this bug requires to reedit each time you do a copy/paste. Thanks.

http://websvn.kde.org/?view=rev&revision=1215050

ockels (ockels) wrote :

Confirmed here on Kubuntu 10.04LTS. Kmail version 1.13.5 Development Platform 4.4.5 (KDE 4.4.5). Please fix this very annoying bug.

Matus Medo (matus-medo) wrote :

I hoped that this will be solved in KDE 4.6.0 but it persisted. Oh my...

Klaus Layer (klaus-layer) wrote :

Could the ubuntu kdepim package maintainers please comment on this.

Klaus Layer (klaus-layer) wrote :

According to https://bugs.kde.org/show_bug.cgi?id=259468 the bug was fixed upstream in 4.4.10.

Changed in kdepim (Ubuntu):
status: New → Confirmed
Leon Maurer (leon-n-maurer) wrote :

I've still got this bug in the 4.6.1 packages that were released today; it looks like Kontact is version 4.4.9 and not 4.4.10.

Leon Maurer (leon-n-maurer) wrote :

Is there any plan to release Kontact 4.4.10? It looks like that's the cure.

David Nemeskey (nemeskeyd) wrote :

As far as I understood, 4.4.10 should have been part of 4.6.1. Even if it is not (perhaps because it contains untested features, I don't know), please at least please release the patch that fixes this bug. Thanks.

Leon Maurer (leon-n-maurer) wrote :

Anyone listening out there? Are there any plans to get Kontact 4.4.10 out to 10.10 users, or must we wait another month+ for 11.04 (which looks to have 4.4.10)? What's another month when you've already been waiting 3?!?

Changed in kdepim:
importance: Unknown → Medium
status: Unknown → Fix Released
John Cottier (j-cottier) wrote :

I waste time due to this bug every day at work. But I have just found a kind of work around. If you 'forward' or 'reply' to the email that you want to copy from, and then copy from that forward/reply window, then it does not have the html formatting on :-)

Rafal-maj-it (rafal-maj-it) wrote :

For the love of baby Jesus fix this bug, it's destroying e-mail productivity.

Ganton (ganton) wrote :

> For the love of baby Jesus fix this bug, it's destroying e-mail productivity.
Today I updated my system and this bug hit me when replying emails, several times, please, fix it :-(

> I waste time due to this bug every day at work. But I have just found a kind of work around. If you 'forward' or 'reply' to the email
> that you want to copy from, and then copy from that forward/reply window, then it does not have the html formatting on :-)
I found that, also, if you click with the right button of the mouse on the email and choose the option to "edit" the message, you can there also copy the text without the dreaded html tags.

Harald Sitter (apachelogger) wrote :

Fixed in 11.04.

Changed in kdepim (Ubuntu):
status: Confirmed → Fix Released

Is there a possibility for a KDE SC 4.6.3 (where this bug is fixed) release in Kubuntu-PPA?
Considering https://bugs.launchpad.net/ubuntu/+source/linux/+bug/760131 I'm guessing a lot of people (me included) won't upgrade to Natty until this is fixed.

karaluh (karaluh) wrote :

Another workaround is to paste with middle mouse button.

Mark (mark-wege) wrote :

Will it be fixed for Maverick too? As far as I can see it, I will not be able to upgrade to Natty so soon because of some unfixed ACPI-bugs affecting my system.

Mark Fraser (launchpad-mfraz) wrote :

Had an update this morning to Kubuntu 10.10 that installed kdempim 4.4.9-0ubuntu0.1 and it seems to have fixed this bug.

Klaus Layer (klaus-layer) wrote :

Hi Harald,

this annoying bug is still visible in kubuntu 10.04 LTS release. Please fix this bug. It was not in the initial release but introduced later with the upgrade to the "bug fixing" release KDE 4.4.5.

Thanks for your help.

Changed in kdepim (Ubuntu):
status: Fix Released → Confirmed
Leon Maurer (leon-n-maurer) wrote :

Looks like this is fixed in 11.04, which finally includes KMail 1.13.6. About time.

Mark (mark-wege) wrote :

Any chance, the packages will be made available for Maverick? Natty still does not work for me, so I can not upgrade.

Malte S. Stretz (mss) on 2011-05-24
Changed in kubuntu-ppa:
status: New → Confirmed
Changed in kdepim (Ubuntu):
status: Confirmed → Fix Released
Theresa (theresa) wrote :

Yes, please make this available for 10.10 (Maverick) as well. It's annoying, and I can't update to Natty (11.04) at the moment, so PLEASE make this available for Maverick as well!!!

Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Kubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Kubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect 707135

and any other logs that are relevant for this particular issue.

Changed in kubuntu-ppa:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.