Packaging (dependency) problems with 4.6.0 RC1 on AMD64 in ppa:kubuntu-ppa/beta

Bug #694053 reported by Chris Samuel on 2010-12-24
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned

Bug Description

Looking at trying to upgrade to 4.6.0 RC1 from 4.6.0 beta 2 on Kubuntu 10.10 AMD64, but aptitude wants to uninstall several hundred packages due to problematic dependencies:

The following packages have unmet dependencies:
  libqapt-runtime: Depends: libpolkit-qt-1-1 which is a virtual package.
  polkit-kde-1: Depends: libpolkit-qt-1-1 which is a virtual package.
  kdelibs5-plugins: Depends: libpolkit-qt-1-1 which is a virtual package.
  libgpgme++2: Depends: libgpg-error0 (>= 1.10) but 1.6-1ubuntu2 is installed.

$ apt-cache policy libpolkit-qt-1-1
libpolkit-qt-1-1:
  Installed: (none)
  Candidate: (none)
  Version table:

$ apt-cache policy libgpg-error0
libgpg-error0:
  Installed: 1.6-1ubuntu2
  Candidate: 1.6-1ubuntu2
  Version table:
 *** 1.6-1ubuntu2 0
        500 http://mirror.internode.on.net/pub/ubuntu/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status

To resolve this it wants to remove the following 250 packages:

open: 594; closed: 288; defer: 575; conflict: 711

The following actions will resolve these dependencies:

       Remove the following packages:
1) adept
2) akregator
3) amor
4) apturl-kde
5) ark
6) blogilo
7) bluedevil
8) bomber
9) bovo
10) cantor
11) cantor-backend-kalgebra
12) cervisia
13) cvsservice
14) desktop-effects-kde
15) digikam
16) digikam-dbg
17) digikam-doc
18) dolphin
19) dragonplayer
20) gdebi-kde
21) granatier
22) gwenview
23) install-package
24) jockey-kde
25) jovie
26) juk
27) k3b
28) kaddressbook
29) kaffeine
30) kalarm
31) kalgebra
32) kalzium
33) kanagram
34) kapman
35) kapptemplate
36) kate
37) katomic
38) kbattleship
39) kblackbox
40) kblocks
41) kbluetooth
42) kbounce
43) kbreakout
44) kbruch
45) kbugbuster
46) kcachegrind
47) kcalc
48) kcaldav1
49) kcharselect
50) kcolorchooser
51) kde-core
52) kde-window-manager
53) kdeaccessibility
54) kdeadmin
55) kdeartwork
56) kdebase-apps
57) kdebase-bin
58) kdebase-runtime
59) kdebase-runtime-dbg
60) kdebase-workspace
61) kdebase-workspace-bin
62) kdebase-workspace-dbg
63) kdeedu
64) kdegames
65) kdegraphics
66) kdelibs5
67) kdelibs5-plugins
68) kdemultimedia
69) kdemultimedia-kio-plugins
70) kdenetwork
71) kdenlive
72) kdepasswd
73) kdepim
74) kdepim-dbg
75) kdepim-dbg-kde4
76) kdepim-groupware
77) kdepim-kresources
78) kdepim-runtime
79) kdepim-strigi-plugins
80) kdepim-wizards
81) kdepimlibs-dbg
82) kdepimlibs5
83) kdepimlibs5-dev
84) kdeplasma-addons
85) kdeplasma-addons-dbg
86) kdesdk
87) kdesdk-dolphin-plugins
88) kdesdk-kio-plugins
89) kdesdk-misc
90) kdesudo
91) kdetoys
92) kdeutils
93) kdewebdev
94) kdf
95) kdiamond
96) kdm
97) kfax
98) kfilereplace
99) kfind
100) kfloppy
101) kfourinline
102) kgeography
103) kget
104) kgoldrunner
105) kgpg
106) kgrab
107) kgrubeditor
108) khangman
109) khelpcenter4
110) kig
111) kigo
112) killbots
113) kimagemapeditor
114) kinfocenter
115) kipi-plugins
116) kiriki
117) kiten
118) kjots
119) kjumpingcube
120) klettres
121) klickety
122) klines
123) klinkstatus
124) klipper
125) kmag
126) kmahjongg
127) kmail
128) kmines
129) kmix
130) kmousetool
131) kmouth
132) kmplayer
133) kmplayer-base
134) kmplot
135) kmtrace
136) knetwalk
137) knetworkconf
138) knm-runtime
139) knode
140) knotes
141) kolf
142) kollision
143) kolourpaint4
144) kommander
145) kompare
146) konqueror
147) konqueror-nsplugins
148) konqueror-plugin-microformat
149) konquest
150) konsole
151) konsolekalendar
152) kontact
153) konversation
154) kopete
155) korganizer
156) kpackage
157) kpackagekit
158) kpartloader
159) kpat
160) kppp
161) krdc
162) kremotecontrol
163) kreversi
164) krfb
165) kruler
166) ksame
167) kscd
168) kscreensaver
169) kscreensaver-xsavers
170) kscreensaver-xsavers-extra
171) kscreensaver-xsavers-webcollage
172) kshisen
173) kshutdown
174) ksirk
175) ksnapshot
176) kspaceduel
177) ksquares
178) kstars
179) ksudoku
180) ksysguard
181) ksystemlog
182) kteatime
183) ktimer
184) ktimetracker
185) ktnef
186) ktorrent
187) ktouch
188) ktron
189) ktuberling
190) kturtle
191) kubrick
192) kubuntu-debug-installer
193) kubuntu-desktop
194) kubuntu-firefox-installer
195) kubuntu-konqueror-shortcuts
196) kubuntu-notification-helper
197) kuiviewer
198) kuser
199) kvkbd
200) kvpnc
201) kwalletmanager
202) kweather
203) kwordquiz
204) kwrite
205) language-selector-qt
206) libgpgme++2
207) libkdepim4
208) libkleo4
209) libkopete4
210) libmessagelist4
211) libqapt-runtime
212) libqgpgme1
213) lokalize
214) lskat
215) marble
216) network-manager-pptp-kde
217) okteta
218) okular
219) openoffice.org-kde
220) palapeli
221) parley
222) plasma-dataengines-workspace
223) plasma-desktop
224) plasma-netbook
225) plasma-runners-addons
226) plasma-scriptengine-superkaramba
227) plasma-wallpaper-weather
228) plasma-wallpapers-addons
229) plasma-widget-kimpanel
230) plasma-widget-lancelot
231) plasma-widget-networkmanagement
232) plasma-widgets-addons
233) plasma-widgets-workspace
234) polkit-kde-1
235) qapt-batch
236) quassel
237) rekonq
238) rocs
239) showfoto
240) skanlite
241) software-properties-kde
242) step
243) strigi-applet
244) sweeper
245) systemsettings
246) ubufox
247) umbrello
248) update-manager-kde
249) update-notifier-kde
250) xul-ext-ubufox

It then wants to leave the following dependencies unresolved:

251) apport-kde recommends kubuntu-notification-helper
252) konversation-data recommends konversation (>= 1.3.1-1ubuntu3)
253) ktorrent-data recommends ktorrent (>= 4.0.3-0ubuntu1)
254) kubuntu-desktop recommends apturl-kde
255) kubuntu-desktop recommends kubuntu-firefox-installer
256) kubuntu-desktop recommends kubuntu-notification-helper
257) digikam-doc recommends digikam
258) kdenlive-data recommends kdenlive
259) kvpnc-data recommends kvpnc (>= 0.9.6a-2)
260) firefox recommends ubufox
261) wine1.2 recommends gnome-exe-thumbnailer | kdebase-runtime
262) jovie recommends kmouth
263) kscreensaver recommends kscreensaver-xsavers (= 4:4.5.90-0ubuntu1~maver
264) konqueror recommends konqueror-nsplugins (= 4:4.5.90-0ubuntu1~maverick1
265) dolphin recommends kfind
266) kdebase-runtime recommends kubuntu-debug-installer
267) plasma-scriptengines recommends plasma-scriptengine-superkaramba
268) plasma-netbook recommends kdebase-workspace
269) plasma-desktop recommends kdebase-workspace
270) kdebase-workspace-bin recommends polkit-kde-1
271) cantor recommends cantor-backend-kalgebra
272) okular-extra-backends recommends okular
273) libkio5 recommends kdelibs5-plugins (= 4:4.5.90-0ubuntu1~maverick1~ppa1
274) libkhtml5 recommends kdelibs5-plugins (= 4:4.5.90-0ubuntu1~maverick1~pp
275) kontact recommends kmail
276) kontact recommends kaddressbook
277) kontact recommends korganizer
278) kdepim-kresources recommends korganizer
279) kdepim-groupware recommends kdepim-wizards
280) digikam recommends kipi-plugins
281) showfoto recommends kipi-plugins
282) libkcal2b recommends kaddressbook (>= 4:3.5.10)

garthecho (garth-johnson) wrote :

Exact same here on standard 32 bit. Except, without thinking, I blindly and stupidly allowed it to remove all those packages and am now sitting without a KDE desktop.

Murz (murznn) wrote :

Same problem on Kubuntu amd64.
I try to remove all kde and install again, but have the same error.

Murz (murznn) wrote :

I solve the problem for me with manually install this package from natty. Howto:
- Download the deb from here https://launchpad.net/ubuntu/natty/amd64/libpolkit-qt-1-1/0.99.0-0ubuntu2
do "dpkg -i <filename>"
do aptitude install kubuntu-desktop

garthecho (garth-johnson) wrote :

Thanks a lot Murz! Installing the 32 bit version of 'libpolkit-qt' also worked for me on i386.

Chris Samuel (chris-csamuel) wrote :

That deb fixes one issue and I guess should go into the PPA, but it still leaves the other problem with libpgp-error resulting in the system wanting to remove kdepim (which I can't let it do!):

The following packages have unmet dependencies:
  libgpgme++2: Depends: libgpg-error0 (>= 1.10) but 1.6-1ubuntu2 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:
1) kaddressbook
2) kdenetwork
3) kdepim
4) kdepim-dbg
5) kdepim-dbg-kde4
6) kdepimlibs-dbg
7) kdepimlibs5
8) kdepimlibs5-dev
9) kget
10) kmail
11) ktnef
12) libgpgme++2
13) libkleo4
14) libqgpgme1

      Leave the following dependencies unresolved:
15) kubuntu-desktop recommends kaddressbook
16) kubuntu-desktop recommends kmail
17) kontact recommends kmail
18) kontact recommends kaddressbook
19) libkcal2b recommends kaddressbook (>= 4:3.5.10)

Accept this solution? [Y/n/q/?]

Chris Samuel (chris-csamuel) wrote :

OK, to fix that I had to grab both libgpg-error0 and libgpg-error-dev AMD64 packages from Natty:

http://launchpadlibrarian.net/60100747/libgpg-error0_1.10-0ubuntu2_amd64.deb
http://launchpadlibrarian.net/60100746/libgpg-error-dev_1.10-0ubuntu2_amd64.deb

Not sure whether it's best for them to get rolled into the PPA or for the packages to be rebuilt against the 10.10 versions.

Pak (paolo-tezza) wrote :

For me it's also impossible to install kdm, kubuntu-desktop and many more due to missing or broken dependencies

tianyong (tianyong) wrote :

Hi Murz, thanks a lot, i got kde back with a new look

Jan Schnackenberg (yehaa) wrote :

Thank's a lot Murz. That tip with the libpolkit-qt-1-1 deb was exactly what I needed.

Whoever can do this: Please add this library to the experimental/beta/whatever repositories where they are desperately needed. :)

Pak (paolo-tezza) wrote :

Thanks Murz...my KDE come back now :)

Ukyoi (ukyoi) wrote :

Same here. I remembered exactly that when I tried to update to KDE 4.5.3, I've encountered this problem and today it happened again. Now I can only use Gnome.

Philip Muškovac (yofel) wrote :

The beta ppa was updated, can you try again?

tianyong (tianyong) wrote :

it seems ok now, thanks a ton

Chris Samuel (chris-csamuel) wrote :

Looking good to me too, I reset the 3 packages I had upgraded and it's looking like it'll upgrade OK now.

Happy Newtonmas all! :-)

Philip Muškovac (yofel) wrote :

Closing this bug then, thanks for reporting this.

Changed in kubuntu-ppa:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers