Unofficial Package Updates for Kubuntu

Klipper shortcut and usage

Reported by Duarte Rocha on 2010-08-11
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned

Bug Description

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid

~$ kde4-config --version
Qt: 4.7.0
Plataforma de Desenvolvimento KDE: 4.5.00 (KDE 4.5.0)
kde4-config: 1.0

The default shortcut (Ctrl+Alt+V) doesn't work. Even if you change the combination keys through:

System Settings -> Global Shortcuts -> Klipper

If I try to configure it through the klipper configure option, on the shortcuts there is no option to the "show klipper menu".

Also when you click on a item from klipper list, the list doesn't disappear, is this a new feature? Can I disable it?

I have klipper configured to store 100 entries, if I select a entry from the klipper -> more -> entry , the entry is selected and the klipper menu disappear.

regards.

Sel Goona (alieneye) wrote :

Same problems here since update to KDE 4.5.0.

Default shortcut dont work anymore, and the drop down menu dont close, until I click again on the systray Klipper icon.

You can reconfigure the the shortcut combination via the 'global hotkeys' part of system settings.

CTRL-ALT-V doesn't work, even though it is listed there for me, however.
I have KDE4.5 release packages from the Kubuntu PPA.

sebas's comment on http://dot.kde.org/2010/08/10/kde-releases-development-platform-applications-and-plasma-workspaces-450#new suggests it's a dbus / qt issue but I've no idea if that is right.

Sel Goona (alieneye) wrote :

https://bugs.kde.org/show_bug.cgi?id=247460

> A workaround is to use right mouse to open the menu, which seems to work for me.

Duarte Rocha (duarte-rocha) wrote :

If you select "System tray Configuration" -> "Entries"

Change the klipper value to "none" (or some other value then Ctrl+Alt+V) then save, and than go back there and do the same, but put the default "Ctrl+Alt+V", it will show a conflict warning, and if you accept it, the shortcut will work again.

Though the shortcut works, when you select a entry from klipper, the "klipper windows" will not go away....

The only way klipper works as it should, is if you
"> A workaround is to use right mouse to open the menu, which seems to work for me. "

regards,

That creates a new shortcut to popup the main GUI for a system tray applet, which in this case is being configured to conflict with the global short cut (that's broken). So with this workaround, the Klipper menu doesn't appear at the mouse position, for instance.

As you say, not a work around :-/

molecule-eye (niburu1) wrote :

I'm having the same issue. In the meantime I've implemented Duarte's workaround.

Should be fixed with KDE SC 4.5.1, at least here it works ;)

Changed in kubuntu-ppa:
status: New → Fix Released

Not fixed here (massive KDE update last night from the PPA).
CTRL-ALT-V still does nothing, even though configured in the global shortcuts. I don't have it set in the system tray settings.

Duarte Rocha (duarte-rocha) wrote :

After upgrading to "KDE SC 4.5.1" the problem was fixed...for me.

Don't know about the "default shortcut", since I already had found a workaround for that. But now when selecting an entry from klipper, the window disappears =)

Even after the 2nd tranche of updates last night from the Kubuntu PPA, still no response to CTRL-ALT-V here.
Duarte, could you undo your work around and confirm that the default CTRL-ALT-V doesn't work, nor in fact does anything entered for 'Show Klipper Popup' in 'Global Keyboard Shortcuts, Klipper' ?

Duarte Rocha (duarte-rocha) wrote :

Indeed, the default shortcut only works if you define it under:

System tray configuration -> Entries

And redefine the same shortcut to nothing and then to the default Ctrl + Alt + V.

Otherwise, if defined under 'Global Keyboard Shortcuts, Klipper' it won't work.

regards,

Just confirming it's not fixed, cheers for checking.

Duarte Rocha (duarte-rocha) wrote :

Now we lost the "search" feature....

Before when one activated the klipper menu, and typed something it searched the list and narrow the options shown to the ones that matched the typed text....

Now it doesn't work either :'(

Can anyone else confirm this behavior?

regards,

Riskable (riskable) wrote :

I was able to get Klipper working via keyboard shortcut in KDE 4.5.1 by going into Settings->Shortcuts and Gestures->Global Keyboard Shortcuts and selecting Plasma Workspace. Under there is an option to set the global shortcut key for Klipper (System-Klipper-10). I set mine to my usual, ctr-shift-X.

However, the ability to have the Klipper menu popup at the mouse cursor position appears to have been removed in this version. I added the configuration item (PopupAtMousePosition=true) by hand to ~/.kde/share/config/klipperrc but it doesn't do anything. The Klipper menu still just pops up from the system tray which is annoying since I regularly work with dual monitors (have to move the mouse quite a screen distance to get there sometimes).

Riskable (#14) Worked for me, thanks!

Kubuntu 4.5.1, Kubuntu 10.10

ilia (ilia) wrote :

Workaround by Riskable (#14) is actually the same as the one by Duarte Rocha (#4), it just uses another GUI window for the same configuration. Try setting the shortcut the first way, then observe is through the second one and vice versa (make sure to re-start system settings before following #14).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.