kde-4.5 automatically creates lots of junk activities

Bug #616296 reported by Dennis Schridde on 2010-08-11
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned
kdelibs
Incomplete
Medium

Bug Description

Whenever I start kde-4.5, the activity selector will display lots of junk activities. The names of these range from "Start" (my regular search&execute activity is also named "Start") to "unnamed". These activities usually seem to be newspaper-activities.
When I delete them, they will reappear upon next start of KDE.
Such unwanted activities will also still appear after deleting .kde/share/config/plasma*. (I am atm not exactly sure whether the activities appearing then are the exact same ones.)

Dennis Schridde (devurandom) wrote :

plasma-desktop just exited in a possibly unrelated crash. After starting it again from the commandline, I get even more activities, all also called "Start". They all seem to be empty newspaper activities. The "unnamed" activity mentioned earlier is a search&exec one. One of the "Start" thingies seemed to be a duplicate of my real "News" newspaper activity.

It is a bit difficult to measure the exact configuration of each activity, because apparently the activity selector is easily confused by switching between them. The first time I tried to display the activities in a row, it worked fine and they were shown on the desktop. Now, upon clicking them in the selector, the desktop will show the empty newspaper for *all* of my activities, even for those which were correct.

This is using kde-4.5 from kubuntu-ppa/backports.

Dennis Schridde (devurandom) wrote :

I managed to get some more information after a reboot:
* "Start" - Newspaper - showing the plasmoids of my original "News" activity, but all unconfigured
* "unnamed" - S&E in default configuration (konqueror, kmail, systemsettings, dolphin)
* "Start" - empty newspaper
* "Start" - empty newspaper
* "Start" - S&E as I configured it
* "Start" - empty newspaper
* "Start" - S&E in default configuration
* "News" - newspaper as I configured it - broken layout, especially for Facebook plasmoid (the website is displayed outside of the plasmoid, in a small square)
* "Start" - empty newspaper

The order these activities appear in seems to be randomised on every start, and some activities labelled "Start" seem to be added upon every start of KDE.

Dennis Schridde (devurandom) wrote :

It seems that producing a plasma-desktop crash or removing activities will create more activities on the next start of KDE. (Maybe some recovery mechanism running wild?)

Currently I have mostly "unnamed" and empty activities, a few "Start" newspaper activities. My original "Start" S&E activity, however, is entirely gone.

Changed in kdelibs:
status: Unknown → New
Perran Trevan (perrantrevan) wrote :

I have a similar problem.

I have 4 virtual desktops (just normal Desktop activities) with a different activity (widgets, wallpaper) each.

When I open the activity manager there are at least 10 random extra activities. If I delete them manually they reappear on next login.

This can't be good for system resources...

Changed in kdelibs:
status: New → Confirmed
Changed in kdelibs:
status: Confirmed → Invalid
H.i.M (hir-i-mogul-gmail) wrote :

Same here.

Kubuntu 10.04 + ppa

Changed in kdelibs:
importance: Unknown → Medium
Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Kubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Kubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect 616296

and any other logs that are relevant for this particular issue.

Changed in kdelibs:
status: Invalid → Incomplete
Changed in kubuntu-ppa:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.