Qt 4.7.0 breaks QX11EmbedWidget

Bug #614699 reported by Malte S. Stretz on 2010-08-07
130
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned
qt4-x11 (Ubuntu)
Medium
Unassigned

Bug Description

Qt 4.7.0 has a bug which breaks embedding of X11 windows. See <http://bugreports.qt.nokia.com/browse/QTBUG-10809> and the mess it causes in KDE <https://bugs.kde.org/show_bug.cgi?id=241509>. This will be fixed in Qt 4.7.1, but maybe the fix could be backported?

Origaman (mail-benno-dielmann) wrote :

Please fix this because it renders plasma-netbook virtually unusable. The panel is flickering constantly and it's very hard to close windows because if the panel is activated, one of these little empty windows (see KDE bug report) always gets focus so that if you click the close button of maximized windows (almost all are maximized in plasma-netbook), plasma crashes.

Changed in kubuntu-ppa:
status: New → Confirmed

A fix from qt's git repository (change 9a1b0695277a3864b42d082095962f8742cdcf04)

A Qt version with the above fix applied is now available on my PPA:

https://launchpad.net/~thilo.ginkel/+archive/qt4.7-bugfix

Salva Ferrer (salva-ferrer) wrote :

Thilo's version worked for me.

Thank you!

Malte S. Stretz (mss) wrote :

Nice, this also fixes the broken embedding of rdesktop in krdc.

Blackpaw (blackpaw) wrote :

Thanks, worked for me too. Still seeing corruption in the system tray menu though.

schnebeck (thorsten-schnebeck) wrote :

@#5 Does fullscreen krdc-rdp works for you?
Here embedding works but fullscreen is still brocken. Not sure if this is still a Qt oder a krdc bug.

Malte S. Stretz (mss) wrote :

@schnebeck: Sorry, got no time the next two weeks to test it. Please file a bug at bko.

Alf Gaida (agaida) wrote :

The solution for this can be found at:

https://bugs.kde.org/show_bug.cgi?id=241509

Alvin (alvind) wrote :

Thilo, the packages in your ppa fixed krdc behaviour for me, but today there were updates in the kubuntu-backports repository that broke it again.

tlu (thomas-ludwig-gmx) wrote :

Yep, I can confirm what Alvin wrote.

Do we know which specific package causes the problem, or is it more than one? I know there are a large number of packages as part of qt4-x11 that Thilo has in the PPA.

-- Sent from my Palm Pre
On Aug 18, 2010 9:26, tlu &lt;<email address hidden>&gt; wrote:

Yep, I can confirm what Alvin wrote.

--

Qt 4.7.0 breaks QX11EmbedWidget

https://bugs.launchpad.net/bugs/614699

You received this bug notification because you are a direct subscriber

of the bug.

Rocco (rocco) wrote :

Replacing libqtgui4 with same package from Thilo-Alexander, makes at least krdc behave.

This is a very annoying bug; I see it in multiple apps that I run at startup.

I hope the updated Qt gets in soon, or a lot of people in the Maverick beta will be thinking KDE is regressing (when in fact it is becoming super-polished in every other way).

I can confirm what Rocco says: I installed Thilo-Alexander's libqtgui4_4.7.0~beta2-0ubuntu3~lucid1~ppa5_amd64 package (only) and the bug disappeared.

affects: ubuntu → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: patch
Trent Leonard (zanophol) wrote :

I can confirm the above reported behavior of this bug existing when I upgraded to KDE 4.5 via the launchpad ppa. Then I added the "fix" ppa, and this solved the issue. However, after some updates to the kubuntu backports ppa, this behavior has now returned.

Alf Gaida (agaida) wrote :

I've run into the same problem. So i build a new ppa, witch is not affected by minor updates. If you use it, you must look for possible updates by yourself.

https://launchpad.net/~info-g-com/+archive/qt4.7beta-gc

Jonathan Riddell (jr) on 2010-08-24
tags: added: kubuntu
Changed in qt4-x11 (Ubuntu):
milestone: none → ubuntu-10.10-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.7.0~beta2-0ubuntu6

---------------
qt4-x11 (4:4.7.0~beta2-0ubuntu6) maverick; urgency=low

  * Add kubuntu_16_qx11embed.diff to fix QX11Embed widgets, fix from
    qt's git repository (change
    9a1b0695277a3864b42d082095962f8742cdcf04), Closes LP: #614699
 -- Jonathan Riddell <email address hidden> Tue, 24 Aug 2010 13:34:47 +0100

Changed in qt4-x11 (Ubuntu):
status: Triaged → Fix Released
tlu (thomas-ludwig-gmx) wrote :

Will this fix be backported to Lucid?

Antonio (antonio-merker) wrote :

I'd like to know the same thing...

Felix Geyer (debfx) wrote :

Fixed in qt4-x11 4:4.7.0~beta2-0ubuntu3~lucid1~ppa6.

Changed in kubuntu-ppa:
status: Confirmed → Fix Released
Blackpaw (blackpaw) wrote :

Avoid installing Alf's repository, it doesn't fix the problem and its making it impossible to upgrade to the Maverick fix (qt4-x11 (4:4.7.0~beta2-0ubuntu6) without uninstalling KDE first,

Alf Gaida (agaida) wrote :

It may be, i'm not perfect. Only one question - how can you install a fix in lucid if the lucid package starts to build in 4 hours?

dovshap (dovshap) wrote :

I can confirm that the version from the kubuntu-ppa, fixes the issue with krdc.
Thank You

Alf Gaida (agaida) wrote :

@23: There is an easy way to get back to the official kubuntu-backports - use dpkg instead of apt-get. I suggest this way:

* delete my repository from the list
* sudo apt-get update
* dpkg-query --list '*qt*' | grep 4:4.7.0-beta2-gc01 | awk '{print $2}' > downgrade.qt
* mkdir qtdown && cd qtdown
* aptitude download $(cat downgrade.qt) -t lucid
* sudo dpkg -i *.deb

Because dpkg take no care of dependecies use this suggestion with care.

Waleed Hamra (w-hamra1987) wrote :

Alf, i used your repository as well, a simpler solution i found was this:
*delete your repository
* sudo apt-get update (or aptitude)
*apt-cache policy libqtcore4
*check the highest version in the version table available. at the moment of writing the post, this is 4:4.7.0~beta2-0ubuntu3~lucid1~ppa6
*order aptitude to install it using:
sudo aptitude install libqtcore4=4:4.7.0~beta2-0ubuntu3~lucid1~ppa6

aptitude will complain of dependencies, and suggest downgrading all packages from your repo, accept the solution.
if anyone finds any mistake/error/problem with this method, please tell me.

Blackpaw (blackpaw) wrote :

Thanks Alf, but I ended up doing it the hard way :) took a record of the packages apt removed and reinstalled them. I do appreciate the work you put into creating the repo.

Alf Gaida (agaida) wrote :

I only reapplied the patch. Unfortunally the patch lacks of one line of code :( Normaly i build my packages for Arch so i see no problem to remove and reapply packages. Sorry for this. With pacman it is pacman -Rd mypackage && pacman -S officialpackage.

Waleed Hamra (w-hamra1987) wrote :

i can confirm that the latest updates in backport, fixed the bug. thank you for everyone who worked on this :)

Blackpaw (blackpaw) wrote :

Yes, I've upgraded a Maverick install and a Lucid + KDE 4.5 Install, both are fixed now and look so much better.

Yes, the upgrade did work, the small windows are nowhere to be seen. Somehow, however, I was wondering whether I am the only one to experience the following quirks after this upgrade:

- as the attached screenshot shows, when I quit applications it's weird that they leave an empty line that is not replaced by one of the remaining applications - is this the intended behavior? Does anyone get that?
- some applications, like Choqok and Skype, are always misaligned;
- last application in the group (in this case Kopete) often shows its name on top of the icon of the first application (in this case, the Printer Applet);
- the pop-up widget hosting all the hidden icons shouldn't be that wide (it reaches the rightmost limit), but as long as the longest name (in this case, KOrganizer Reminder Daemon) - am I correct in thinking so?

Before the upgrade, if Skype and Choqok were set to hidden and I tried to click on the white triangle in the system tray, the pop-up widget appeared for a moment to disappear straight after that, making it impossible to access hidden icons (unless visibility was changed). Moreover, I remember reading in this bug* that non-native applications like Skype triggered this bug. So looking at their misalignment now, does that mean this still has something to do with the present bug?

Please, let me know if you need further details, or if I should open a new bug. Thanks.

* https://bugs.kde.org/show_bug.cgi?id=241509

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.