Kontact unusable after upgrade to 4.5 beta 2

Bug #593305 reported by Jan Schnackenberg on 2010-06-13
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned

Bug Description

After upgrading to 4.5 beta 2 kontact is now unusable.

First it was missing libraries:

jan@pc:~$ kontact
kontact: error while loading shared libraries: libkontactinterface.so.4: cannot open shared object file: No such file or directory

installed libkontactinterface4

jan@pc:~$ kontact
kontact: error while loading shared libraries: libakonadi-contact.so.4: cannot open shared object file: No such file or directory

installed libakonadi-contact4

jan@pc:~$ kontact
kontact(9468)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "Kontact/Plugin" not found
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/jan/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
kontact(9468)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/kcm_kontact.so" does not offer a qt_plugin_instance function.
kontact(9468)/kdecore (KLibrary) kde3Factory: The library "/usr/lib/kde4/kcm_kontact.so" does not offer an "init_kcm_kontact" function.
kontact(9468)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/kcm_kontact.so" does not offer a qt_plugin_instance function.
kontact(9468)/kdecore (KLibrary) kde3Factory: The library "/usr/lib/kde4/kcm_kontact.so" does not offer an "init_kcm_kontact" function.
kontact(9468)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:

The Kontact-window came up but was completely empty. The configuration-dialog showed that Kontact does not recognise any modules (akregator, mail, addressbook).

Opening aptitude and inspecting the dependencies of kontact I saw that there are two packages of all of them. Same version-number. I had to deactivate the "backports" repository and do an dist-upgrade again for kontact to start working again.

to me it says:
Could not start process for imaps.
and doesn't reach checking mail for example

Leon Maurer (leon-n-maurer) wrote :

I'm having a similar problem in the release of 4.5 -- how did you install libkontactinterface4?

apt-file says that libkontactinterface.so.4 is in the package 'kdepimlibs5', but when I look at the files in that package (dpkg -L kdepimlibs5), I don't see it there (in fact, the package is pretty much empty).

Gernot Pansy (notz) wrote :

have the same problem, solved it by installing missing dependencies:

sudo apt-get install libkontactinterface4 libakonadi-contact4

rtjmay (rtjmay) wrote :

I can verify the same issue running Akregator stand-alone after upgrading to KDE SC 4.5.

Re-installing did not fix the dependency issue, but installing libkontactinterface4 and libakonadi-contact4 did.

Yann Nave (yannux-onbebop) wrote :

Same as rtjmay.

rekcuFniarB (retratserif) wrote :

Found out at http://kubuntu.ru/node/6724#comment-60383 that instaling libakonadi-contact4 and libkontactinterface4 packages fixes it.

Changed in kubuntu-ppa:
status: New → Triaged
Rohan Garg (rohangarg) wrote :

Hi
Can you reproduce the issue with the latest PIM beta 3 packages?

Dennis Schridde (devurandom) wrote :

Should be easy to figure out, just look whether kontact depends on packages providing libkontactinterface.so.4 and libakonadi-contact.so.4, i.e. libkontactinterface4 and libakonadi-contact4. If not, the bug is still reproducible.

Jan Schnackenberg (yehaa) wrote :

I could mark both libkontactinterface4 and libakonadi-contact4 as "Automatic" in aptitude without them being removed. Is that enough for "not reproducing"?.

reagle (joseph.reagle) wrote :

Just installed KMail 4:4.4.8-0ubuntu1~lucid1~ppa1 and problem still there.

I would like to confirm that the problem is still there, I just installed kontact_4%3a4.4.8-0ubuntu1~lucid1~ppa1_i386.deb and need to install libkontactinterface4 and libakonadi-contact4 manually.

Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Kubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Kubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect 593305

and any other logs that are relevant for this particular issue.

Changed in kubuntu-ppa:
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Kubuntu PPA because there has been no activity for 60 days.]

Changed in kubuntu-ppa:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers