system-config-printer-kde missing error

Bug #591980 reported by terry b on 2010-06-10
232
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Medium
Unassigned
kdeadmin (Ubuntu)
Medium
Unassigned

Bug Description

Just upgraded from 4.4.4 on 10.04 and received the following error.

Configure local and remote Printers

The service 'Printer Configuration' does not provide an interface 'KCModule' with keyword 'system-config-printer-kde/system-config-printer-kde.py' The factory does not support creating components of the specified type.

terry b (tbohaning-gmail) wrote :

Just realized that I may not have been clear enough.

In System Settings/ Printer Configuration is where I see this error.

Ralph Janke (txwikinger) wrote :

Thanks for submitting this issue and helping to make Kubuntu better!

I have tried to reproduce this problem and have not been able to do so.

Could you please provide a list of installed kubuntu packages. How did you upgrade? Could you please provide the logs from the upgrade in /var/log/

Thanks again for your support of Kubuntu!

Changed in kubuntu-ppa:
status: New → Incomplete
Mark Fraser (launchpad-mfraz) wrote :

I'm seeing this too. I upgraded by doing apt-get update and then apt-get upgrade.

terry b (tbohaning-gmail) wrote :

The upgrade was accomplished using synaptic after adding the PPA.

I've attached the dpkg.log file. If that is not what you want then please advise.

Is there a good way to generate the list that you have requested?? Sorry not sure how to approach this.

Ralph Janke (txwikinger) wrote :

both logs show that KDE 4.5 beta2 was upgraded, not KDE 4.4.4. In 4.4.4, I could not reproduce this problem, however it does occur in 4.4.85.

Changed in kubuntu-ppa:
status: Incomplete → Triaged
importance: Undecided → Medium
Chris Samuel (chris-csamuel) wrote :

The error shown is misleading, the reason that the factory is reporting an error is because it is trying to load a Python module that isn't packaged in Ubuntu. :-(

The real error is (I believe)

systemsettings(22750)/python (plugin): Failed to import module
Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 64, in <module>
    import cupsutils.ppds
ImportError: No module named cupsutils.ppds
systemsettings(22750)/python (plugin): Failed to import module
systemsettings(22750)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore

On Debian systems the cupsutils.ppds module is provided by the python-cupsutils package:

python-cupsutils:
  Installed: (none)
  Candidate: 1.0.0-4lenny1
  Version table:
     1.0.0-4lenny1 0
        700 http://http.us.debian.org lenny/main Packages

But this module doesn't appear to be packaged for Ubuntu:

root@quad:~# apt-cache search python-cupsutils
root@quad:~#
root@quad:~# apt-file search cupsutils
root@quad:~#

Good luck with that!

terry b (tbohaning-gmail) wrote :

Still broken in Beta 2

terry b (tbohaning-gmail) wrote :

My error. Still broken in RC 1.

Mark Fraser (launchpad-mfraz) wrote :

Upgraded to KDE 4.5 RC1 and I'm also still getting this error. I agree with Chris Samuel in comment 6, if you type:
python /usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py

Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 64, in <module>
    import cupsutils.ppds
ImportError: No module named cupsutils.ppds

Could the package be installed from debian for now?

Mark Fraser (launchpad-mfraz) wrote :

Downloading and installing python-cupsutils from http://packages.debian.org/sid/python-cupsutils removes the error, but I am only shown:
Basic Server Settings
 Show printers shared by other systems
 Share published printers connected to this system
 Allow remote administration
 Allow users to cancel any job (not just their own)
 Save debugging information for troubleshooting

Aristofeles (aristoteles) wrote :

Hey everybody. I have just met the same problem as you did. I find RC very nice but problem with my wifi printer can be annoying. So i unmarked beta repository and installed kde printer setup from 4.4.5 release. And it is working like it should have with 4.5rc1. I hope in final release you will deal with it.

Constantin Berzan (exit3219) wrote :

This problem affects me too.

I think https://bugs.launchpad.net/ubuntu/+source/kdeadmin/+bug/602343 is a duplicate.

Chris Samuel (chris-csamuel) wrote :

Bug #602343 is indeed a duplicate of this, but cannot be marked as such as there are 2 other bugs marked as duplicates of it and Launchpad doesn't seem to be clever enough to handle that situation and requires someone with more privileges to change them to point here first.

Philip Muškovac (yofel) on 2010-07-23
Changed in kdeadmin (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: maverick
Jonathan Riddell (jr) wrote :

Fixed in 4.4.92-0ubuntu2
  * Remove 01_system_config_printer_kde_cupsutils.diff, it's only
    relevant for Debian not Ubuntu

Changed in kdeadmin (Ubuntu):
status: Triaged → Fix Released
lnxusr (bjwest) wrote :

No, not fixed in 4.4.92-0ubuntu2. I have system-config-printer-kde 4.4.92-0ubuntu2 installed and problem is still there.

Philip Muškovac (yofel) wrote :

@Inxusr: no, this bug is fixed, I get a different crash on maverick now, see bug 611677

lnxusr (bjwest) wrote :

@Philip: You're right. I get the output in bug 611677 now. I may have had two terminals open last night and looked at the wrong one after upgrading, or it may have been something that cleaned out when I shut down last night and powered up this morning, but I did see the same errors.

Chris Samuel (chris-csamuel) wrote :

Has this only been pushed out as a 32-bit package ? I'm still seeing 4:4.4.92-0ubuntu1~lucid1~ppa1 as the version available on my AMD64 box.

root@quad:~# apt-cache policy system-config-printer-kde
system-config-printer-kde:
  Installed: 4:4.4.92-0ubuntu1~lucid1~ppa1
  Candidate: 4:4.4.92-0ubuntu1~lucid1~ppa1
  Version table:
 *** 4:4.4.92-0ubuntu1~lucid1~ppa1 0
        500 http://ppa.launchpad.net/kubuntu-ppa/beta/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     4:4.4.5-0ubuntu1~lucid1~ppa1 0
        500 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/ lucid/main Packages
     4:4.4.2-0ubuntu1 0
        500 http://mirror.linux.org.au/ubuntu/ lucid/main Packages
        500 http://mirrors.uwa.edu.au/ubuntu/ lucid/main Packages

Ky6uk (ky6uk) wrote :

Kubuntu PPA have Triaged status.

John Webster (civil-bigpond) wrote :

I still have this problem with a fresh installation of the Daily Build LiveCD (32-bit) dated 2 August 2010.

Ky6uk (ky6uk) wrote :

@John Webster Can bug 611677

I also have that issue :(

Still a problem in lucid or maverick with KDE 4.5.1 ?

Changed in kubuntu-ppa:
status: Triaged → Fix Released
glepore70 (greg-rhobard) wrote :

Fixed for me with 4.5.1

terry b (tbohaning-gmail) wrote :

fixed for me as well. Lucid w/ 4.5.1.

The last update that I had indicated the 4.5.1 has not been released for Maverick yet.

Good ;) Thanks

glepore70 (greg-rhobard) wrote :

I'm using Maverick and kde backports, so I got KDE 4.5.1 today and the bug is fixed. Actually, it got fixed a week or two ago.

Chris Samuel (chris-csamuel) wrote :

Looks like it's fixed for me with Lucid (10.04) and KDE 4.5.1 from the Kubuntu PPA.

Thanks everyone!

I've just updated to KDE 4.7 from kubuntu backports ppa and got this bug.
The tail of .xsession-errors file is attached.

Alex Sidorenko (asid) wrote :

Yes, I have the same problem on Kubuntu/Natty after upgrading to 4.7 from ppa

Alex

Philip Muškovac (yofel) wrote :

@Stanislav and @Alex: this bug is closed, can you please file a new bug for your 4.7 issues. (Which I can confirm btw.)

@Philip
Sure.
I've filed bug 818207.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers