Conflict when updating due to a clash between libpam-kwallet and pam-kwallet and between libdiscovercommon and libmuon

Bug #1536528 reported by Joan Maspons on 2016-01-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Medium
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Els paquets nous següents s'instal·laran:
  appstream{a} fonts-noto-hinted{a} ieee-data{a} kde-config-screenlocker{a} kde-style-qtcurve-qt4{a} kde-style-qtcurve-qt5{a}
  libappstream2{a} libdiscovercommon{ab} libkf5calendarevents5{a} libkscreenlocker5{a} libkwineffects7{a} libkwinglutils7{a}
  libkwinxrenderutils7{a} libpam-kwallet4{ab} libpam-kwallet5{ab} libqt5xcbqpa5{a} libqtcurve-utils2{a} linux-headers-4.2.0-25{a}
  linux-headers-4.2.0-25-generic{a} linux-image-4.2.0-25-generic{a} linux-image-extra-4.2.0-25-generic{a} oxygen5-icon-theme
  plasma-discover plasma-discover-common{a} plasma-discover-updater plasma-look-and-feel-org-kde-breezedark-desktop{a}
Els paquets següents se suprimiran:
  muon-common{u}
Els paquets següents s'actualitzaran:
  about-distro baloo baloo-kf5 bind9-host bluedevil breeze breeze-cursor-theme breeze-icon-theme dnsutils ecryptfs-utils
  frameworkintegration jags kactivities kate kate5-data kde-cli-tools kde-cli-tools-data kde-config-gtk-style kde-config-gtk-style-preview
  kde-config-sddm kde-config-touchpad kde-l10n-ca kde-style-breeze kde-style-breeze-qt4 kde-style-oxygen-qt5 kde-touchpad kded5
  kdelibs-bin kdelibs5-data kdelibs5-plugins kdeplasma-addons-data kdoctools kdoctools5 kgamma5 khelpcenter khelpcenter4 khotkeys
  khotkeys-data kimageformat-plugins kinfocenter kinit kio kmenuedit kpackagelauncherqml kpackagetool5 kross kscreen ksnapshot ksshaskpass
  ksysguard ksysguard-data ksysguardd ktexteditor-data ktexteditor-katepart kubuntu-desktop kwayland-data kwin kwin-addons kwin-common
  kwin-data kwin-style-breeze kwin-x11 kwrited libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56
  libavresample-ffmpeg2 libavutil-ffmpeg54 libbind9-90 libdlrestrictions1 libdns-export100 libdns100 libecryptfs1 libepoxy0
  libgsettings-qt1 libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecorations2-5v5 libkdecorations2private5v5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4
  libkf5activities5 libkf5activitiesexperimentalstats1 libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5 libkf5baloo5
  libkf5balooengine5 libkf5bluezqt-data libkf5bluezqt6 libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5
  libkf5declarative-data libkf5declarative5 libkf5dnssd-data libkf5dnssd5 libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5
  libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5
  libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5
  libkf5jsembed-data libkf5jsembed5 libkf5kcmutils-data libkf5kcmutils5 libkf5kdelibs4support-data libkf5kdelibs4support5
  libkf5kdelibs4support5-bin libkf5khtml-bin libkf5khtml-data libkf5khtml5 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5krosscore5 libkf5krossui5 libkf5modemmanagerqt6 libkf5networkmanagerqt6 libkf5newstuff-data libkf5newstuff5
  libkf5notifications-data libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5
  libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5people-data libkf5people5 libkf5peoplebackend5 libkf5peoplewidgets5
  libkf5plasma5 libkf5plasmaquick5 libkf5plotting5 libkf5pty-data libkf5pty5 libkf5quickaddons5 libkf5runner5 libkf5screen6
  libkf5service-bin libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
  libkf5style5 libkf5su-bin libkf5su-data libkf5su5 libkf5sysguard-bin libkf5sysguard-data libkf5sysguard5 libkf5sysguard5-data
  libkf5texteditor5 libkf5texteditor5-libjs-underscore libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5
  libkf5unitconversion-data libkf5unitconversion5 libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5
  libkf5waylandserver5 libkf5webkit5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
  libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkf5xmlrpcclient-data libkf5xmlrpcclient5 libkfile4 libkfontinst5 libkfontinstui5
  libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4
  libkparts4 libkprintutils4 libkpty4 libkrosscore4 libkrossui4 libksgrd7 libksignalplotter7 libktexteditor4 libkunitconversion4
  libkwalletbackend5-5 libkwin4-effect-builtins1 libkworkspace5-5 liblwres90 liboxygenstyle5-5 liboxygenstyleconfig5-5
  libplasma-geolocation-interface5 libplasma3 libpostproc-ffmpeg53 libpowerdevilcore2 libpowerdevilui5 libprocesscore7 libprocessui7
  libqca-qt5-2 libqca-qt5-2-plugins libqgsttools-p1 libqt5clucene5 libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5designer5
  libqt5designercomponents5 libqt5gui5 libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediaquick-p5
  libqt5multimediawidgets5 libqt5network5 libqt5opengl5 libqt5organizer5 libqt5positioning5 libqt5printsupport5 libqt5qml-graphicaleffects
  libqt5qml5 libqt5quick5 libqt5quickwidgets5 libqt5script5 libqt5sensors5 libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite libqt5svg5
  libqt5test5 libqt5webkit5 libqt5widgets5 libqt5x11extras5 libqt5xml5 libqt5xmlpatterns5 libsolid4 libswresample-ffmpeg1
  libswscale-ffmpeg3 libtaskmanager5 libthreadweaver4 libweather-ion7 libxml2 libxml2-dev libxml2-utils linux-generic
  linux-headers-generic linux-image-generic linux-libc-dev milou muon-discover muon-notifier muon-updater oxygen-icon-theme oxygen-sounds
  plasma-dataengines-addons plasma-desktop plasma-desktop-data plasma-framework plasma-mediacenter plasma-nm plasma-pa
  plasma-runners-addons plasma-wallpapers-addons plasma-widget-kimpanel plasma-widgets-addons plasma-workspace polkit-kde-agent-1
  powerdevil powerdevil-data python-libxml2 python3-dbus.mainloop.pyqt5 python3-pyqt5 qdbus-qt5 qml-module-org-kde-activities
  qml-module-org-kde-bluezqt qml-module-org-kde-draganddrop qml-module-org-kde-extensionplugin qml-module-org-kde-kcoreaddons
  qml-module-org-kde-kio qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem
  qml-module-org-kde-people qml-module-org-kde-runnermodel qml-module-org-kde-solid qml-module-qtgraphicaleffects qml-module-qtmultimedia
  qml-module-qtquick-controls qml-module-qtquick-controls-styles-breeze qml-module-qtquick-dialogs qml-module-qtquick-layouts
  qml-module-qtquick-localstorage qml-module-qtquick-privatewidgets qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebkit
  qt5-image-formats-plugins qtdeclarative5-kf5declarative qtdeclarative5-kf5solid qtdeclarative5-localstorage-plugin
  qtdeclarative5-qtquick2-plugin qttools5-dev-tools sddm sddm-theme-breeze sonnet-plugins systemsettings user-manager
Els paquets següents són RECOMANATS però NO s'instal·laran:
  kwayland-integration qtwayland5
370 paquets a actualitzar, 26 a instal·lar, 1 a suprimir i 0 a no actualitzar.
Es necessita obtenir 276 MB d'arxius. Després del desempaquetat s'utilitzaran 324 MB.
No s'han trobat les dependències del paquets següents:
 libpam-kwallet4 : Entra en conflicte: pam-kwallet4 (< 4:5.5) però el 4:5.4.3-0ubuntu1~ubuntu15.10~ppa1 està instal·lat.
                   Trenca: pam-kwallet4 (< 4:5.5) però el 4:5.4.3-0ubuntu1~ubuntu15.10~ppa1 està instal·lat.
 libpam-kwallet5 : Entra en conflicte: pam-kwallet5 (< 4:5.5) però el 4:5.4.3-0ubuntu1~ubuntu15.10~ppa1 està instal·lat.
                   Trenca: pam-kwallet5 (< 4:5.5) però el 4:5.4.3-0ubuntu1~ubuntu15.10~ppa1 està instal·lat.
 libdiscovercommon : Trenca: libmuon (< 4:5.5.3a) però el 4:5.4.3-0ubuntu1~ubuntu15.10~ppa1 està instal·lat.
Les accions següents resoldran les dependències:

     Suprimeix els següents paquets:
1) libmuon
2) muon

     Mantén la versió actual dels següents paquets:
3) libpam-kwallet4 [No instal·lat]
4) libpam-kwallet5 [No instal·lat]

     Leave the following dependencies unresolved:
5) kubuntu-desktop recomana libpam-kwallet4
6) kubuntu-desktop recomana libpam-kwallet5
7) plasma-desktop recomana libpam-kwallet4
8) plasma-desktop recomana libpam-kwallet5

Accepteu la solució? [Y/n/q/?]

Joan Maspons (jmaspons) on 2016-01-21
description: updated
Joan Maspons (jmaspons) on 2016-01-21
summary: - Conflict when updating due to a conflict between libpam-kwallet and pam-
+ Conflict when updating due to a clash between libpam-kwallet and pam-
kwallet
summary: Conflict when updating due to a clash between libpam-kwallet and pam-
- kwallet
+ kwallet and between libdiscovercommon and libmuon
tags: added: wily
tags: added: kubuntu ppa
Joan Maspons (jmaspons) wrote :

installing the packages before the upgrade fix the problem:

sudo apt-get install libpam-kwallet4 libpam-kwallet5 libdiscovercommon
sudo apt-get dist-upgrade

I will miss muon update notifications :´(
With this update you must choose between muon or muon-discover, muon-updater and muon-notifier. It's no longer possible to install all packages together.

Dependencies should be fixed.

Philip Muškovac (yofel) wrote :

We'll look into the kwallet dep issues, those shouldn't happen. For muon, see bug 1536519

Changed in kubuntu-ppa:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers