kde4 apps can not launch khelpcenter

Bug #1378746 reported by Jonathan Riddell on 2014-10-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Scarlett Gately Moore

Bug Description

kde4 apps can not launch khelpcenter
Help -> Konsole Handbook -> "Could not find service khelpcenter"

Jonathan Riddell (jr) on 2014-10-08
tags: added: plasma5
Scarlett Gately Moore (sgclark) wrote :

khelpcenter is not installed by default. Is this on purpose? Anyway to fix, apt-get install khelpcenter

Jonathan Riddell (jr) wrote :

It is, but it's the plasma 5 khelpcenter that's installed. But there's no reason why they can't be compatible

Scarlett Gately Moore (sgclark) wrote :

Ahh yes I see now. Investigating.

Jonathan Riddell (jr) wrote :

the binary is the same so it must be looking for a kservice file to tell is what binary to run
what happens if you keep khelpcentre from plasma5 installed but also have
 /usr/share/kde4/services/khelpcenter.desktop
from khelpcenter4 ?

Scarlett Gately Moore (sgclark) wrote :

Ok so I applied a version of https://git.reviewboard.kde.org/r/119589/ to achieve this and khelpcenter does indeed start with it. But, the documentation is not found for most apps. So I am inquiring if there is a better way to achieve found documents than
kbuildsyscoca4 which is in kdelibs5... that defeats the purpose of kf5.

Changed in kubuntu-ppa:
status: New → In Progress
assignee: nobody → Scarlett Clark (sgclark)
Scarlett Gately Moore (sgclark) wrote :

ok so for kde4 apps kdelibs5 is of course needed duh. anyway kbuildsycoca4 was no help here. Our problem is
The only docs found by khelpcenter is in /usr/share/doc/HTML/en but kde4 apps install docs into /usr/share/doc/kde/HTML/en
The question is is this upstream or did we change the paths somewhere?

Scarlett Gately Moore (sgclark) wrote :

good news is the launching of khelpcenter RR has been given a ship it. Still need to fix the path problem.

Scarlett Gately Moore (sgclark) wrote :

Filed bug https://bugs.kde.org/show_bug.cgi?id=340508 upstream. Lets see what they say.

Scarlett Gately Moore (sgclark) wrote :

packaging issue that is being fixed per package. Rules file was pointing documentation to the wrong location.

Changed in kubuntu-ppa:
status: In Progress → Fix Committed
Changed in kubuntu-ppa:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.