.desktop files can not start apps with kdesu

Bug #1375786 reported by Harald Sitter on 2014-09-30
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
High
Unassigned
synaptic (Ubuntu)
Medium
Unassigned
Utopic
Undecided
Unassigned

Bug Description

-install synaptic
-start via kickoff

KDEInit could not launch '':
Could not open library '/usr/lib/x86_64-linux-gnu/libkdeinit5_'.
Cannot load library /usr/lib/x86_64-linux-gnu/libkdeinit5_: (/usr/lib/x86_64-linux-gnu/libkdeinit5_.so: cannot open shared object file: No such file or directory)

(upstream bug somewhere in kio, notmart has a review for it pending somewhere)

Related branches

Jonathan Riddell (jr) on 2014-10-08
summary: - kdesu more broken
+ .desktop files can not start apps with kdesu
Rohan Garg (rohangarg) wrote :

Synaptic should probably start using pkexec instead of kdesu like it does for the regular gtk frontend.

Leszek Lesner (leszek-lesner) wrote :

In general pkexec can be used for every application. Would make the password prompt more consistent also.

Rohan Garg (rohangarg) wrote :

Already being discussed upstream on KDE Frameworks Devel, there are going to be focus stealing issues as mentioned on [1] if we use pkexec everywhere. So this needs to be solved in pkexec first before moving forward.

[1] https://mail.kde.org/pipermail/kde-frameworks-devel/2014-November/020554.html

Harald Sitter (apachelogger) wrote :

The bigger issue is that neither DBUS_SESSION_BUS nor DISPLAY is forwarded through pkexec which prevents KUniqueApplications (and their KF5 counterpart one presumes) from starting as uniqueness is implemented through dbus and auto-starting a session dbus at least on X11 requires DISPLAY to be set (not that I know why).

Rohan Garg (rohangarg) wrote :

Patch for Synaptic

Chris J Arges (arges) wrote :

Rejected upload as it contains extra debian/patches/series file. Please fix this and reupload, thanks.

Adolfo Jayme (fitojb) on 2015-01-24
Changed in synaptic (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu Utopic):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

Please add the SRU header as mentioned on https://wiki.ubuntu.com/StableReleaseUpdates

Possible workaround :

sudo ln -s /usr/bin/kdesudo /usr/bin/kdesu

MaXo (mahmood-188) wrote :

had the same issue.

Bruno's workaround did the trick! Thanks!

tags: added: utopic
Changed in synaptic (Ubuntu Utopic):
status: Confirmed → Invalid
Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Kubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Kubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect 1375786

and any other logs that are relevant for this particular issue.

Changed in kubuntu-ppa:
status: Confirmed → Incomplete
Changed in synaptic (Ubuntu):
status: Fix Released → Incomplete
Changed in synaptic (Ubuntu Utopic):
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.