Unable to set locale after update

Bug #1327527 reported by Medor
84
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Fix Released
Undecided
Unassigned

Bug Description

After update localization in my kubuntu falled.

Can not add my language in System Settings/Locale

I get only error massege

You have the language with code 'uk' in your list of languages to use for translation but the localization files for it could not be found. The language has been removed from your configuration. If you want to add it again please install the localization files for it and add the language again.

Revision history for this message
Medor (bogkuz) wrote :

bogdan@bogdan-K7VT4APro:~$ sudo apt-get install --reinstall language-pack-uk-base
eading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libmozjs185-1.0 linux-headers-3.13.0-26 linux-headers-3.13.0-26-generic
  linux-image-3.13.0-26-generic linux-image-extra-3.13.0-26-generic
  linux-tools-3.13.0-26 linux-tools-3.13.0-26-generic lua-bitop lua-posix
  lua5.1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/2903 kB of archives.
After this operation, 0 B of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = "en",
 LC_ALL = (unset),
 LC_TIME = "en_UA.UTF-8",
 LC_MONETARY = "en_UA.UTF-8",
 LC_ADDRESS = "en_UA.UTF-8",
 LC_TELEPHONE = "en_UA.UTF-8",
 LC_NAME = "en_UA.UTF-8",
 LC_MEASUREMENT = "en_UA.UTF-8",
 LC_IDENTIFICATION = "en_UA.UTF-8",
 LC_NUMERIC = "en_UA.UTF-8",
 LC_PAPER = "en_UA.UTF-8",
 LANG = "en_UA.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 629114 files and directories currently installed.)
Preparing to unpack .../language-pack-uk-base_1%3a14.04+20140410_all.deb ...
Unpacking language-pack-uk-base (1:14.04+20140410) over (1:14.04+20140410) ...
Replaced by files in installed package language-pack-uk (1:14.04+20140522) ...
Setting up language-pack-uk-base (1:14.04+20140410) ...
Generating locales...
  uk_UA.UTF-8... done
Generation complete.
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
lokster (lokiisyourmaster) wrote :

As far as I can tell, the bug affects all languages.
So far, I have found that the language settings search for /usr/share/locale/[LOCALE]/entry.desktop to confirm that the language suport is installed for the selected [LOCALE].
However, only /usr/share/locale/en_US/entry.desktop exists. The rest of the entry.desktop files are located in /usr/share/locale/l10n/[LOCALE]/entry.desktop
Copying for example /usr/share/locale/l10n/bg/entry.desktop to /usr/share/locale/bg/entry.desktop makes the error message go away when I try to add bulgarian language, but KDE still uses en_US after restart.
I've tried also deleting ~/.kde/env/setlocale.sh but it does not change anything.

Revision history for this message
lokster (lokiisyourmaster) wrote :

Btw, installing/reinstalling various locale-related packages does not help.

Revision history for this message
Medor (bogkuz) wrote :

bogdan@bogdan-K7VT4APro:~$ sudo locale-gen uk_UA.UTF-8
Generating locales...
  uk_UA.UTF-8... done
Generation complete.

but in /usr/lib/locale/ exists only C.UTF-8 folder

Revision history for this message
Svetoslav Stefanov (svetlisashkov) wrote :

On my system there are more localization related files (incl. *.desktop file) in /usr/share/locale-kdelibs4/.

Changed in kubuntu-ppa:
status: New → Confirmed
Revision history for this message
Daniil Lukianov (rosenrotttt) wrote :

"You have the language with code 'ru' in your list of languages to use for translation but the localization files for it could not be found. The language has been removed from your configuration. If you want to add it again please install the localization files for it and add the language again."

All required packages are installed. However, I can not select any locale other than U.S. English.

Revision history for this message
Obsidian (grandobsidian) wrote :

I confirm that there is such a mistake.
"On my system there are more localization related files (incl. *.desktop file) in /usr/share/locale-kdelibs4/."

Revision history for this message
Svetoslav Stefanov (svetlisashkov) wrote :

For me it seems that the the problem is libkdecore5. After I've upgraded it, I've noticed that my programs menu has changed - from Bulgarian to English language. And after that the message "You have the language with code..." has started to appear every time I've tried to use Settings>System Settings>Locale>Languages.

Revision history for this message
Alex (baburka) wrote :

I confirm this bag on Kubuntu 14.04 32-bit KDE 4.13.1.
I cann't setting Ukrainian language in my system.
And I don't have problem on the 64-bit system jn the work.

Revision history for this message
Svetoslav Stefanov (svetlisashkov) wrote :

My system is 64-bit and the problem exists.

Revision history for this message
lokster (lokiisyourmaster) wrote :

Progress!!!
I have purged the kubuntu updates ppa with "sudo ppa-purge ppa:kubuntu-ppa/ppa", and the problem was gone - locales are installing without errors, and everything is back to normal.
It seems that the package "kde-l10n-bg" was causing the problem in my case - even with ppa:kubuntu-ppa/ppa enabled, if I downgrade only this package to the version from the official repositories the problem is gone after restart.

Revision history for this message
lokster (lokiisyourmaster) wrote :

Continuing from my previous post...
The difference between the working and the non-working kde-l10n-* package seems to be that the working has /usr/share/locale/[LOCALE] directory, and the non-working has /usr/share/locale-kdelibs4/[LOCALE] where [LOCALE] is my locale (in my case "bg").
The directories look identical and have the same *.mo files

Revision history for this message
Svetoslav Stefanov (svetlisashkov) wrote :

I can confirm that on my system downgrading kde-l10n-* package solves the problem.

Revision history for this message
Medor (bogkuz) wrote :

 downgrading kde-l10n-* package solves the problem.
thanks to lokster (lokiisyourmaster) :)
but my plasma widgets still not localized

Revision history for this message
otto06217 (otto-kesselgulasch) wrote :

Thanks,

but in my case the evil was https://launchpad.net/~kubuntu-ppa/+archive/experimental. Mea culpa.

sudo apt-get purge ppa:kubuntu-ppa/experimental leads to an unusable system because of uninstalling "some" essential packages.

A sudo apt-get install kubuntu-desktop leads to a working system again.

Let's logout. I'll be back soon I hope.

Revision history for this message
otto06217 (otto-kesselgulasch) wrote :

I'm back.

Revision history for this message
eugenez (eugene-zvyagintsev) wrote :

really want to get a fix :)

Revision history for this message
Ettore Atalan (atalanttore) wrote :

Same problem with german language on my system.

Revision history for this message
welrob (robvanderwel) wrote :

Same for Dutch language, please make a fix

Revision history for this message
Marco (marco-torri76) wrote :

same for italian language, how can I do??? please???

Revision history for this message
welrob (robvanderwel) wrote :

After the last update off kde-l10n-nl all the programs are in dutch again except the plasma widgets are stile in English.

Revision history for this message
welrob (robvanderwel) wrote :

after i click on the all to standard button all works fine so this is OK now

Changed in kubuntu-ppa:
status: Confirmed → Fix Released
Revision history for this message
Medor (bogkuz) wrote :

After update everything is OK

Revision history for this message
Philip Muškovac (yofel) wrote :

Removed the ubuntu task as this should've never been an issue in the archive

no longer affects: ubuntu
Revision history for this message
th4fhfu8qid6 (th4fhfu8qid6) wrote :

bug also exists in 12.04 x32 for CJK. Having language support completely and automatically removed is ot really helpful for daily work, though we are trying already hard, really hard...

Revision history for this message
Angelescu (titus0818) wrote :

I am affected, too. After upgrade to kde 4.14 from ppa:kubuntu-ppa/backports all sistem have no localization. I use romanian language, ro.
First, I edited /etc/environment where I add this line: LC_ALL="en_US.utf8"
After that, entire DE and his default apps are in romanian. The rest of app are still in english.
Here are the result of cmd. locale in netrunner 14, upgraded from the same ppa, which is not affected :
netrunerk@netrunerk-System-Product-Name:~$ locale
LANG=ro_RO.UTF-8
LANGUAGE=ro:en
LC_CTYPE="ro_RO.UTF-8"
LC_NUMERIC=ro_RO.UTF-8
LC_TIME=ro_RO.UTF-8
LC_COLLATE="ro_RO.UTF-8"
LC_MONETARY=ro_RO.UTF-8
LC_MESSAGES="ro_RO.UTF-8"
LC_PAPER=ro_RO.UTF-8
LC_NAME=ro_RO.UTF-8
LC_ADDRESS=ro_RO.UTF-8
LC_TELEPHONE=ro_RO.UTF-8
LC_MEASUREMENT=ro_RO.UTF-8
LC_IDENTIFICATION=ro_RO.UTF-8
LC_ALL=
here are the same cmd. in kubuntu 14.04:
k1404@windows9OEM:~$ locale
LANG=en_RO.UTF-8
LANGUAGE=en
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=en_US.utf8

how can edit something and where, for to have the result of cmd. locale, in Kubuntu like in Netrunner?
This will fix the problem without any downgrade.

Revision history for this message
Vlad Paul Paval (wladypauly) wrote :

I have the same problem on Kubuntu 14.04. Tried everything, from completely removing locales and locale related packages and config files to locale-gen , dpkg --reconfigure locales and so on. Nothing works, I cannot switch to RO locale. And the terminal gives me the error

perl: warning: Please check that your locale settings: are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory”

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers