rabbitmq image fails to build

Bug #1814233 reported by Martin André on 2019-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Critical
Unassigned

Bug Description

INFO:kolla.common.utils.rabbitmq:Error: Package: rabbitmq-server-3.7.11-1.el7.noarch (rabbitmq_rabbitmq-server)
INFO:kolla.common.utils.rabbitmq: Requires: erlang >= 20.3
INFO:kolla.common.utils.rabbitmq: Available: erlang-R16B-03.18.el7.x86_64 (epel)
INFO:kolla.common.utils.rabbitmq: erlang = R16B-03.18.el7
INFO:kolla.common.utils.rabbitmq: Available: erlang-19.3.6.4-1.el7.x86_64 (delorean-master-testing)
INFO:kolla.common.utils.rabbitmq: erlang = 19.3.6.4-1.el7

http://logs.openstack.org/64/634264/2/check/kolla-build-centos-source/802cdeb/logs/build/000_FAILED_rabbitmq.txt.gz

Reviewed: https://review.openstack.org/634365
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=cfbcf830f04604b3628e999acc78a45dcebd27c2
Submitter: Zuul
Branch: master

commit cfbcf830f04604b3628e999acc78a45dcebd27c2
Author: Jon Schlueter <email address hidden>
Date: Thu Jan 31 21:13:50 2019 -0500

    Pin rabbitmq-server to 3.7.10

    New version of rabbitmq-server in epel but not new enough version of
    erlang available in epel or delorean-trunk repos.

    Closes-Bug: #1814233
    Change-Id: Iac3cad17ff8279a2be66ffe1366d6844f999d66f

Changed in kolla:
status: Confirmed → Fix Released

Reviewed: https://review.openstack.org/634945
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=baa611e552319325e0eb1909ee14eb008e154ebd
Submitter: Zuul
Branch: master

commit baa611e552319325e0eb1909ee14eb008e154ebd
Author: Martin André <email address hidden>
Date: Tue Feb 5 15:28:10 2019 +0100

    Pin rabbitmq-server for ubuntu

    Ubuntu is also affected by the new rabbitmq server version mismatch
    with erlang. Pin it to last known working version until the packaging
    mess is fixed.

    Change-Id: I5e3ba7762f0990718e4180ffcd3db7722edc17b4
    Related-bug: #1814233

Mark Goddard (mgoddard) on 2019-03-29
Changed in kolla:
milestone: none → 8.0.0

This issue was fixed in the openstack/kolla 8.0.0.0rc1 release candidate.

Marcin Juszkiewicz (hrw) wrote :

Still present:

()[root@83c4f64a8d68 /]# yum install rabbitmq-server
Loaded plugins: fastestmirror, ovl, priorities
Loading mirror speeds from cached hostfile
8 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package rabbitmq-server.noarch 0:3.7.18-1.el7 will be installed
--> Processing Dependency: erlang >= 20.3 for package: rabbitmq-server-3.7.18-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: rabbitmq-server-3.7.18-1.el7.noarch (rabbitmq_rabbitmq-server)
           Requires: erlang >= 20.3
           Available: erlang-R16B-03.18.el7.x86_64 (epel)
               erlang = R16B-03.18.el7
           Available: erlang-19.3.6.4-1.el7.x86_64 (delorean-master-testing)
               erlang = 19.3.6.4-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
()[root@83c4f64a8d68 /]#

Mark Goddard (mgoddard) wrote :

Could you provide more info hrw? Are we seeing this in CI? Due to CentOS 7.7 release?

Mark Goddard (mgoddard) wrote :

I'd say it's probably a different bug.

Marcin Juszkiewicz (hrw) wrote :

The bug is "we have to pin rabbitmq-server to 3.7.10 due to dependencies of newer versions". And we fixed it by doing that pinning.

My comment should be read as "newer versions still depend on erlang 20.3+ :(".

Mark Goddard (mgoddard) wrote :

I see. Should we raise a bug for it then? "RabbitMQ is pinned to an old version on CentOS"?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers