tripleo ui image is failed and block the gate

Bug #1744215 reported by Jeffrey Zhang on 2018-01-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Medium
Unassigned
tripleo
High
Honza Pokorny

Bug Description

$ npm run build
> tripleo-ui@7.4.7 build /home/jeffrey/openstack/tripleo-ui
> webpack --env=prod --bail --progress

  0% compiling/home/jeffrey/openstack/tripleo-ui/node_modules/cheerio/lib/api/traversing.js:10
    return memo.concat(_.filter(elem.children, isTag));
                                     ^

TypeError: Cannot read property 'children' of undefined
    at /home/jeffrey/openstack/tripleo-ui/node_modules/cheerio/lib/api/traversing.js:10:38
    at /home/jeffrey/openstack/tripleo-ui/node_modules/lodash/lodash.js:935:11
    at /home/jeffrey/openstack/tripleo-ui/node_modules/lodash/lodash.js:4920:15
    at baseReduce (/home/jeffrey/openstack/tripleo-ui/node_modules/lodash/lodash.js:932:5)
    at Function.reduce (/home/jeffrey/openstack/tripleo-ui/node_modules/lodash/lodash.js:9698:14)
    at initialize.exports.find (/home/jeffrey/openstack/tripleo-ui/node_modules/cheerio/lib/api/traversing.js:9:17)
    at initialize.module.exports (/home/jeffrey/openstack/tripleo-ui/node_modules/cheerio/lib/cheerio.js:86:18)
    at new initialize (/home/jeffrey/openstack/tripleo-ui/node_modules/cheerio/lib/static.js:26:20)
    at initialize (/home/jeffrey/openstack/tripleo-ui/node_modules/cheerio/lib/static.js:23:14)
    at Object.parse (/home/jeffrey/openstack/tripleo-ui/node_modules/favicons/helpers-es5.js:193:32)
    at /home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:84:31
    at Object.async.forEachOf.async.eachOf (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:233:13)
    at createHTML (/home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:83:19)
    at /home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:122:24
    at /home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:718:13
    at async.forEachOf.async.eachOf (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:233:13)
    at _parallel (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:717:9)
    at Object.async.parallel (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:731:9)
    at createPlatform (/home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:117:19)
    at /home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:135:21
    at Object.async.forEachOf.async.eachOf (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:233:13)
    at createOffline (/home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:131:19)
    at create (/home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:178:90)
    at /home/jeffrey/openstack/tripleo-ui/node_modules/favicons/es5.js:184:20
    at fn (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:746:34)
    at /home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:1213:16
    at /home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:166:37
    at /home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:706:43
    at /home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:167:37
    at Immediate.<anonymous> (/home/jeffrey/openstack/tripleo-ui/node_modules/async/lib/async.js:1206:34)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! tripleo-ui@7.4.7 build: `webpack --env=prod --bail --progress`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the tripleo-ui@7.4.7 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/jeffrey/.npm/_logs/2018-01-19T06_45_25_684Z-debug.log

Tags: ui Edit Tag help
Changed in kolla:
importance: Undecided → Critical
summary: - triplo ui image is failed and block the gate
+ tripleo ui image is failed and block the gate
description: updated
description: updated
Julie Pichon (jpichon) on 2018-01-19
tags: added: ui
Jiri Tomasek (jtomasek) wrote :

Looking at http://tarballs.openstack.org/tripleo-ui/ tripleo-ui-latest.tar.gz matches tripleo-ui-7.4.7.tar.gz. How is tripleo-ui-latest updated? We have merged the changes which fix reported issue yesterday.

Changed in tripleo:
status: New → Triaged
importance: Undecided → Critical
milestone: none → queens-rc1
milestone: queens-rc1 → queens-3
Honza Pokorny (hpokorny) wrote :

I just found out that tripleo-ui-7.4.7.tar.gz was published on the day when we upgraded our upstream check/gate jobs to nodejs8. I'll keep looking.

Honza Pokorny (hpokorny) on 2018-01-20
Changed in tripleo:
assignee: nobody → Honza Pokorny (hpokorny)

Reviewed: https://review.openstack.org/535633
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=ec0950b20937c67d75b5bab712dd2b57d8be7af5
Submitter: Zuul
Branch: master

commit ec0950b20937c67d75b5bab712dd2b57d8be7af5
Author: Jeffrey Zhang <email address hidden>
Date: Fri Jan 19 14:53:01 2018 +0800

    Add tripleo-ui image to skipped image list

    There is some issue on tripleo-ui side, which block the kolla gate.
    Revert me when https://bugs.launchpad.net/tripleo/+bug/1744215 is
    fixed.

    Change-Id: I68867f0bbabad61d583761d54c35d1df15fb8698
    Related-Bug: #1744215

Changed in tripleo:
milestone: queens-3 → queens-rc1
Honza Pokorny (hpokorny) wrote :

The cause of the build failures was the fact that the tripleo-ui-latest.tar.gz file wasn't being updated on merges. This has now been fixed.

I see that tripleo-ui has been added to the skip list. Is there a way to run a test build to see if the above mentioned fix in fact resolves this bug?

Alex Schultz (alex-schultz) wrote :

Looks like https://review.openstack.org/#/c/539187 is the revert.

Changed in tripleo:
milestone: queens-rc1 → rocky-1
Changed in tripleo:
milestone: rocky-1 → rocky-2
Changed in tripleo:
milestone: rocky-2 → rocky-3
Honza Pokorny (hpokorny) wrote :

How can I verify that this has been fixed? What is the gate that the original report refers to?

Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → rocky-rc2
Alex Schultz (alex-schultz) wrote :

Dropping from critical as this is no longer affecting any gates. The revert is still pending over in Kolla

Changed in tripleo:
importance: Critical → High
milestone: rocky-rc2 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Honza Pokorny (hpokorny) on 2019-01-14
Changed in tripleo:
status: Triaged → Fix Released
Mark Goddard (mgoddard) wrote :

Do we need to do anything about this in kolla?

Michal Nasiadka (mnasiadka) wrote :

It's been in skipped images (https://github.com/openstack/kolla/blob/a911010054ef514cdc28aad71f0a6869a830dd87/kolla/image/build.py#L103) for over a year, I think we should decrease priority (not Critical).

Mark Goddard (mgoddard) wrote :

Not blocking gate - decreasing priority.

Changed in kolla:
importance: Critical → Medium
Mark Goddard (mgoddard) wrote :

Building the image for centos/source still fails for me.

tripleo-ui@10.3.0 build: `webpack --env=prod --bail --progress`

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers